Go Back   Club Lexus Forums > Lexus Model Forums > RX Models > RX - Second Generation
Sign in using an external account
Register Forgot Password?

My dashboard lights are on!

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-11-10, 08:53 PM   #1
mandyfig
Moderator
Trader Score: (0)
 
mandyfig's Avatar
 
Join Date: Apr 2007
Location: GA
Posts: 8,795
Default My dashboard lights are on!

Finally happened to me! My VSC, Trac Off, Brake and Tire Pressure (this one was blinking) lit up!

It was off and on. Happened 3x already. It would be on and then the next time it would not show.

What is this again?

Do I need to call in for a check up?

Battery's good (12.6V), charging is good (14.6+ V).
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
__________________
SC430 WGC-Ecru/RX330 Bamboo Pearl-Gray/IS350 Black Onyx-Gray
mandyfig is offline   Reply With Quote
Old 01-12-10, 08:50 AM   #2
Adamjeeps
Lead Lap
Trader Score: (0)
 
Adamjeeps's Avatar
 
Join Date: Jul 2009
Location: VA
Posts: 460
Default

Quote:
Originally Posted by mandyfig View Post
Finally happened to me! My VSC, Trac Off, Brake and Tire Pressure (this one was blinking) lit up!

It was off and on. Happened 3x already. It would be on and then the next time it would not show.

What is this again?

Do I need to call in for a check up?

Battery's good (12.6V), charging is good (14.6+ V).
Dealer replaced my brake light switch under warranty and fixed this problem a few months ago. It is a very common problem and you might be able to get them to fix it even if you are out of warranty since it is so common.
__________________
2007 RX 350 - Traded in for 2012 SRX
Adamjeeps is offline   Reply With Quote
Old 01-12-10, 09:01 AM   #3
visual
Rookie
Trader Score: (0)
 
Join Date: Aug 2009
Location: va
Posts: 51
Default

Most likely is a bad brake switch. This is very typical problem for the rx. The switch is right under the brake paddle. You can get it online for $17.
This happens to my wife car a couple times. I reset the car computer by remove the black battery terminal, and it has not come back for 3 months now.
visual is offline   Reply With Quote
Old 01-12-10, 01:14 PM   #4
RsSharKy
Rookie
Trader Score: (0)
 
Join Date: Feb 2009
Location: MD
Posts: 50
Default

i am not sure if this is the reason
but there is a TSB regarding "SOME VEHICLES MAY EXPERIENCE MULTIPLE WARNING LIGHTS ILLUMINATED."
http://www-odi.nhtsa.dot.gov/tsbs/ts...intVersion=YES
__________________
09 OB RX350 PBE w/ RX400h wanna be taillights
08 SP IS250 AWD
04 GTO <- kissed a tree then good bye...
RsSharKy is offline   Reply With Quote
Old 01-12-10, 08:45 PM   #5
mandyfig
Moderator
Trader Score: (0)
 
mandyfig's Avatar
 
Join Date: Apr 2007
Location: GA
Posts: 8,795
Default

Now this is sounding familiar, brake SW recall. I have to check the TSB's. Thanks. I will call my Service Advisor anyway and see if she will invite me to come in...I have the Platinum Extended Warranty.
__________________
SC430 WGC-Ecru/RX330 Bamboo Pearl-Gray/IS350 Black Onyx-Gray
mandyfig is offline   Reply With Quote
Old 01-12-10, 08:48 PM   #6
mandyfig
Moderator
Trader Score: (0)
 
mandyfig's Avatar
 
Join Date: Apr 2007
Location: GA
Posts: 8,795
Default

I will post a pic of the lights tomorrow. I seem to remember that this could be the battery or the alternator but I checked them both they seem to be OK. I cleaned up my battery terminal today, it had gunk. 1st time I have seen in a while, like 2 years.

So I had to re-set the windows.

I am not having luck re-setting the moonroof. How was that again?
__________________
SC430 WGC-Ecru/RX330 Bamboo Pearl-Gray/IS350 Black Onyx-Gray
mandyfig is offline   Reply With Quote
Old 01-14-10, 07:45 AM   #7
visual
Rookie
Trader Score: (0)
 
Join Date: Aug 2009
Location: va
Posts: 51
Default

Quote:
Originally Posted by mandyfig View Post
I will post a pic of the lights tomorrow. I seem to remember that this could be the battery or the alternator but I checked them both they seem to be OK. I cleaned up my battery terminal today, it had gunk. 1st time I have seen in a while, like 2 years.

So I had to re-set the windows.

I am not having luck re-setting the moonroof. How was that again?
Fully open and then close completely will reset the moonroof.
visual is offline   Reply With Quote
Old 01-15-10, 11:18 AM   #8
Kostyan
Pole Position
Trader Score: (0)
 
Join Date: Aug 2007
Location: MD
Posts: 282
Default

We're having the same problem with lights on the dash.

Can someone please point me to the entire list of things that need to be reset and how-to after disconnecting the battery?
__________________
2006 TL NAVI 6spd
2005 RX 330 AWD NAVI
Kostyan is offline   Reply With Quote
Old 01-15-10, 11:27 AM   #9
mandyfig
Moderator
Trader Score: (0)
 
mandyfig's Avatar
 
Join Date: Apr 2007
Location: GA
Posts: 8,795
Default

The brake sw recall invloves the AC light blinking plus other lights lighting up. It says a new junction box needs replaced.

Does not talk about the specific lights...
__________________
SC430 WGC-Ecru/RX330 Bamboo Pearl-Gray/IS350 Black Onyx-Gray
mandyfig is offline   Reply With Quote
Old 01-15-10, 11:28 AM   #10
mandyfig
Moderator
Trader Score: (0)
 
mandyfig's Avatar
 
Join Date: Apr 2007
Location: GA
Posts: 8,795
Default

My Service Advisor was on vacation and I sent her an email. We'll see what she says when she comes back regarding this issue.
__________________
SC430 WGC-Ecru/RX330 Bamboo Pearl-Gray/IS350 Black Onyx-Gray
mandyfig is offline   Reply With Quote
Old 01-15-10, 12:25 PM   #11
Kostyan
Pole Position
Trader Score: (0)
 
Join Date: Aug 2007
Location: MD
Posts: 282
Default

Quote:
Originally Posted by mandyfig View Post
My Service Advisor was on vacation and I sent her an email. We'll see what she says when she comes back regarding this issue.
What is a recall #, which model years does it affect, and what if vehicle is past bumper-to bumper wtty?
__________________
2006 TL NAVI 6spd
2005 RX 330 AWD NAVI
Kostyan is offline   Reply With Quote
Old 01-15-10, 02:58 PM   #12
mandyfig
Moderator
Trader Score: (0)
 
mandyfig's Avatar
 
Join Date: Apr 2007
Location: GA
Posts: 8,795
Default

There was a recall on the brake switch. This is not related to our situation.

There was a TSB for multiple lights turning on and the AC switch blinking. This TSB says a new junction Box must be installed in the engine bay. I am not sure if this is covered by the extended warranty that I have. The original TSB is only good for the regular warranty, 48 mos/50K miles.

I do not even know that the above is the source of the issue that we have.
__________________
SC430 WGC-Ecru/RX330 Bamboo Pearl-Gray/IS350 Black Onyx-Gray
mandyfig is offline   Reply With Quote
Old 01-22-10, 09:58 AM   #13
Kostyan
Pole Position
Trader Score: (0)
 
Join Date: Aug 2007
Location: MD
Posts: 282
Default

hey guys I am going to try to reset the ECU this weekend by unplugging the battery terminal, but afraid the car won't work right after that because I dont have any kind of instruction to reset the options. From the way you guys are describing it, it sounds pretty involved....can someone please point me to those instructions or perhaps can email them to me?
__________________
2006 TL NAVI 6spd
2005 RX 330 AWD NAVI
Kostyan is offline   Reply With Quote
Old 01-22-10, 02:04 PM   #14
mandyfig
Moderator
Trader Score: (0)
 
mandyfig's Avatar
 
Join Date: Apr 2007
Location: GA
Posts: 8,795
Default

Before you proceed with the ECU reset, I need to let you know what I have done. I had an appointment this week for this issue and had to cancel due to a conflict.

However, I put in my OBDII reader to determine if there is something in the system recorded to show the warning lights being lit. Result: Nada, nothing. It says, no recorded readings.

Re-setting the ECU will probably do nothing, but you can try. Are you going to remove the battery terminal to re-set the ECU?

Because I did this already and the lights still go ON, every now and then.

I will have to take it in to Lexus. And I will let you know.
__________________
SC430 WGC-Ecru/RX330 Bamboo Pearl-Gray/IS350 Black Onyx-Gray
mandyfig is offline   Reply With Quote
Old 01-23-10, 04:20 PM   #15
Kostyan
Pole Position
Trader Score: (0)
 
Join Date: Aug 2007
Location: MD
Posts: 282
Default

mandyfig, I was going to reset the ECU by unplugging the negative terminal from the battery for a few hrs

If its a stupid 17 dollar switch then its ok....I am worried about possible other causes which are mosre costly to repair...we're at 60k mi, past bumper to bumper wtty

i look fwd to the outcome of visit
__________________
2006 TL NAVI 6spd
2005 RX 330 AWD NAVI
Kostyan is offline   Reply With Quote
Old 01-23-10, 04:20 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
voltage problem. could there be a short or bad grounding? Do.Man LS400 15 02-10-12 07:10 PM
25 great Jeremy Clarkson quotes I8ABMR Car Chat 1 05-09-10 05:29 AM
Turbo Timer Wiring SC300 ICONYQ Performance & Maintenance 6 10-20-09 12:41 PM
Top 25 Quotes from Top Gear's Jeremy Clarkson felixsc300 Car Chat 18 05-24-09 03:50 PM
My RX300 wont start, Fuel problem Electrical problem? Davinci RX - First Generation 8 08-31-07 01:24 PM


Tags
05, 330, abs, c1223, c1249, code, dashboard, error, gx470, lexsus, lexus, lights, ljghts, my, on, rx, vsc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 06:29 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info