Go Back   Club Lexus Forums > Lexus Model Forums > RX Models > RX - Second Generation
Sign in using an external account
Register Forgot Password?

Lights come on while driving

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-01-09, 05:22 PM   #1
alsader
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2008
Location: IL
Posts: 3
Default Lights come on while driving

Hello,

I bought a 2005 RX330 a couple months ago. It now has 48,500 miles. The following happened 3 times while driving:

The ABS, Brake, and VSC lights come on solid and the Low Tire Pressure light blinks. Things go back to normal after I turn the engine off and start it again.

Dealer wants to see it first before they do anything about it. Problem is that every time it happened the dealer was closed. I live about an hour away and I’m not even sure I want to drive for one hour while these lights are on.

Reading some postings it seems like this was a known issue with the 2004 models (brake light switch). Has anyone seen this problem with a 2005 model?

Thanks,
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
alsader is offline   Reply With Quote
Old 01-01-09, 07:39 PM   #2
steve_m
Driver School Candidate
Trader Score: (0)
 
Join Date: Mar 2006
Location: CA
Posts: 5
Default

my '06 RX330 has the identical problem. First time to the dealer, they could not get any codes. Later in the day, the lites came on again, they took a look and pointed at a bald spot on the front right tire, and said "that's your problem!". I put four fresh tires on it, and the lites still come on perhaps once per day. As the dealer that's been working the problem is 45 minutes away, I'll need to find a time to drive it in while the lites are on again. thanks for your info re recent postings, I'll look that up...
steve_m is offline   Reply With Quote
Old 01-02-09, 05:00 AM   #3
triplecore
Lead Lap
Trader Score: (0)
 
Join Date: Jun 2006
Location: New England
Posts: 479
Default

Quote:
Originally Posted by alsader View Post
Hello,

I bought a 2005 RX330 a couple months ago. It now has 48,500 miles. The following happened 3 times while driving:

The ABS, Brake, and VSC lights come on solid and the Low Tire Pressure light blinks. Things go back to normal after I turn the engine off and start it again.

Dealer wants to see it first before they do anything about it. Problem is that every time it happened the dealer was closed. I live about an hour away and Iím not even sure I want to drive for one hour while these lights are on.

Reading some postings it seems like this was a known issue with the 2004 models (brake light switch). Has anyone seen this problem with a 2005 model?

Thanks,
I think it might have something to do with traction control. Because when I got mine stuck in a snow bank the same thing happened as the back wheel kept spinning. One the tow got it off the mound and I drove it for a while it went away. Have you tried resetting your tire pressure?

I'm guessing something is causing the unit to trip and its over heating which why I believe the unit malfunction with the indicator lights and hence it sporadic.
__________________
2010 RX350
triplecore is offline   Reply With Quote
Old 01-10-09, 08:44 AM   #4
alsader
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2008
Location: IL
Posts: 3
Default Update

Hi,

I took the care to the dealer today (8 days after the last time the lights showed up). They found a code in the computer. It was switch code C1249 which was the brake light switch. Same problem as it was in the 2004 model. The dealer replaced the switch and hopefully I won't see these lights again.
alsader is offline   Reply With Quote
Old 02-04-09, 02:17 PM   #5
clague
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2006
Location: OR
Posts: 6
Default

Quote:
Originally Posted by alsader View Post
Hi,

I took the care to the dealer today (8 days after the last time the lights showed up). They found a code in the computer. It was switch code C1249 which was the brake light switch. Same problem as it was in the 2004 model. The dealer replaced the switch and hopefully I won't see these lights again.
I had the same symptoms and the same diagnostic result from the ECU... code C1249 on my '06 RX330. The dealer replaced the stop switch assembly today under warranty, and no sign of the lights again as of yet.
clague is offline   Reply With Quote
Old 11-30-10, 06:26 PM   #6
Tajai7
Rookie
Trader Score: (0)
 
Join Date: Mar 2003
Location: Minnesota
Posts: 53
Default

For a couple weeks, my Check VSC, the Alert/Warning light (Red Triangle with Exclamation Point), ABS, and Brakes warning lights all would come on when starting my car up intermittently. If I turned my car immediately off and restarted, no lights would come on. Now these lights come on every time at start up.

I had the trouble codes scanned for my '06 IS250 AWD and it spit back two code: C1249 and C1223. C1249 is an open circuit in the stop light switch and C1223 is a ABS control fault error.

After reading several threads I had my buddy install a new stop light switch and reset the computer and no lights have come back on. I've started multiple times and have drove about 50 miles now and the lights have no returned! So if you get a c1249 and c1223 trouble code error on your Lexus, this is probably the solution. The only rip off is that I had to get the part from Lexus because I didn't want to wait to have it shipped from partsgeek.com (http://tinyurl.com/34len8a) and the $40 part became $83 through Lexus. I'm sure they probably would have charged $50 to diagnosis the issue and another $150 for labor...I'm pretty sure I came out way ahead in this situation. Hope this helps some you out there!

(search tags: Lexus Trouble Codes Errors C1249 C1223 Stop Light Switch Open Stop Light Circuit)
Tajai7 is offline   Reply With Quote
Old 12-30-10, 08:14 PM   #7
Montimar1
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2010
Location: AZ
Posts: 9
Default

Had the same problem on my 330/06 took to dealer today and they replaced Brake Lamp Switch
P/N 84340-47020 $75.00 Labor $68.00. Gave me a 2010 350 loaner, what a ride and difference. Wish it was a Christmas present!!!!!!!

Last edited by Montimar1; 12-30-10 at 08:15 PM.. Reason: wanted tto add "today"
Montimar1 is offline   Reply With Quote
Old 04-10-11, 11:25 PM   #8
hyiu
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2005
Location: NY
Posts: 29
Default

I have a 06 RX 330, and also have the same problem once in a while:
The VSC, brake, tire pressure and ABS will light up when driving.

traced back to the code C1249 also.

the guys checked the brake lights, saying sometimes if you have burned out bulbs, you might have the same pblm. Once that is checked out fine, he looked into the switch.

he did checked and said the part is 84340-35030.

There are other parts mentioned before, and he said its for other models, but he said at times, they are interchangeable.

Attached is a pic of my old part... its near the brake pedal.
Attached Images
 

Last edited by hyiu; 04-11-11 at 12:32 PM..
hyiu is offline   Reply With Quote
Old 04-15-11, 06:28 AM   #9
Pete60
Driver School Candidate
Trader Score: (0)
 
Join Date: Dec 2010
Location: Colorado
Posts: 9
Default Pete60

HeyU,

Thanks for the info, part # and Picture. This may be just what I need!

I want the 3 icon lights (check E, VSC and Traction) to go off and stay off

Pete
Pete60 is offline   Reply With Quote
Old 09-19-11, 06:31 AM   #10
srx
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2011
Location: Ontario
Posts: 3
Default

Hi. I have just removed the brake switch, opened it, cleaned the contacts inside (very simple switch) and installed it back. It's doable and not complicated, but one has to take an uncomfortable position to remove it. Installing back it's a bit easier. It may also take time, because every move you do to remove the switch is slow (lack of space). I followed this steps:
1.removed the spring to get access to the sensor.
2.using a 14 mm wrench loosened the nut a bit and then removed the switch by rotating it (you need to remember the position of the nut).
3.unplugged the cable as soon as I could get access to it. You do not want to damage any contacts by rotating the switch too much with the cable plugged in it.
4.Opened the sensor by unbending the 4 aluminum contact connecting the plastic part with the metal part of the switch. Inside I found a sort of oxide on the contacts. Apparently the switch remained on (because of the oxide) when it was supposed to be off.
5.Reinstalled the switch.
srx is offline   Reply With Quote
Old 09-19-11, 06:31 AM
 
 
 
 
Reply

Tags
05, 2004, abs, brake, c1249, code, driving, is300, lexus, light, lights, related, rx330, switch, vsc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 03:05 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info