Go Back   Club Lexus Forums > Lexus Model Forums > RX Models > RX - First Generation
Sign in using an external account
Register Forgot Password?

I have a bad gas mileage, how about yours ??

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-22-07, 09:46 AM   #1
bowen.chau
Rookie
Trader Score: (0)
 
Join Date: Jul 2007
Location: -
Posts: 82
Default I have a bad gas mileage, how about yours ??

I have just bought a 1999 Toyota Harrier in Hong Kong last week and noticed that I have a bad gas mileage on my Harrier. The computer shows it's average of 5.3 km/L ...

Anything that I can do to increase my gas mileage? I have just changed the engine oil, transmission oil and air filter.

Does fuel injection cleansing and spark plug change ... can improve the gas mileage? Many thanks.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
bowen.chau is offline   Reply With Quote
Old 07-22-07, 09:56 AM   #2
zombie
Lead Lap
Trader Score: (1)
 
zombie's Avatar
 
Join Date: Mar 2006
Location: SugarLand,Texas
Posts: 487
Default

i keep the real time mpg cruise info on the screen while im driving. then i try to keep the gas pedal on the highest cruise mpg (usually 25-35mpg). you can also keep your tires properly inflated and try not to use the AC that much.

your probably gonna hear a lot of mixed reviews on the effects of fuel injector cleaner. I add a bottle of chevron fuel injector cleaner every time i change my oil, but i cant really tell the difference.
__________________

http://www.cardomain.com/ride/2671523
99 rx300 170k+ miles
wrecked May 2011
zombie is offline   Reply With Quote
Old 07-22-07, 10:00 AM   #3
bowen.chau
Rookie
Trader Score: (0)
 
Join Date: Jul 2007
Location: -
Posts: 82
Default

So, how about the spark plug ??
Does the gas mileage usually be improved after the spark plugs have been changed and the engine valves has been cleaned?
bowen.chau is offline   Reply With Quote
Old 07-22-07, 10:09 AM   #4
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

Welcome to CL.

Hmm, that's about 12.5 mpg or so. I get about 15 to 16 mpg right now under my conditions (see my homepage below for more)

Would be interested to know how many kms you have on the odometer, what type of engine you have in your Harrier, the 2.2 or the 3.0 and if you have AWD or FWD?

Fuel injector cleaning and spark plug changing can improve gas mileage In addition check the following.

-tire pressure
-MAF sensor cleaned (I'll point you in the right direction if you want to know more)
-IACV cleaned (what is your RPM reading at idle?) (generally spray carb cleaner in a small hole in the throttle body, if you need to know more about this let me know and I'll point you in the right direction)
-Pull EFI fuse or disconnect negative battery pulled for a few minutes (to clear ECU). I generally recommend the latter the first time you do it as it appears to be more effective from my observations.
-in the case of an AWD and depending on the kms, good to change out the transfer case and rear differential fluids
-fresh coolant (having an old coolant leads to a hotter engine over time, increasing NOX emissions in the case of emissions tests and since exhaust passes through A/F sensors on one or both banks (depending on engine configuration) makes gas mileage less efficient. I like to add at least one bottle of Redline WaterWetter to the coolant and noticed on Redline's site they have a dealer in Hong Kong, http://www.redlineoil.com/dealers_in...=35&submit.y=5
-Less restrictive muffler
-alighnment and balance of tires

If you need any other help just let me know.
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 10:29 AM   #5
bowen.chau
Rookie
Trader Score: (0)
 
Join Date: Jul 2007
Location: -
Posts: 82
Default

Wow, thanks for your help, Lexmex.

How do I know my car is AWD or FWD?
There is a emblem "3.0 FOUR", so I assume that's AWD, right?

Mine has 63000 kms on it.
My idle is around 600-700 rpm.
The temperature of my engine is below half on the gauge.

What is MAF and IACV?
bowen.chau is offline   Reply With Quote
Old 07-22-07, 10:39 AM   #6
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

Quote:
Originally Posted by bowen.chau View Post
Wow, thanks for your help, Lexmex.

How do I know my car is AWD or FWD?
There is a emblem "3.0 FOUR", so I assume that's AWD, right?

Mine has 63000 kms on it.
My idle is around 600-700 rpm.
The temperature of my engine is below half on the gauge.

What is MAF and IACV?
I'll take these in a few posts.

Being 3.0, your engine is the 1MZFE that you would find in Canadian and U.S. markets.

Your idle is about right, we see 750 RPM as average, but in hotter months it can dip slightly and/or when MAF/IACV/air filter is dirty.

Your vehicle is still very young for its model year.

Cooling temperature is good if at or below middle line.

As far as AWD you should have it, but emblems can be deceptive.

So check underneath your vehicle and see if you have this outlined in blue, if so you have AWD.

I'll talk about MAF/IACV in next few posts.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 10:45 AM   #7
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

Incidentally, what I am about to describe is something I did on Friday in the early evening after having a low idle of about 500 rpm.

First thing you want to check out is the MAF (Mass Air Flow Sensor). This is the location in my RX, but you will find it just after your airbox and it looks just like the one you see here. This little sensor basically measure the flow/temperature of air entering the engine to help in the calculation of the air/fuel ratio (a.k.a. to help deliver the right amount of fuel based on how much air is coming in).
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 10:49 AM   #8
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

You have to remove the two little screws to get this off.

Once you have it in your hand you should notice this, a red diode. One side is usually a little dirtier than the other. This is the second most likely cause of the infamous P0171 error (a check engine light error that is the most common affecting the RX300). The number 1 cause is just an abnormal air flow reading. What you want to do is clean it. Electrical contacts cleaner works well, but I happen to use due to easier availability computer keyboard cleaner. This is step 1.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 10:51 AM   #9
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

If you turn the sensor upside down and peak into one of the two openings you will also see 2 small threads. Clean these also by simply spraying in there and then turning it rightside up. Blow in it after about a minute or so and give it a little shake, then it let it dry for a minute or two and reinstall.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 10:57 AM   #10
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

Now the IACV (Idle Air Control Valve). For this you will need some carburator cleaner or an engine degreaser spray. I haven't found the computer keyboard cleaner to be as effective. This little device allows a small amount of air to enter the engine to maintain idle, otherwise the engine would stall.

It gets dirty mainly due to the fact that the way this and many other engines work is that they recirculate oil, moisture and other non-exhaust-byproducts of combustion via the camshafts through the PCV Valve (will get to that, too) and the crankshaft vent filter hose (a hose that hooks up to the air intake just in front of the MAF sensor). As you can imagine these byproducts can clog the IACV and thus cause reduced idle rpm among other things. What you need to do is locate the throttle body below and remove the two rubber hoses (they are accordion shaped and held in by two brackets) and you should see this.

THERE IS AN UPDATE TO THIS STARTING AT POST 42 OF THIS THREAD.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD

Last edited by Lexmex; 11-12-07 at 09:20 AM..
Lexmex is offline   Reply With Quote
Old 07-22-07, 11:00 AM   #11
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

Notice in the photo above how on the left side it is a little dirtier. This is the oil residue I was referring to that can clog the IACV. the IACV itself is partly that black piece you see below the right tube and extends backward and up. I have seen many people simply replace this or take off a lot of things to clean it...in most cases this is not necessary.

On the right side there is a small hole in the tube.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 11:04 AM   #12
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

What you want to do is spray into that hole for about 15 seconds as shown. Then reconnect everything.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 11:08 AM   #13
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

One more thing, the PCV (positive crankcase ventilation) Valve. This is what I was referring to earlier. The thing you need to remember is this thing gets dirty. It is located on the left side of the engine just underneath the intake manifold. This PCV design was changed around the 2001 model year, but since your Harrier is a 99 like my RX, it should look the same.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 11:11 AM   #14
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

Just pull it out with a strong tug and then disconnect it from the clamp on the rubber hose it attaches to. What I recommend is spraying some of that computer keyboard cleaner or electrical contact cleaner in there (works better than carb cleaner) and then rinse it out with water. You should be easily able to press it in with a screw driver/paperclip or other.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 11:15 AM   #15
Lexmex
Super Moderator
Trader Score: (0)
 
Lexmex's Avatar
 
Join Date: Apr 2004
Location: Miami, Florida
Posts: 16,382
Default

Last thing I recommend to do is pull the negative battery cable off for a few mintues to reset the ECU. The short of it is that your driving habits are evaluated so to speak by the ECU and depending on this and the state of the vehicle will ultimately affect your gas mileage.

Another small trick that does the same thing, though not quite as effectively is to pull out (with the key of the ignition) the EFI fuse located here in your fusebox. Take it for at least a minute and then put back in and start up your vehicle. It might have a low idle at first but then should start to pick up. This is normal. Pulling the EFI fuse for a minute can also help reset any CEL (Check Engine Light) you may have, assuming it isn't something that is permantent such as a messed up part, bad sensor, etc, then the light will stay on.
Attached Images
 
__________________
Homepage of my 1999 RX300 AWD
Lexmex is offline   Reply With Quote
Old 07-22-07, 11:15 AM
 
 
 
 
Reply

Tags
air, bad, battery, camshaft, change, effect, flow, fuel, gas, lexus, mass, mileage, mpg, rx300, sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 LS430 suggestion on body kit fchungi2 LS430 5 12-01-13 12:52 AM
Changing the suspension C240 Suspension and Brakes 0 07-30-13 10:34 AM
GPS Map software for Indonesia hjbb RX - Third Generation 1 02-19-13 04:22 PM
Toyota Harrier Rear window? 033rierrah RX - Second Generation 3 11-26-12 03:40 PM
Speaker Problem - searched high and low RuninRoach RX - Second Generation 15 09-14-12 01:16 AM

All times are GMT -7. The time now is 10:05 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info