Check Engine Light and VSC lights are on - Club Lexus Forums


Go Back   Club Lexus Forums > Lexus Model Forums > RX Models > RX - 2nd Gen (2004-2009)
Log In 

Check Engine Light and VSC lights are on

Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-15-15, 09:49 PM   #1
nick1407
Driver School Candidate
Trader Score: (0)
 
Join Date: Sep 2015
Location: California
Posts: 1
Default Check Engine Light and VSC lights are on

Driving around today in my 2004 RX330, I kept smelling a rotten egg odor. Mainly when i was braking i would smell it. I smelt the outside of the car but nothing. was just coming from the inside.
My vehicle has sort of been struggling to start the past few weeks.

Do you think it could be the battery? I've read online that, or even catalytic converter
would love some feedback
thanks
nick1407 is offline   Reply With Quote
Old 09-16-15, 11:37 AM   #2
adi419
Driver School Candidate
Trader Score: (0)
 
Join Date: Sep 2015
Location: VA
Posts: 1
Default

nick1407 it's your Catalytic Converter. I just got mine changed along with a Oxygen sensor on my 05 RX.
Hope this helps
adi419 is offline   Reply With Quote
Old 09-16-15, 03:49 PM   #3
RX3302004
Driver
Trader Score: (0)
 
Join Date: Mar 2013
Location: FL
Posts: 183
Default

If not the CC maybe the brake light switch.
RX3302004 is offline   Reply With Quote
Old 09-16-15, 06:34 PM   #4
bigboss
Driver School Candidate
Trader Score: (0)
 
Join Date: Apr 2012
Location: MN
Posts: 44
Default

go to a autozone or your local auto part store get a CEL scanner to read the code. whenever a CEL tiggers, the VSC will always come on.

Rotten odor smell is usually a leaky catalytic or a bad evac air system.
bigboss is offline   Reply With Quote
Old 09-18-15, 07:02 AM   #5
taldrich97
Driver School Candidate
Trader Score: (0)
 
Join Date: Oct 2013
Location: CT
Posts: 3
Default

I believe there is also a post regarding tiny hole that can develop on top of exhaust that can throw off the sensor.
taldrich97 is offline   Reply With Quote
Old 09-18-15, 09:20 AM   #6
dzul
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2014
Location: brunei
Posts: 2
Default

I hve prblm with my is 300 when I start the engine check vsc coming out for a re second,
Sometime its not, I already bring the car to the dealer for check this problem
but they say no problem with the car,, can someone help me with this problem
dzul is offline   Reply With Quote
Old 10-19-15, 04:08 AM   #7
lechatkawa
Driver School Candidate
Trader Score: (0)
 
Join Date: Oct 2015
Location: Niger
Posts: 3
Default

HI,

I've got same problem yesterday on my 2005 RX330, it was just the 30A ABS fuse to replace.
lechatkawa is offline   Reply With Quote
Old 10-21-15, 10:32 AM   #8
eisens
Rookie
Trader Score: (0)
 
Join Date: Jun 2003
Location: Florida
Posts: 50
Default

Happened to me and it was my spark plugs. 5 platinum spark plugs later everything is fine.

eisens is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil smell Tsmith1982 LS - 4th Gen (2007-present) 3 12-25-14 09:03 PM
burning smell in cabin m1964 RX - 3rd Gen (2010-2015) 6 09-09-14 09:24 PM
92 es300 exhaust smell in cabin lluahs ES - 1st to 4th Gen (1990-2006) 3 07-07-14 07:32 PM
'10 3GS Oil Smell Gas iLub3GS GS - 3rd Gen (2006-2011) 13 03-21-14 09:25 PM
WEIRD SMELL when ACCELERATION 07 is350 dimon1688 IS - 2nd Gen (2006-2013) 18 02-28-12 01:00 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 03:51 AM.



Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS