CEL, Excessive Ripple & headlight leveler warning light - Club Lexus Forums

Log In 

CEL, Excessive Ripple & headlight leveler warning light

Reply
 
 
 
Thread Tools Search this Thread
Old 08-16-14, 04:44 AM   #1
lexus4us
Rookie
Thread Starter
 
lexus4us's Avatar
 
Join Date: Sep 2001
Location: PA
Posts: 58
Default CEL,Excess Ripple,leveler light & can't shift from park

Hi all


What's your thoughts on this?

First the back story on my 2001 RX300 213,000 mile well maintained vehicle.

Just weeks prior ( in case it's relative) my indicator light came on for a bulb. Probably a filament since all are lit.

Yesterday morning (May have been prior day) the warning light came on for the auto headlight leveler. Later my wife comes home from the store reporting that the dash lights were flickering and car barely made it home due to flickering dash lights and sensation of stalling .

My son tested and got these results:

P1130. P1150
Excessive Ripple on Alternator
Battery tested OK

Of course the previous lamp & headlight Level indicator issues.

As you can imagine the battery was drained ( battery tested good) so this morning we jumped it and let it run for 10 minutes but the battery light remained on, dash lights flickered and almost ( would have ) stalled if brakes were pressed and car would not let take it out of Park and put it into drive....I'm assuming a safety feature.

This evening all the lower type fuses checked out OK.

So, I have 2 A/F sensors ,lamp bulbs & alternator on hand to deal with it Sunday.

Seems like allot is happening at one time. My suspicions are I'm about to enter the automotive Twilight Zone LOL

Thoughts?


I have replaced one sensor & alternator at 100-120k otherwise reg maintance stuff.

Last edited by lexus4us; 08-16-14 at 04:40 PM. Reason: Update topic & typos
lexus4us is offline   Reply With Quote
Old 08-16-14, 06:09 PM   #2
salimshah
Moderator
 
Join Date: Apr 2001
Location: Austin, TX
Posts: 9,471
Default

Your problem stems form alternator being bad and once the battery voltage starts dropping down all electrical sensors start going crazy.

Pull out the alternator and have it bench tested. Replace or repair per your desire.

With 213k miles the alternator has served you well.

Salim
(Visiting PA)
salimshah is offline   Reply With Quote
Old 08-16-14, 08:29 PM   #3
lexus4us
Rookie
Thread Starter
 
lexus4us's Avatar
 
Join Date: Sep 2001
Location: PA
Posts: 58
Default

Quote:
Originally Posted by salimshah View Post
Your problem stems form alternator being bad and once the battery voltage starts dropping down all electrical sensors start going crazy.

Pull out the alternator and have it bench tested. Replace or repair per your desire.

With 213k miles the alternator has served you well.

Salim
(Visiting PA)

Salmi,

Yes it has served me well. I hope you are correct concerning the craziness of the electronics.

If you get near the York PA area let me know.
lexus4us is offline   Reply With Quote
Old 08-17-14, 08:39 AM   #4
lexus4us
Rookie
Thread Starter
 
lexus4us's Avatar
 
Join Date: Sep 2001
Location: PA
Posts: 58
Default

Changed the alternator and all the smaller light bulbs since this pre-dated the other symptom. As of now ,all seems to be clear. We'll see after driving to work tomorrow.
lexus4us is offline   Reply With Quote
Old 08-19-14, 04:48 AM   #5
lexus4us
Rookie
Thread Starter
 
lexus4us's Avatar
 
Join Date: Sep 2001
Location: PA
Posts: 58
Default

It's been two days since installing the alternator. The codes, and remaining symptoms have ceased. Just goes to show you how an alternator can cause so many symptoms. Makes me wonder if a repair shop iwould have charged me to replace the sensors since the scanner initially produced the codes.
lexus4us is offline   Reply With Quote
Old 08-20-14, 11:12 PM   #6
salimshah
Moderator
 
Join Date: Apr 2001
Location: Austin, TX
Posts: 9,471
Default

Shows you that you should not jump to diagnose a symptom. Gather all data and see if they have a common root cause. Do your diagnosis from there.

ECU's and sensors control the engine and all of it needs good power supply and charging system.

Salim
salimshah is offline   Reply With Quote
Old 09-03-14, 04:13 AM   #7
lexus4us
Rookie
Thread Starter
 
lexus4us's Avatar
 
Join Date: Sep 2001
Location: PA
Posts: 58
Default

Turns out that I have an extra unopened & sealed Denso Air Fuel Ratio Sensor #234-9009.

I listed it in classified if anyone is interested.

Thanks
lexus4us is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Battery, abs, vsc, vsc off lights on car dies boombastic GS - 2nd Gen (1998-2005) 21 07-12-16 07:22 AM
ES300 flickering lights EPayne42 ES - 1st to 4th Gen (1990-2006) 6 01-22-15 04:43 AM
Eletrical system issues 1uzae86 LS - 1st and 2nd Gen (1990-2000) 4 09-24-14 06:56 PM
HID Auto-Leveling light came on-went away but there is a problem TRM04 GS - 2nd Gen (1998-2005) 16 06-16-07 03:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 01:51 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved