99 RX300 Fan Runs High Speed Only - Club Lexus Forums

Log In 

99 RX300 Fan Runs High Speed Only

Reply
 
 
 
Thread Tools Search this Thread
Old 05-01-09, 04:17 AM   #1
ROGERDMILL
Driver School Candidate
Thread Starter
 
Join Date: Apr 2009
Location: MA
Posts: 4
Default 99 RX300 Fan Runs High Speed Only

I have a 99RX - my problem is the fan runs in 'high speed' all the time when the A/C or heat is turned on. The **** adjusts the fan speed 'bars' indicator up and down correctly, but the fan only runs in high speed. Any ideas on what the problem might be? Blower control relay maybe? Blower control module?

Any suggestions appreciated.

Thanks,
Roger
ROGERDMILL is offline   Reply With Quote
Old 05-02-09, 08:57 PM   #2
tdandkd
Driver School Candidate
 
Join Date: Feb 2008
Location: WI
Posts: 27
Default

I also have the 99RX and had the same problem. It's the blower motor control module. It is located behind the glove compartment, against the firewall. Takes all of 10 minutes and a screwdriver to replace. I bought mine from Park Place Lexus online for about $175.
tdandkd is offline   Reply With Quote
Old 05-03-09, 06:47 PM   #3
tomstep2
Pole Position
 
tomstep2's Avatar
 
Join Date: Feb 2009
Location: GA
Posts: 240
Default

My 99 is also doing the same thing. Before replacing my blower motor control module, I am going to check the hidden fuse box behind the coin holder on the left side of the dash. Per other threads, this seems to be a common issue and sometimes the blower fuse is the problem.
tomstep2 is offline   Reply With Quote
Old 05-10-09, 11:51 AM   #4
ROGERDMILL
Driver School Candidate
Thread Starter
 
Join Date: Apr 2009
Location: MA
Posts: 4
Default

I replaced the Blower Control Module today (part# 87165-22050, purchased a new one on line for $169 plus shipping). Fan works fine now.

THANKS "tdandkd" I really appreciate the suggestions and pointing out location of the module.

Roger
ROGERDMILL is offline   Reply With Quote
Old 05-10-09, 09:25 PM   #5
tdandkd
Driver School Candidate
 
Join Date: Feb 2008
Location: WI
Posts: 27
Default

Glad I could help!
tdandkd is offline   Reply With Quote
Old 06-11-09, 06:49 PM   #6
skinny gs
Rookie
 
Join Date: Jan 2008
Location: IL
Posts: 91
Default

Same issue, same cure!
skinny gs is offline   Reply With Quote
Old 06-11-09, 07:54 PM   #7
habeeb89
Lexus Test Driver
iTrader: (3)
 
habeeb89's Avatar
 
Join Date: Nov 2007
Location: IL
Posts: 1,501
Default

I was thinking that it could be the thermostat going bad, but I guess that would have nothing to do with the AC being on.
habeeb89 is offline   Reply With Quote
Old 06-12-09, 06:38 AM   #8
lexus114
Lexus Champion
 
lexus114's Avatar
 
Join Date: Aug 2007
Location: Bethlehem Twsp. Pennsylvania
Posts: 4,259
Default

Did you do a system diagnostic test to the a/c control system?? Do a search on here it will explain how to do it. ( I did it once,but dont remember how now)
lexus114 is offline   Reply With Quote
Old 10-26-10, 09:39 AM   #9
bmwboyee
Driver School Candidate
 
Join Date: Oct 2010
Location: TX
Posts: 40
Default

how do you get back there to that thing. It is really tucked up back there.
bmwboyee is offline   Reply With Quote
Old 03-22-12, 06:20 PM   #10
tomstep2
Pole Position
 
tomstep2's Avatar
 
Join Date: Feb 2009
Location: GA
Posts: 240
Default

Update**

Nearly 3 years later the blower control module quit completely. I knew what the problem was and figured as long as it is blowing, I didn't really care. Once it quit completely, I got the part from Lexus for $229 + tax. Took me about 30 minutes as I was doing it this evening in the dark. Now fan works perfectly!
tomstep2 is offline   Reply With Quote
Old 03-23-12, 03:34 AM   #11
hypervish
Lexus Fanatic
 
hypervish's Avatar
 
Join Date: Aug 2009
Location: NJ
Posts: 5,343
Default

Thanks for the update! I'm sure it will help others eventually!
hypervish is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Heater / AC Blower Fan not working... JettCRX RX - 1st Gen (1999-2003) 16 04-09-16 06:10 AM
Turn signal that affects the heater blower? GrantReid Performance & Maintenance 4 11-05-15 09:53 AM
Blower Motor Relay Location - gs400 LexXxtacy GS - 2nd Gen (1998-2005) 0 06-21-12 10:16 AM
Noisy Fan draco RX - 2nd Gen (2004-2009) 12 11-03-10 09:35 PM
'97 ES300, blower motor only runs on really low speed btgt570 ES - 1st to 4th Gen (1990-2006) 8 06-11-09 10:00 AM


Tags
1999, 300, 8716522050, blower, control, controller, fan, lexus, module, motor, oem, rx, rx300, sale, speed

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 04:11 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved