A.C. parts replaced after compressor failed but still not fully cold - Club Lexus Forums


A.C. parts replaced after compressor failed but still not fully cold

Reply
 
 
 
Thread Tools Search this Thread
Old 08-14-14, 04:10 PM   #1
jsimms2
Driver School Candidate
Thread Starter
 
Join Date: Mar 2013
Location: Louisiana
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default A.C. parts replaced after compressor failed but still not fully cold

95 SC300
Replaced compressor, condensor, dryer, expansion valve, and condendor. Had shop evac and load it with 2 pounds of r134a. My vent temperature is about 60 degrees. The expansion valve I installed came with an extremely long copper tube that attaches in the engine bay to the AC line. That tube was much longer than the stock valve. I am wondering if something like that could cause an issue or if I should look at something else.
jsimms2 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
a/c expansion valve? Alwaysgolf IS F (2008-2014) 6 08-19-14 09:12 PM
A/C problem,, Expansion Valve or Compressor or somthing else? eyecon7 GS - 2nd Gen (1998-2005) 11 07-20-10 07:38 AM
92-96 Expansion valve or Compressor or both??? lexus72 ES - 1st to 4th Gen (1990-2006) 35 07-21-09 08:34 AM
A/C Compressor Problem redjeeper GS - 2nd Gen (1998-2005) 4 11-21-07 02:40 PM
SC 400 Air Conditioning Service Info Needed heyma Performance & Maintenance 24 08-21-07 10:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 07:54 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved