A.C. parts replaced after compressor failed but still not fully cold - Club Lexus Forums

Log In 

A.C. parts replaced after compressor failed but still not fully cold

Reply
 
 
 
Thread Tools Search this Thread
Old 08-14-14, 03:10 PM   #1
jsimms2
Driver School Candidate
Thread Starter
 
Join Date: Mar 2013
Location: Louisiana
Posts: 21
Default A.C. parts replaced after compressor failed but still not fully cold

95 SC300
Replaced compressor, condensor, dryer, expansion valve, and condendor. Had shop evac and load it with 2 pounds of r134a. My vent temperature is about 60 degrees. The expansion valve I installed came with an extremely long copper tube that attaches in the engine bay to the AC line. That tube was much longer than the stock valve. I am wondering if something like that could cause an issue or if I should look at something else.
jsimms2 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
No AC after repairs, when I turn AC on, gas/hissing noise under driver side dash chungmeow GS - 2nd Gen (1998-2005) 13 06-17-16 08:54 PM
a/c expansion valve? Alwaysgolf IS F (2008-2014) 6 08-19-14 08:12 PM
A/C Compressor Problem redjeeper GS - 2nd Gen (1998-2005) 4 11-21-07 01:40 PM
SC 400 Air Conditioning Service Info Needed heyma Performance & Maintenance 24 08-21-07 09:59 PM
1991 AC Problem Mark Manzo LS - 1st and 2nd Gen (1990-2000) 3 06-16-06 06:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 07:45 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved