Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300 > Performance & Maintenance
Sign in using an external account
Register Forgot Password?

Accessories on 2jzgte swap

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-02-14, 03:52 AM   #1
2jdeemo
Driver School Candidate
Trader Score: (0)
 
2jdeemo's Avatar
 
Join Date: Aug 2013
Location: Cali
Posts: 32
Default Accessories on 2jzgte swap

Can't seem to find this info. To much un-needed things or not using the right key words but I was curious what accessories wouldn't work if I did the 2jzgte swap in my sc300 and used the wiring harness it came with.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
2jdeemo is offline   Reply With Quote
Old 07-02-14, 09:34 AM   #2
soarer13oy
Lexus Champion
Trader Score: (13)
 
soarer13oy's Avatar
 
Join Date: Feb 2008
Location: Sacramento
Posts: 2,191
Default

I lost traction control, and the ect/pwr button. That all i can think of that i lost.
__________________
13.2 @109 2.3x 60' (2jzgte usdm twins)
http://www.youtube.com/watch?v=MvPbByDcFM8
http://www.youtube.com/watch?v=At6iZ-vPFBU
Borg warner s366, 2jzgte head/ ge block, ls400 brakes, ccw classics, map ecu, 550cc, 4" dp, 3" dual exit exhaust, aem cam gears
soarer13oy is offline   Reply With Quote
Old 07-02-14, 02:00 PM   #3
2jdeemo
Driver School Candidate
Trader Score: (0)
 
2jdeemo's Avatar
 
Join Date: Aug 2013
Location: Cali
Posts: 32
Default

That's it? Did u use a supra motor set or aristo?
2jdeemo is offline   Reply With Quote
Old 07-02-14, 02:32 PM   #4
Highway
Pole Position
Trader Score: (0)
 
Join Date: Oct 2011
Location: New Jersey
Posts: 349
Default

I lost nothing with the Aristo motorset w/auto aristo ECU on my original 1995 sc300 5spd. I however use a complete tweak'd harness and Tweak'd modified tach . As it is right now my battery dies if it sits. After researching before I even did the swap I saw users reporting the same. So in short you have to address the tach & explore using a complete aftermarket ECU. GL
__________________
2JZGTE powered SC300
Highway Riding!
Highway is offline   Reply With Quote
Old 07-02-14, 03:16 PM   #5
CatManD3W
Lexus Test Driver
Trader Score: (10)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 932
CatManD3W
Default

With the Aristo swap you will need to use the SC300 A/C compressor.....the lines bolt up different and are a different size on Aristo....
__________________
1992 Lexus SC300 Original 5spd #586 4K9 |1 of 1601|
|2JZGTE|Aristo ECU|440's|TT Fuel Pump|BorgWarner S366 0.91A/R@14psi|Full 3" SS exhaust|LS400 BBK|Tial MV-R|Tial Q|W58|CompetitionClutch Stage 4|ARP Headstuds|3" IC & Piping|GSP Mono-RS Coilovers|XXR 521 18x8.5/10|SC400 OEM Lip|6000k HID|

1999 Toyota Tacoma X-Cab

|5VZFE|5spd|4wd|Shrockworks Front Bumper|Bilstein Adjustable 5100's|Wheelers Custom AAL|Bilstein 5125's|Deckplate mod|Magnaflow exhaust|33X10.5X15 BFG A/T|OEM 15X7's
CatManD3W is offline   Reply With Quote
Old 07-02-14, 04:40 PM   #6
soarer13oy
Lexus Champion
Trader Score: (13)
 
soarer13oy's Avatar
 
Join Date: Feb 2008
Location: Sacramento
Posts: 2,191
Default

Quote:
Originally Posted by 2jdeemo View Post
That's it? Did u use a supra motor set or aristo?
I used an aristo motor but its basically the same as a supra.
__________________
13.2 @109 2.3x 60' (2jzgte usdm twins)
http://www.youtube.com/watch?v=MvPbByDcFM8
http://www.youtube.com/watch?v=At6iZ-vPFBU
Borg warner s366, 2jzgte head/ ge block, ls400 brakes, ccw classics, map ecu, 550cc, 4" dp, 3" dual exit exhaust, aem cam gears
soarer13oy is offline   Reply With Quote
Old 07-02-14, 11:18 PM   #7
2jdeemo
Driver School Candidate
Trader Score: (0)
 
2jdeemo's Avatar
 
Join Date: Aug 2013
Location: Cali
Posts: 32
Default

I'm mostly asking about the harness not the motor. And my ac lines are busted anyways so no ac for me ahaha
2jdeemo is offline   Reply With Quote
Old 07-03-14, 03:00 AM   #8
KahnBB6
Lexus Champion
Trader Score: (3)
 
Join Date: Jun 2010
Location: California
Posts: 1,893
Default

Quote:
Originally Posted by Highway View Post
I lost nothing with the Aristo motorset w/auto aristo ECU on my original 1995 sc300 5spd. I however use a complete tweak'd harness and Tweak'd modified tach . As it is right now my battery dies if it sits. After researching before I even did the swap I saw users reporting the same. So in short you have to address the tach & explore using a complete aftermarket ECU. GL
Hang on... why does the 2JZGTE swap cause a battery drain gremlin? Is there some issue with using an OEM GTE ecu?
__________________
1993 SC300 5-speed NA | Built R154 | Gixxer_Drew Susp. 600/325 | TT: brakes FR, rims, rear sway, seats | Koyo rad | 4.272 TT Torsen LSD
------------------------
KahnBB6 is offline   Reply With Quote
Old 07-03-14, 10:31 AM   #9
soarer13oy
Lexus Champion
Trader Score: (13)
 
soarer13oy's Avatar
 
Join Date: Feb 2008
Location: Sacramento
Posts: 2,191
Default

Quote:
Originally Posted by KahnBB6 View Post
Hang on... why does the 2JZGTE swap cause a battery drain gremlin? Is there some issue with using an OEM GTE ecu?
I dont seem to have a battery drain issue, but im not using a tweak harness either.
__________________
13.2 @109 2.3x 60' (2jzgte usdm twins)
http://www.youtube.com/watch?v=MvPbByDcFM8
http://www.youtube.com/watch?v=At6iZ-vPFBU
Borg warner s366, 2jzgte head/ ge block, ls400 brakes, ccw classics, map ecu, 550cc, 4" dp, 3" dual exit exhaust, aem cam gears
soarer13oy is offline   Reply With Quote
Old 07-03-14, 11:44 AM   #10
CatManD3W
Lexus Test Driver
Trader Score: (10)
 
CatManD3W's Avatar
 
Join Date: May 2013
Location: SteelCity
Posts: 932
CatManD3W
Default

Quote:
Originally Posted by soarer13oy View Post
I dont seem to have a battery drain issue, but im not using a tweak harness either.
x2.....No battery drain here....Im not using tweak either.....Your battery may just be cooked....Go get it checked at an auto parts store they usually do it for free
__________________
1992 Lexus SC300 Original 5spd #586 4K9 |1 of 1601|
|2JZGTE|Aristo ECU|440's|TT Fuel Pump|BorgWarner S366 0.91A/R@14psi|Full 3" SS exhaust|LS400 BBK|Tial MV-R|Tial Q|W58|CompetitionClutch Stage 4|ARP Headstuds|3" IC & Piping|GSP Mono-RS Coilovers|XXR 521 18x8.5/10|SC400 OEM Lip|6000k HID|

1999 Toyota Tacoma X-Cab

|5VZFE|5spd|4wd|Shrockworks Front Bumper|Bilstein Adjustable 5100's|Wheelers Custom AAL|Bilstein 5125's|Deckplate mod|Magnaflow exhaust|33X10.5X15 BFG A/T|OEM 15X7's
CatManD3W is offline   Reply With Quote
Old 07-03-14, 02:39 PM   #11
2jdeemo
Driver School Candidate
Trader Score: (0)
 
2jdeemo's Avatar
 
Join Date: Aug 2013
Location: Cali
Posts: 32
Default

Quote:
Originally Posted by CatManD3W View Post
x2.....No battery drain here....Im not using tweak either.....Your battery may just be cooked....Go get it checked at an auto parts store they usually do it for free
What harness are u using?
2jdeemo is offline   Reply With Quote
Old 07-03-14, 02:39 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
92 sc300 with 2jzgte swap.. Gauge cluster prob 2jz610 Performance & Maintenance 9 10-09-14 10:50 PM
Avg. Cost of a 2JZ-GTE swap? Casper9604 Performance & Maintenance 43 01-07-13 03:52 PM
1jzgte swap scstreets Performance & Maintenance 1 12-26-12 04:18 PM
Sc400 with 2jzgte which motor mount to use? sidwin Performance & Maintenance 4 11-15-12 08:13 PM
2jzge vs 2jzgte oil dipstick 95SC3T Performance & Maintenance 4 10-24-12 07:45 AM


Tags
1995, aristo, sc300, swap

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 01:04 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info