Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300 > Performance & Maintenance
Sign in using an external account
Register Forgot Password?

Please help !! SC problem

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-25-14, 11:36 AM   #1
SC2JZ420
Driver School Candidate
Trader Score: (0)
 
SC2JZ420's Avatar
 
Join Date: Feb 2014
Location: Florida
Posts: 10
SRT4Life420 Hotboxed_S10
Default Please help !! SC problem

I recently bought this 1995 sc300 about a month and half ago and little by little I've been replacing parts alternator , starter , battery , fuel filter ,so anyways yesterday night I put gas (93 octane) and as soon as I started the car it started misfiring a little bit . Then I drove for a minute or so with a steady throttle position and the rpm will drop for a second then pick up normally . I made it home with it misfiring abit. Now this morning it cranks and starts but immidiatly shuts off. Any suggestions? I pulled 3 codes 14 ignition signal , 25 lean a/f ratio,and 71 egr system malf. I've always had 71 but 14 and 25 are new , I also was gonna do the fuel pump mod to 12v but when I looked it's been done already
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
SC2JZ420 is offline   Reply With Quote
Old 05-25-14, 11:42 AM   #2
SC2JZ420
Driver School Candidate
Trader Score: (0)
 
SC2JZ420's Avatar
 
Join Date: Feb 2014
Location: Florida
Posts: 10
SRT4Life420 Hotboxed_S10
Default

Can this possibly be the igniter?
SC2JZ420 is offline   Reply With Quote
Old 05-25-14, 11:42 AM
 
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help my sc took a **** on me SC2JZ420 Performance & Maintenance 6 06-16-14 11:22 PM
Misfire, failed cam position sensor 1UZFEric Performance & Maintenance 5 03-03-14 01:30 PM
92 sc400 codes 14 and 15 sc710 Performance & Maintenance 10 02-26-14 07:38 AM
GSh misfire issues?!? Speedy0o GS - Third Generation 32 12-09-13 07:03 AM
92' SC400 Misfiring canman44 Performance & Maintenance 8 12-04-13 07:39 PM

All times are GMT -7. The time now is 01:06 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info