Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300 > Performance & Maintenance
Sign in using an external account
Register Forgot Password?

Will not idle but no check engine light

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-20-14, 10:58 PM   #1
SCHolmes
Driver School Candidate
Trader Score: (0)
 
SCHolmes's Avatar
 
Join Date: Sep 2013
Location: VA
Posts: 13
Question Will not idle but no check engine light

So I searched the forums and everywhere says when the iacv or tps go out it throws the CEL on. I have a 92 sc300 5spd. It will turn over but will not stay cranked. I have to give it gas for it to stay on. I can drive it and it runs fine. It also dosent do this all the time. So I'm lost. I cleaned my maf sensor, iacv, and throttle body. Can some please help me!?
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
SCHolmes is offline   Reply With Quote
Old 05-20-14, 11:16 PM   #2
ZeRoSe7en
Rookie
Trader Score: (0)
 
Join Date: Oct 2012
Location: AZ
Posts: 73
Default

Sounds like a fuel delivery issue. Bad injectors? Pump? Regulator? Filter?
ZeRoSe7en is offline   Reply With Quote
Old 05-21-14, 11:04 AM   #3
AnonymousG
Pole Position
Trader Score: (2)
 
Join Date: Jan 2011
Location: Bay Area, CA
Posts: 321
Default

Do the 12v fuel mod. Sounds like your fuel pump ecu is going out.
__________________
92 SC300 5spd conversion - Royal Jade Pearl

YellowSpeed Coils - 96 Front - 97+Tails - SC4 Front Lip - Injen SRI - MKIV DualCore Rad - NRG/Nardi - BattleVersion subframe bushings - Poly rear dif bushings - BattleVersion knuckles - Braided power steering hose - Front & rear Prothane bushings - MKIV swaybars - BattleVersion front swaybar links - S2000 black seats - Kazama engine mounts
AnonymousG is offline   Reply With Quote
Old 05-26-14, 12:56 PM   #4
SCHolmes
Driver School Candidate
Trader Score: (0)
 
SCHolmes's Avatar
 
Join Date: Sep 2013
Location: VA
Posts: 13
Default

I already did the 12v mod and filter was replaced a couple of months ago
SCHolmes is offline   Reply With Quote
Old 05-26-14, 01:00 PM   #5
SCHolmes
Driver School Candidate
Trader Score: (0)
 
SCHolmes's Avatar
 
Join Date: Sep 2013
Location: VA
Posts: 13
Default

And would it be fuel system if it's not constant. Because I'd figure it be a sensor since it runs fine just messes up time to time
SCHolmes is offline   Reply With Quote
Old 05-26-14, 06:05 PM   #6
Cleanshots
Lexus Champion
Trader Score: (2)
 
Cleanshots's Avatar
 
Join Date: Dec 2007
Location: NorCal
Posts: 2,790
Send a message via AIM to Cleanshots
Default

its iacv cause if you give it agas and it stays on it means the iacv is dirty or not working etc.. open it clean it and assemble should be fine..
__________________

94 Sc300 Blk on USB 5spd 1 of 227 #076
2Jz-gte, Turbonetics T72-70, aeromotive, R154, BC racing, koyo, Act, HKS Hi Power, zirgo, TRS, Momo, Tial, BrianCrower, Fluidamper
Check out my threads and leave some love.
Stage1: Build and GTE Swap.
Stage2: Paint!
Ongoing Photoshoot Thread.
Cleanshots is offline   Reply With Quote
Old 05-27-14, 02:40 PM   #7
SCHolmes
Driver School Candidate
Trader Score: (0)
 
SCHolmes's Avatar
 
Join Date: Sep 2013
Location: VA
Posts: 13
Default

We'll I took it out and cleaned the nipple off so what do you mean open it?

Thank y'all for responding btw
SCHolmes is offline   Reply With Quote
Old 05-28-14, 02:38 PM   #8
Ozzzzy
Driver
Trader Score: (0)
 
Join Date: Feb 2013
Location: fl
Posts: 101
Default

How did you clean your MAF? I know that if you use cleaner on some of them, it ruins the sensor.
Ozzzzy is offline   Reply With Quote
Old 05-28-14, 02:55 PM   #9
Ali SC3
Na-T Guru
Trader Score: (10)
 
Ali SC3's Avatar
 
Join Date: Oct 2007
Location: CO
Posts: 6,912
Default

you aren't supossed to clean the 92 maf's with maf cleaner. only 96+ you can clean like that.
__________________

1995 Lexus SC300 5spd Na-T ( TT Ecu Mod + a few others)
Ali SC3 is offline   Reply With Quote
Old 05-29-14, 09:17 PM   #10
SCHolmes
Driver School Candidate
Trader Score: (0)
 
SCHolmes's Avatar
 
Join Date: Sep 2013
Location: VA
Posts: 13
Default

Well the maf sensor is still good
SCHolmes is offline   Reply With Quote
Old 05-30-14, 08:50 AM   #11
SC400slide
Lexus Champion
Trader Score: (6)
 
SC400slide's Avatar
 
Join Date: Apr 2012
Location: In Recovery mode
Posts: 2,994
Jonathan Hoppman SC400slide
Send a message via Skype™ to SC400slide
Default

Quote:
Originally Posted by SCHolmes View Post
Well the maf sensor is still good
Well just to make sure, test it.

Click the image to open in full size.

Also, technically, the MAF isn't really, in your case at least, an MAF. Like ALi said, 96 and up are different and can be cleaned with the spray. 92-95 are karmen vortex type, whcih can only be cleaned by blowing it off. In your case, it's not an MAF, it's an AFM...but that doesnt really matter as long as you clean it right.
__________________
1992 SC400 152k, 1995 SC400 190k, 1999 GS300 210k, 2001 Toyota Sequoia 235k, 2003 Chevy Suburban 175k, 1999 NB Miata 165k, 2000 Miata SE 6 Spd 110k
Lebo Boh tak miloval svet...
Apple Device Intellegentsia
TLN# 49 "Burnt Brownie"
SC400slide is offline   Reply With Quote
Old 05-30-14, 09:07 AM   #12
Ali SC3
Na-T Guru
Trader Score: (10)
 
Ali SC3's Avatar
 
Join Date: Oct 2007
Location: CO
Posts: 6,912
Default

I know your air flow meter is questionable now because I have cleaned one before and had that similar problem. 92-95 you cannot clean them really, it even says on the side of the maf cleaner spray not to use on certain older toyota and lexus vehicles, that little warning is for your car specifically.
sit it in the sun for a day or 2 and let it dry out or try gently with a hairdryer to get all the cleaner moisture out of it. sometimes they can work again, sometimes they just wont work again.

not saying it was your original problem, but it could be a problem now depending on how you cleaned it.

where did you hear about the CEL coming on for these things, on a 92 the cel hardly goes off for anything unless its completely shorted, which means you could still have a bad tps or IACV and not have a code. I have had a bad tps on my 95 with no code, drove it like that for a month before finding out I grabbed the tps out of the wrong box when putting my parts back on the motor, put on a spare that was bad by accident.
__________________

1995 Lexus SC300 5spd Na-T ( TT Ecu Mod + a few others)
Ali SC3 is offline   Reply With Quote
Old 05-30-14, 03:21 PM   #13
Dtaylor3
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2012
Location: SC
Posts: 20
Default

I had an issue like this on my 95. Mine also smoked a bit. Turned out being the ecu making my injectors give too much fuel. Swapped the ecu for one i found on ebay and it ran great
Dtaylor3 is offline   Reply With Quote
Old 05-30-14, 04:01 PM   #14
SCHolmes
Driver School Candidate
Trader Score: (0)
 
SCHolmes's Avatar
 
Join Date: Sep 2013
Location: VA
Posts: 13
Default

Quote:
Originally Posted by Ali SC3 View Post
where did you hear about the CEL coming on for these things, on a 92 the cel hardly goes off for anything unless its completely shorted, which means you could still have a bad tps or IACV and not have a code. I have had a bad tps on my 95 with no code, drove it like that for a month before finding out I grabbed the tps out of the wrong box when putting my parts back on the motor, put on a spare that was bad by accident.
My previous experiences with cars not SCs this is my first sc.
SCHolmes is offline   Reply With Quote
Old 05-30-14, 04:02 PM   #15
SCHolmes
Driver School Candidate
Trader Score: (0)
 
SCHolmes's Avatar
 
Join Date: Sep 2013
Location: VA
Posts: 13
Default

Quote:
Originally Posted by SC400slide View Post
Well just to make sure, test it.

Click the image to open in full size.

Also, technically, the MAF isn't really, in your case at least, an MAF. Like ALi said, 96 and up are different and can be cleaned with the spray. 92-95 are karmen vortex type, whcih can only be cleaned by blowing it off. In your case, it's not an MAF, it's an AFM...but that doesnt really matter as long as you clean it right.
Thank you I'll test it tomorrow
SCHolmes is offline   Reply With Quote
Old 05-30-14, 04:02 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 RX IACV Cleaning DeadRX NELOC 2 07-11-14 08:26 AM
Need help, maybe ecu related Bender25 Performance & Maintenance 7 05-23-13 08:31 AM
TT iacv flange size jwin Performance & Maintenance 2 02-03-13 12:54 PM
Me, myself and ES300. Need help! CEL and tranny slipping after MAF and IACV cleaned catstrophy ES300 and ES330 14 07-17-12 09:10 PM
Idle Air Control Valve - should I just buy a new one? gsrthomas RX - First Generation 21 02-21-08 05:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 03:09 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info