Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300 > Performance & Maintenance
Sign in using an external account
Register Forgot Password?

Help car wont start :(

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-10-12, 07:37 PM   #1
batman714
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2012
Location: ca
Posts: 8
Default Help car wont start :(

Hey guys first off im new to this forum i got my sc300 about a month ago

Everything was working fine then i noticed the battery light was on while i was driving to work parked it ran inside because i was late. Came out later would start made that clicking noise

So i went and got a new battery and swaped it out only thing is the guy at autozone gabe me the wrong battery i pluged it in backwards thanks to this and lost all power to the car

Then i check on here to see what to do
So far i have already went and got the correct battery and replaced it and the alternator fuse which had blown. Now the car seems to have power dashlights radio ect and it cranks pretty good but wont start

Please some help thanks everyone
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
batman714 is offline   Reply With Quote
Old 08-10-12, 07:39 PM   #2
Davidddd
Pole Position
Trader Score: (1)
 
Join Date: Jul 2012
Location: California
Posts: 241
Default

Did you check your ignition fuse? It should be located in your driver side kick panel in a small black box that says "fuse".
Davidddd is offline   Reply With Quote
Old 08-10-12, 09:42 PM   #3
batman714
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2012
Location: ca
Posts: 8
Default

I cant check until tomorrow since its at my work :/ anything else i should do while there
Planing in checking the spark plugs also
batman714 is offline   Reply With Quote
Old 08-11-12, 02:01 PM   #4
batman714
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2012
Location: ca
Posts: 8
Default

It work it works it works hahaha thanks so much

Why is my battery light a still on though? Needs to charge?
batman714 is offline   Reply With Quote
Old 08-11-12, 02:09 PM   #5
Davidddd
Pole Position
Trader Score: (1)
 
Join Date: Jul 2012
Location: California
Posts: 241
Default

Check for loose connections
Davidddd is offline   Reply With Quote
Old 08-17-12, 12:24 PM   #6
dirtybum
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2012
Location: ca
Posts: 3
Default

I think your alternator may go soon from experience mine came on I ignored it because I replaced the battery and the light came then went away and return again after a month or so while driving, my car felt like it stalled while driving on the freeway, sure enough it was the alternator
dirtybum is offline   Reply With Quote
Old 08-17-12, 12:24 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help car won't start. May be starter laoboiGS3 Northern California Lexus Club 4 04-27-13 02:45 AM
Please help! Replaced battery now car wont start. Gkiesel ES300 and ES330 1 02-19-13 09:06 AM
Fuel Pump Relay Stuck Closed - Car won't start Windsor LS400 3 01-02-13 01:04 PM
2004 IS300 Battery post were reversed and car wont start PLEASE HELP Kelsis300 IS - First Generation 3 12-05-12 01:05 PM
sc400 battery problem help?? unknown159 Performance & Maintenance 2 11-29-11 12:48 AM


Tags
93, alt, blown, ct, fuse, lexus, ls400, parked, replaced, start, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 08:17 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info