Go Back   Club Lexus Forums > Lexus Model Forums > SC Models > SC 400/300 > Performance & Maintenance
Sign in using an external account
Register Forgot Password?

92 sc300 with 1jzgte a/c issue

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-03-10, 06:59 AM   #16
bryan767
Lexus Test Driver
Trader Score: (6)
 
bryan767's Avatar
 
Join Date: Aug 2008
Location: Maryland
Posts: 821
Default

I have the proper gauges when i filled it btw. I was watching the high andside. I gota look for a shop who can vacuum the system
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
__________________
Sc400 - 1JZ - Borg s362 - XXR 521 - FOR SALE (click the signature)
bryan767 is offline   Reply With Quote
Old 07-23-14, 07:20 PM   #17
Kyuzilla35
Driver School Candidate
Trader Score: (0)
 
Join Date: Jul 2014
Location: California
Posts: 14
Default

sorry to bump this dead thread, but I'm having almost the same issue and i've done some searching to no avail.

since I know nothing about A/C's / HVAC and I'm kind of iffy in taking an engine swapped car to a shop to work on it (I have a recently purchased 92 SC with a 1JZ swap)., I would like to try to diagnose what's going on.

I've been told by the previous owner it's probably the condenser, but from my reading, it's more likely that it's a missing signal.

the fan blows fine, and the heater works great.... but it's over 90 degrees here in Cali and I'd really like to get this fixed before I have to drive hours to the nearest race track lol....

how do I tell if the condenser or another part of the a/c system is bad and who should I enlist the help of?
Kyuzilla35 is offline   Reply With Quote
Old 07-23-14, 07:20 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY AC Compressor and Condenser/Drier replacement dcz GS - Second Generation 57 10-14-14 08:56 AM
Weird A/C Cooling behavior | 2008 IS 250 macho6868 IS - Second Generation 0 09-10-14 05:46 PM
LS400 AC recharging problem, pressures won't go hi/lo. zukikat LS400 7 08-31-13 01:50 PM
98 gs400 A/c problem? pitmanr200 GS - Second Generation 9 03-05-08 12:47 AM
flashing light on AC switch on LS400 Curt LS400 13 08-17-05 04:13 PM


Tags
1jz, 92, ac, cabin, expansion, filter, freon, located, problem, r134, recharge, refill, replacing, sc300, valve

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 06:05 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info