Go Back   Club Lexus Forums > Members
Sign in using an external account
Register Forgot Password?

GS4_Fiend GS4_Fiend is offline

Lexus Fanatic

Visitor Messages

Showing Visitor Messages 1 to 9 of 9
  1. CrazySC300
    05-05-12 12:17 AM
    CrazySC300
    I have an interesting theory on how my check engine light came on, I posted pics of it...I'm almost certain that's the culprit behind it, Since it's a sensor. I will still do a pressure test on the EGR stuff though, Thanks!
  2. CrazySC300
    04-28-12 08:04 PM
    CrazySC300
    Just posted my results in that smog thread, Hopefully you can help me out, Thanks!
  3. duster
    06-09-11 09:16 PM
    duster
    I read a recent post about your recommendation on the BC coilovers. When I talk to folks they tell me they are good for a "budget" coilover so maybe I'm leaning towards bilstein HD to go along with my existing ltunes springs, trd blue sways and rmm stb. Any thoughts are appreciated. I'm just not used to working with "budget" products on the lex. Thx
  4. lexusscturbo
    12-15-10 02:58 PM
    lexusscturbo
    50 I believe as many dime sized dings per panel..
  5. xianan87
    11-30-10 12:36 PM
    xianan87
    Hey man,

    are those wheels mounted on your car right now? can i see a pic?
  6. GS4DOUGIE
    03-16-10 03:03 PM
    GS4DOUGIE
    John-

    Send me the link to your FS post for the wheels I bought please? Posting feedback for you
  7. nbanupe
    10-17-09 12:11 PM
    nbanupe
    I hear youre looking for some gs4 2nd gen chrome wheels i have a set im trying to get rid of. hit me up if interested!!!!!!
  8. slickgs300
    06-18-09 09:55 PM
    slickgs300
    I have a 2000 GS300 with 144K miles. About 1 month ago I started to hear a rattling / clanking from underneath the car towards the front, sometimes at idle, sometimes under acceleration. I figured it was one of the front pipes but couldn’t really locate it.

    Today the CEL came on, and it reads: P0430 Catalyst Efficiency Below Threshold, Bank 2. The performance has not been effected, and acceleration is normal. I do not smell anything abnormal, and the car is running as good as usual. I haven’t used any different gas and always fill it with 89 octane. I live in New Jersey so the car has seen its share of snow & salt. Do you think the cat(s) are bad or could it be a loose or broken pipe? Is the O2 sensor an issue as well?

    I’m dreading taking it to the dealer because of the crazy $$$ I’m reading on these threads to get it fixed. I can keep turning off the CEL but it’s probably just going to get worse. Any advice is greatly appreciated...
  9. slickgs300
    06-18-09 09:52 PM
    slickgs300
    I have a 2000 GS300 with 144K miles. About 1 month ago I started to hear a rattling / clanking from underneath the car towards the front, sometimes at idle, sometimes under acceleration. I figured it was one of the front pipes but couldnít really locate it.

    Today the CEL came on, and it reads: P0430 Catalyst Efficiency Below Threshold, Bank 2. The performance has not been effected, and acceleration is normal. I do not smell anything abnormal, and the car is running as good as normal. I havenít used any different gas and always fill it with 89 octane. I live in New Jersey so the car has seen its share of snow & salt. Do you think the cat(s) are bad or could it be a loose or broken pipe? Is the O2 sensor an issue as well?

    Iím dreading taking it to the dealer because of the crazy $$$ Iím reading on these threads to get it fixed. I can keep turning off the CEL but itís probably just going to get worse.

About Me

  • About GS4_Fiend
    State
    CA
    Gender
    Male
    Lexus Car
    GS 430
    Year of your Lexus
    2003

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Yesterday 09:33 PM
  • Join Date: 08-02-08

Friends

Showing Friends 1 to 6 of 6
All times are GMT -7. The time now is 07:24 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info