Go Back   Club Lexus Forums > Lexus Special Interest Forums > Maintenance
Sign in using an external account
Register Forgot Password?

help please overheat on my brother 2000 lexus lx470

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-13-14, 02:51 AM   #1
rafeet
Driver School Candidate
Trader Score: (0)
 
Join Date: Dec 2013
Location: Oman
Posts: 1
Default help please overheat on my brother 2000 lexus lx470

Hi guys
My brother lx470 2000 with 190k miles has over heat problem
and because he is not in cars, I'm helping him to solve this problem.
He serviced the car month ago, full service with replacing t-belt and water pump,all lubricants and filtersthe and radiator had been cleaned and checked for any defects. Overheat problem appeared before service I thought changing water pump will solve it but now he has the same problem. Even I removed the thermometer to make it directly cooling the system to see the affect but same thing.
The heat gos up some times especially when driving up hill or sometimes in normal driving.
Please any suggestions
Please help
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
rafeet is offline   Reply With Quote
Old 08-13-14, 01:26 PM   #2
napstermik
Driver School Candidate
Trader Score: (0)
 
Join Date: Feb 2013
Location: east
Posts: 30
Default

check the easy stuff first, clogged path to radiator, fan not running, ect.
napstermik is offline   Reply With Quote
Old 08-19-14, 12:52 PM   #3
maxx430
Pole Position
Trader Score: (0)
 
Join Date: Apr 2012
Location: Sacramento, CA
Posts: 277
Default

thermostat may be playing a role too
__________________
maxx430 is offline   Reply With Quote
Old 08-21-14, 09:27 AM   #4
Taco_Kid
Pole Position
Trader Score: (0)
 
Join Date: Apr 2009
Location: az
Posts: 285
Default

does this vehicle have a procedure to remove any air pockets from the cooling system after doing such work?

a before and after problem sounds to me like a radiator issue, so i might suggest you have that flow tested.

water pumps on these motors rarely are cause for overheat issues because they spin all the time and its very unlikely the impeller is so bad it wont pump water.

another possibility might be ATF fluid being too hot in the radiator. perhaps sample the ATF and send to lab if radiator checks out ok.

running way too lean can cause heat problems, but i would expect CEL to pop on this one.
Taco_Kid is offline   Reply With Quote
Old 08-21-14, 09:27 AM
 
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LS400 stalling problem solved! raydleoni Maintenance 15 09-01-13 03:08 PM
Coolant boiling temperature gauge high lexus-is2 IS - Second Generation 8 08-28-13 11:50 AM
97 Lexus LS400 Overheating HELP ibarje LS400 5 05-19-13 06:15 PM
Running hot midwest2 LX470 and LX450 2 02-19-13 08:09 PM
LX 570 shudder / vibration when turning LX470570 LX570 17 09-03-12 12:09 PM

All times are GMT -7. The time now is 09:15 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info