Go Back   Club Lexus Forums > Lexus Model Forums > LX Models > LX570
Sign in using an external account
Register Forgot Password?

Horn fuse keeps blowing

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 11-24-13, 08:32 AM   #1
rdbdds
Driver School Candidate
Trader Score: (0)
 
rdbdds's Avatar
 
Join Date: Nov 2013
Location: Texas
Posts: 3
Default Horn fuse keeps blowing

My horn fuse on my 2011 LX 570 keeps blowing after first use of horn. Any ideas on what could be causing it?
Thanks
David
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
rdbdds is offline   Reply With Quote
Old 11-24-13, 03:47 PM   #2
ProperD
Lead Lap
Trader Score: (4)
 
ProperD's Avatar
 
Join Date: Mar 2009
Location: Hawaii
Posts: 692
dawagarage
Send a message via AIM to ProperD
Default

verify youre using the correct amp fuse?
__________________

ratsun: dawa, 73 datsun 620
zilvia: dawagarage, 96 S14, 90 Z32
ProperD is offline   Reply With Quote
Old 11-26-13, 04:17 AM   #3
ggebhardt
Lexus Test Driver
Trader Score: (0)
 
ggebhardt's Avatar
 
Join Date: Jan 2005
Location: Florida
Posts: 994
Default

Pull the wires off the horns and see if it still blows a fuse when you try to blow the horn. If it does it is in the wiring, if not then you got a bad horn(s).
__________________
Greg in Jax, FL
2015 LX570
ggebhardt is offline   Reply With Quote
Old 11-26-13, 07:23 AM   #4
rdbdds
Driver School Candidate
Trader Score: (0)
 
rdbdds's Avatar
 
Join Date: Nov 2013
Location: Texas
Posts: 3
Default

Thank you both for your responses!
I do indeed have the correct fuse size and plan to check the horn as you suggested.
Thanks again!
David
rdbdds is offline   Reply With Quote
Old 11-26-13, 07:23 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn upgrade question.. electrical gurus needed SaleenS7 LS430 13 10-05-14 03:19 PM
horn not working 305ls400 LS400 2 03-08-12 02:26 PM
Where is the horn relay on a 95 Lexus SC400?? showgun82 SC 400/300 0 01-16-12 07:36 PM
Think I blew out my horn tuddy GS - Second Generation 13 08-16-11 07:40 AM
Horn stopped working. Any ideas? corradoMR2 RX - Second Generation 9 07-12-06 12:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 04:05 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info