Go Back   Club Lexus Forums > Lexus Model Forums > LX Models > LX470 and LX450
Sign in using an external account
Register Forgot Password?

2001 lx470 Mark Levenson Stereo Problems

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-04-07, 11:26 AM   #1
lexus otta
Driver School Candidate
Trader Score: (0)
 
Join Date: Oct 2007
Location: Ontario
Posts: 4
Default 2001 lx470 Mark Levenson Stereo Problems

Hi Folks

I have a 2001 LX470 with a Mark levenson Stereo. I have no sound at all, but all the displays work and shows all radio stations etc just fine.

I am told that more than likely the amp is faulty and needs to either be replaced or yank the radio and sent out to Lexus California for diagnosis for a minimum $600.00 fee.

My Questions:

The amp is suppose to be under the pass seat, but please confirm if the amp is actually behind the head unit on a 2001.It is not under the seat

Can I put an aftermarket unit in.

Does any one know of where to buy another one of these units, besides the delaer who want $2100.00 for a new one.

Any other ideas??

Thanks
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
lexus otta is offline   Reply With Quote
Old 10-04-07, 09:38 PM   #2
llcc1975
Pole Position
Trader Score: (0)
 
llcc1975's Avatar
 
Join Date: Jul 2006
Location: UT
Posts: 214
Default

Are you sure it's not under the passenger seat? At first I didn't see mine because the DVD unit for the navigation system is directly on top of the Levinson amp.

Also, e-mail this guy: E. Gus Mancy at egusman@woh.rr.com. He really helped me out when I had an issue with my 2002 Levinson radio head unit.
__________________
2007 Audi A3 2.0T DSG - Premium | Open Sky
Retired - 2002 LX470 - Nav | ML | Vaistech SLI
Retired - 2005 GX470 - Sport | Nav | ML | Vaistech SLI
Retired - 2006 Infiniti G35 Coupe - Premium | Aero | Sport
Green eggs and are tasty.
llcc1975 is offline   Reply With Quote
Old 10-05-07, 04:50 AM   #3
lexus otta
Driver School Candidate
Trader Score: (0)
 
Join Date: Oct 2007
Location: Ontario
Posts: 4
Default AMP Location

Thanks for responding, I do not have a NAV system, is attached to the underneath of the seat or attached to the floor under a panel

Regards

Ian
lexus otta is offline   Reply With Quote
Old 10-09-07, 06:30 AM   #4
lexus otta
Driver School Candidate
Trader Score: (0)
 
Join Date: Oct 2007
Location: Ontario
Posts: 4
Default

I just want to say thanks for your help here, I did contact the person you listed and he was a great help, I did find the amp under the seat, ( DAH on my part) and I want to make sure it is the amp at fault, do you have a diagnosing sheet for this.

Once again, thank you for your help

Regards
lexus otta is offline   Reply With Quote
Old 08-10-09, 04:22 PM   #5
bf470
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2009
Location: ca
Posts: 1
Default

Is it time for a new head unit? bad Amp?
This '01 LX470 ML/Nav first had intermittent CD, then no CD sound. Now it has no FM/AM/Tape. FM may go on for a few seconds, then turns off. The speakers sometimes "click" while the stereo is completely powered off.
bf470 is offline   Reply With Quote
Old 08-10-09, 04:22 PM
 
 
 
 
Reply

Tags
2001, 470, amp, es330, head, levenson, lexu, lexus, lx, lx470, mark, problems, radio, stereo, unit

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 09:41 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info

Content Relevant URLs by vBSEO 3.5.2