Horn fuse keeps blowing - Club Lexus Forums


Go Back   Club Lexus Forums > Lexus Model Forums > LX Models > LX - 3rd Gen (2008-present)
Sign In
Register Forgot Password?

Horn fuse keeps blowing

Reply
 
 
 
 
Thread Tools Search this Thread
Old 11-24-13, 07:32 AM   #1
rdbdds
Driver School Candidate
Trader Score: (0)
 
rdbdds's Avatar
 
Join Date: Nov 2013
Location: Texas
Posts: 3
Default Horn fuse keeps blowing

My horn fuse on my 2011 LX 570 keeps blowing after first use of horn. Any ideas on what could be causing it?
Thanks
David
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
rdbdds is offline   Reply With Quote
Old 11-24-13, 02:47 PM   #2
Dawa
Lead Lap
Trader Score: (4)
 
Dawa's Avatar
 
Join Date: Mar 2009
Location: Hawaii
Posts: 697
dawagarage
Send a message via AIM to Dawa
Default

verify youre using the correct amp fuse?
__________________

ratsun: dawa, 73 datsun 620
zilvia: dawagarage, 96 S14, 90 Z32
Dawa is offline   Reply With Quote
Old 11-26-13, 03:17 AM   #3
ggebhardt
Lexus Test Driver
Trader Score: (0)
 
ggebhardt's Avatar
 
Join Date: Jan 2005
Location: Florida
Posts: 1,144
Default

Pull the wires off the horns and see if it still blows a fuse when you try to blow the horn. If it does it is in the wiring, if not then you got a bad horn(s).
__________________
Greg in Jax, FL
2015 LX570
ggebhardt is offline   Reply With Quote
Old 11-26-13, 06:23 AM   #4
rdbdds
Driver School Candidate
Trader Score: (0)
 
rdbdds's Avatar
 
Join Date: Nov 2013
Location: Texas
Posts: 3
Default

Thank you both for your responses!
I do indeed have the correct fuse size and plan to check the horn as you suggested.
Thanks again!
David
rdbdds is offline   Reply With Quote
Old 11-26-13, 06:23 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn upgrade question.. electrical gurus needed SaleenS7 LS - 3rd Gen (2001-2006) 17 03-01-15 03:07 PM
horn not working 305ls400 LS - 1st and 2nd Gen (1990-2000) 2 03-08-12 01:26 PM
94 ES300 Horn problems kennyg ES - 1st to 4th Gen (1990-2006) 1 05-31-08 07:59 AM
Horn stopped working. Any ideas? corradoMR2 RX - 2nd Gen (2004-2009) 9 07-12-06 11:22 AM
My 95 ES300 horn is not working banking ES - 1st to 4th Gen (1990-2006) 2 11-03-01 09:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 03:13 PM.

Join ClubLexus

Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info