Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS460, LS460L and LS600h
Sign in using an external account
Register Forgot Password?

Mark Levinson Amp Repair

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-14-10, 12:04 PM   #1
oscarls460
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2010
Location: CA
Posts: 4
Default Mark Levinson Amp Repair

I just wanted to let eveyone one that has had Mark Levinson AMP issues that there is help out there. I sent my AMP to

United Radio
5705 Enterprise Pkwy
East Syracuse NY 13507
315-446-5570

They repaired it for 325.00 dollars and shipped it back with in a day of receiving it.

plugged it back in and back in business.

Oscar
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
oscarls460 is offline   Reply With Quote
Old 10-14-10, 01:00 PM   #2
HyperMKIV
Lexus Champion
Trader Score: (1)
 
HyperMKIV's Avatar
 
Join Date: Feb 2001
Location: ca
Posts: 2,265
HyperMKIV HyperMKIV
Default

good to know... thanks!!!
__________________
HyperMKIV is offline   Reply With Quote
Old 10-14-10, 01:26 PM   #3
cmasten
Lead Lap
Trader Score: (0)
 
Join Date: Jun 2009
Location: ca
Posts: 741
Default

has anyone with a non-ML system ever had a Panasonic amp go bad? I dont know who makes the ML amps, but they seem to have a very high failure rate from what I read
cmasten is offline   Reply With Quote
Old 02-18-11, 04:33 PM   #4
yenyunt
Driver School Candidate
Trader Score: (0)
 
Join Date: Oct 2010
Posts: 10
Wink

Quote:
Originally Posted by oscarls460 View Post
I just wanted to let eveyone one that has had Mark Levinson AMP issues that there is help out there. I sent my AMP to

United Radio
5705 Enterprise Pkwy
East Syracuse NY 13507
315-446-5570

They repaired it for 325.00 dollars and shipped it back with in a day of receiving it.

plugged it back in and back in business.

Oscar
Thanks so much for your valuable information, my LX-470 suffering same thing and i will be sending to United Radio, i just learned about they company and they are BIG and highly reputable company. Quote is same as flat $325. I will not buy use from ebay with high risk nor exchange from dealer. Because United Radio still offer one year warranty. Company seems very organized. I sopke with CS lady and they are very professional. How is your unit working as of now? I can be reached at yenyunt@bcbg.com
Thanks again
Ye
yenyunt is offline   Reply With Quote
Old 02-18-11, 06:56 PM   #5
CJITTY
Lexus Champion
Trader Score: (0)
 
CJITTY's Avatar
 
Join Date: Jul 2010
Location: The South
Posts: 4,115
CJATL404
Default

wow, thank you for posting..i got the 100K warranty, so hopefully if mine goes out, it will do it before then, but this will make a lot of folks feel better
__________________
2008 LS600hL - Smokey Granite Mica
My LS600hL Build Thread with Photos and More http://tinyurl.com/cahf9mo
HOT!!---> LS460/LS600hL Community Wheel and Tire Research Thread http://tinyurl.com/bwg9hk4
CJITTY is offline   Reply With Quote
Old 04-13-11, 08:02 AM   #6
AirRideFan
Pole Position
Trader Score: (1)
 
Join Date: Sep 2010
Location: PA
Posts: 266
Default

This is FANTASTIC info!!! Thanks so much for the info, OP --> oscarls460! This is great. What year is your LS? '07? ...and the amp went bad already !?!?!? Jeeez. My GS430 is an '01.. really a "MINT" car- but I'm surprised my ML amp has made it THIS far before blowing...with all the things I've read about their interals/heat sinks, etc.
WOW.
AirRideFan is offline   Reply With Quote
Old 04-13-11, 08:38 AM   #7
Nospinzone
Moderator
Trader Score: (0)
 
Nospinzone's Avatar
 
Join Date: Mar 2007
Location: MA
Posts: 2,392
Default

Maybe it only seems to me like a lot of these thing are blowing, but there appears to be a real problem with these amps. If that is truly the case, Lexus should warrant these for a longer period. If not it might be cause for a class action suit.
__________________
07 LS460 SWB
08 Ferrari 612 Scaglietti
03 HD CVO Screaming Eagle Deuce
Nospinzone is online now   Reply With Quote
Old 04-13-11, 10:18 AM   #8
marky2mark
Driver
Trader Score: (0)
 
Join Date: Nov 2010
Location: CA
Posts: 142
Default

The car audio shop that did my aftermarket upgrade said they get a LOT of people coming in to replace blown ML amps.
marky2mark is offline   Reply With Quote
Old 04-13-11, 07:55 PM   #9
Shibumi1
Lexus Test Driver
Trader Score: (0)
 
Shibumi1's Avatar
 
Join Date: May 2010
Location: THE Next Level
Posts: 1,489
Default

Quote:
Originally Posted by marky2mark View Post
the car audio shop that did my aftermarket upgrade said they get a lot of people coming in to replace blown ml amps.
thats a 19 channel amp how could they replace that for anywhere near $325..

Im workin on upgrading the whole system (minus headunit) an to do it properly and retain dolby dts u need no less than (3)4 channel amps b4 u even start w sub bass.. I know phoenix gold jus released something "plug n play" but thats a 5 channel w a built in sub.. Plz get me some more info
Shibumi1 is offline   Reply With Quote
Old 04-14-11, 04:17 AM   #10
marky2mark
Driver
Trader Score: (0)
 
Join Date: Nov 2010
Location: CA
Posts: 142
Default

I think he has a place where he can get refurbished ML amps. But I'm sure they charge a lot more than 325. Sounds like United is your best bet unless you want to spend some jack.

Mine was non-ML so I only needed one JL amp and an oem interface unit.
marky2mark is offline   Reply With Quote
Old 04-14-11, 04:52 AM   #11
Shibumi1
Lexus Test Driver
Trader Score: (0)
 
Shibumi1's Avatar
 
Join Date: May 2010
Location: THE Next Level
Posts: 1,489
Default

that makes sense..
Shibumi1 is offline   Reply With Quote
Old 04-14-11, 07:36 AM   #12
vancouverl
Driver
Trader Score: (0)
 
Join Date: Dec 2010
Location: canada
Posts: 120
Default

My amp just went it is ml on a 07 .Speakers front began to rattle at high volumes and only on hot days . I started to notice it when the trunk was full but thought it had to do with distortion of the base seing the trunk was full .Had 1 day of warranty left when I took it in .Waiting for new amp .
vancouverl is offline   Reply With Quote
Old 04-14-11, 06:23 PM   #13
wrc7732
Driver School Candidate
Trader Score: (0)
 
Join Date: Feb 2011
Location: GA
Posts: 25
Default

Mine was replaced under warranty at around 25,000 miles. After noticing where the ML amp is in the trunk, my thought is that perhaps they are overheating. I imagine that with the high quantity of speakers and the relatively high quality sound for a factory system, that the amp may generate a decent amount of heat. I wonder if removing the part of the trunk floor covering the amp or adding some type of cooling ventilation to the amp area would increase the life of these amps. I have certainly experienced amp failure in the past due to over heating and I wonder if that's what's happening to these amps.
wrc7732 is offline   Reply With Quote
Old 04-14-11, 06:34 PM   #14
Shibumi1
Lexus Test Driver
Trader Score: (0)
 
Shibumi1's Avatar
 
Join Date: May 2010
Location: THE Next Level
Posts: 1,489
Default

cooling fan sounds like an excellent idea... as it drive so many speakers an has a very small footprint.. that means it has little surface area for heat to dissipation.. an trunks tend to stay warmer longer..
Shibumi1 is offline   Reply With Quote
Old 04-19-11, 10:37 AM   #15
AirRideFan
Pole Position
Trader Score: (1)
 
Join Date: Sep 2010
Location: PA
Posts: 266
Default

Quote:
Originally Posted by marky2mark View Post
I think he has a place where he can get refurbished ML amps. But I'm sure they charge a lot more than 325. Sounds like United is your best bet unless you want to spend some jack.

Mine was non-ML so I only needed one JL amp and an oem interface unit.
Are you talking about in an LX ? I have an '01 GS430... 8 speakers, total. My amp is not turning on, when I first turn the car on... then after about 5 mins, the music will start playing (Nav voice works fine- all the time though)
It's driving me crazy!!!

NOW, it started popping and crackling.. almost like it has a bad connection, but I'm pretty sure it's INTERNAL, in the ML amp...

I'm going to call this United Radio and see what they think it might be.

Also- I know the '02-'05 (ALL "OTHER" years of my body style GS) use a different part # Mark Levinson amp. Go figure.. '01's are the most unreliable, I'm pretty sure.
AirRideFan is offline   Reply With Quote
Old 04-19-11, 10:37 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mark Levinson danspeeple GS - Fourth Generation 25 09-02-14 12:40 AM
NY FS: Mark Levinson Amp aliga 2Gen GS430 / 400/ 300 Classifieds (98-05) 0 04-07-14 09:45 AM
Levinson Amp Replacement GS300 bingleyg79 GS - Second Generation 3 06-27-10 03:36 PM
CA FS: 2001 Lexus IS300 w/ JDM Altezza Motor and Many Mods! Located in Los Angeles jpsmooth Lexus Vehicles Classifieds 14 08-20-09 12:04 PM
Mark Levinson Stereo help TRedd ES350 (2007 - 2012) 8 04-28-09 11:52 AM


Tags
460, amp, amplifier, ca, car, fix, levinson, lexus, luxse, mark, repair, repairing, shop, stopped, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 09:43 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info