Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS460, LS460L and LS600h
Sign in using an external account
Register Forgot Password?

Mark Levinson Amp Repair

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 04-22-12, 03:52 PM   #31
richardbw
Driver School Candidate
Trader Score: (0)
 
Join Date: Apr 2012
Location: ca
Posts: 2
Default Mark Levinson Amp Failure

I have a 2007 LS 460L and the Mark Levinson amp just failed, so the radio, hd player and bluetooth don't work. I've stopped the very annoying clicking sound that is diagnostic of the amp failure by removing the 30 amp fuse under the passenger side dashboard. I've had a lot of cars, of all price ranges, and this is the first time an amp has failed. Based on the numerous posts I've seen here and other sites, and my personal experience, I believe this is a design or manufacturing defect, as an amp shouldn't fail like this, particularly one that we've paid thousands of dollars for on a premium sound system. I'm talking to Lexus Customer Service and hope that they will recognize this as a design or manufacturing defect and replace the part.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
richardbw is offline   Reply With Quote
Old 04-22-12, 04:41 PM   #32
Silverpaws
Pole Position
Trader Score: (0)
 
Join Date: Jan 2011
Location: GA
Posts: 396
Default

Quote:
Originally Posted by richardbw View Post
I'm talking to Lexus Customer Service and hope that they will recognize this as a design or manufacturing defect and replace the part.
Please provide us with an update after you complete your discussion with Lexus.
__________________
2008 Opaline Pearl LS460
Silverpaws is offline   Reply With Quote
Old 04-22-12, 07:18 PM   #33
Mikey100
Lead Lap
Trader Score: (0)
 
Join Date: Jul 2011
Location: Lake Oconee GA
Posts: 482
Default

Quote:
Originally Posted by richardbw View Post
I have a 2007 LS 460L and the Mark Levinson amp just failed, so the radio, hd player and bluetooth don't work. I've stopped the very annoying clicking sound that is diagnostic of the amp failure by removing the 30 amp fuse under the passenger side dashboard. I've had a lot of cars, of all price ranges, and this is the first time an amp has failed. Based on the numerous posts I've seen here and other sites, and my personal experience, I believe this is a design or manufacturing defect, as an amp shouldn't fail like this, particularly one that we've paid thousands of dollars for on a premium sound system. I'm talking to Lexus Customer Service and hope that they will recognize this as a design or manufacturing defect and replace the part.
Great sense of humor here. Welcome to Lexus-land. Glad you joined Club Lexus.
Mikey Lulejian - Lake Oconee, GA
__________________
FISHING
Is
The ONLY Anecdote For
CHAOS !!!!


* 2008 LS460 Noble Spinel Mica *
Mikey100 is offline   Reply With Quote
Old 04-22-12, 07:42 PM   #34
I8ABMR
Lexus Fanatic
Trader Score: (0)
 
I8ABMR's Avatar
 
Join Date: Sep 2007
Location: Somewhere far far away
Posts: 18,992
Default

Does anyone know if the amp is covered under the extended warranty......I would assume it is
__________________

2010 LEXUS ISF
FEATURES:
2007 GS350

Readers Rides of the month Modified Magazine December 2009
Readers Rides Super Street Magazine June 2010

2003 INFINITI G35 Rearders Rides Super Street Magazine 7/05
2007 Lexus GS350 / 2007 Lexus LS460 / 2010 Lexus ISF
I8ABMR is offline   Reply With Quote
Old 04-23-12, 06:07 AM   #35
Nospinzone
Moderator
Trader Score: (0)
 
Nospinzone's Avatar
 
Join Date: Mar 2007
Location: MA
Posts: 2,299
Default

Only under the Platinum Warranty this is covered - Stereo Component Amplifier.

As I mentioned a year ago in post #7, Lexus may need to warrant these for a longer period or face a possible class action suit.
__________________
07 LS460 SWB
08 Ferrari 612 Scaglietti
03 HD CVO Screaming Eagle Deuce

Last edited by Nospinzone; 04-23-12 at 01:31 PM..
Nospinzone is offline   Reply With Quote
Old 05-03-12, 09:16 PM   #36
GS4_Fiend
Lexus Fanatic
Trader Score: (20)
 
GS4_Fiend's Avatar
 
Join Date: Aug 2008
Location: CA
Posts: 6,648
Default

$325? I rather buy a better aftermarket amp and get it rewired, much worth it.
GS4_Fiend is offline   Reply With Quote
Old 05-04-12, 10:38 AM   #37
dbalch
Driver School Candidate
Trader Score: (0)
 
Join Date: Feb 2012
Location: CO
Posts: 3
Default Retrofit ML / NAV amp to non NAV equipped car

I have a '07 LS460 that did not come with NAV/ML (std radio). Those units are available through auto salvage .com sites. Is it possible to drop one of those units in, and enjoy those features without a lot of special wiring etc? If so, what is the unit number specific to that year/model?
Thanks!
dbalch is offline   Reply With Quote
Old 05-04-12, 11:01 AM   #38
09LS460
Rookie
Trader Score: (0)
 
Join Date: Apr 2012
Location: UT
Posts: 88
Default

Quote:
Originally Posted by GS4_Fiend View Post
$325? I rather buy a better aftermarket amp and get it rewired, much worth it.
I haven't physically looked at the amp, but I guarantee that you cannot just drop any single amp in and have that run your entire car's worth of speakers. Plus, you'd be spending a LOT more than $325 for multiple amps, custom installation, etc.....
09LS460 is offline   Reply With Quote
Old 05-08-12, 08:21 PM   #39
richardbw
Driver School Candidate
Trader Score: (0)
 
Join Date: Apr 2012
Location: ca
Posts: 2
Default Lexus Does the Right Thing.....

I called Lexus Customer Satisfaction and told them of the amp failure problem, and my belief that it was an engineering design flaw based on what I had seen on the web. They were very courteous and got back to me in a few days and said they would cover parts and labor for replacing the amp, even though my 2007 LS460L was out of warranty.
richardbw is offline   Reply With Quote
Old 06-12-12, 06:16 PM   #40
I8ABMR
Lexus Fanatic
Trader Score: (0)
 
I8ABMR's Avatar
 
Join Date: Sep 2007
Location: Somewhere far far away
Posts: 18,992
Default

DAMN !!!! I was driving home today and I starting noticing a little rattle/distorion from the speakers at high volume. I have a feeling my amp is about to go. I read one other post about the same kind of distortion from the speakers but I wanted to see if anyone else knows this symptom. I also noticed that when I pulled into the cooler garage area it got a little better. I am assuming the amp is overheating and about to shut down. I want to take it in before it blows totally and I have no music. This is getting a bit common now.
__________________

2010 LEXUS ISF
FEATURES:
2007 GS350

Readers Rides of the month Modified Magazine December 2009
Readers Rides Super Street Magazine June 2010

2003 INFINITI G35 Rearders Rides Super Street Magazine 7/05
2007 Lexus GS350 / 2007 Lexus LS460 / 2010 Lexus ISF
I8ABMR is offline   Reply With Quote
Old 06-13-12, 05:10 AM   #41
vancouverl
Driver
Trader Score: (0)
 
Join Date: Dec 2010
Location: canada
Posts: 120
Default

Be carefull as ive had a amp changed only to find it was speakers that had blown .Lexus Platinum extended covers all components ,good luck !
vancouverl is offline   Reply With Quote
Old 06-13-12, 10:03 AM   #42
ehaze
Driver
Trader Score: (0)
 
Join Date: Jan 2006
Location: Tejas
Posts: 186
Default

a single amp shouldn't be powering all the speakers in the ML system.

fail by design.
__________________
Send me your spam!
http://craigslistSpam.com/
ehaze is offline   Reply With Quote
Old 06-13-12, 10:15 AM   #43
brianlin87
Resident JDM Snob
Trader Score: (9)
 
brianlin87's Avatar
 
Join Date: Feb 2004
Location: Orange County, CA
Posts: 1,567
brianlin87 blin87
Send a message via AIM to brianlin87
Default

Quote:
Originally Posted by ehaze View Post
a single amp shouldn't be powering all the speakers in the ML system.

fail by design.
co-sign to this statement. if and when I do get around to it, i'll be replacing all my speakers with multiple amp sources.
__________________
Special Thanks to:
Aaron@GoTuning Unlimited
Eddie@Gruppe-S/Dynamic Autosports
Eddie@Mackin
Lawrence@TriStar Autobody
Jin@KyoeiUSA
brianlin87 is offline   Reply With Quote
Old 06-13-12, 10:25 AM   #44
I8ABMR
Lexus Fanatic
Trader Score: (0)
 
I8ABMR's Avatar
 
Join Date: Sep 2007
Location: Somewhere far far away
Posts: 18,992
Default

Quote:
Originally Posted by vancouverl View Post
Be carefull as ive had a amp changed only to find it was speakers that had blown .Lexus Platinum extended covers all components ,good luck !
I think its the amp because its doesnt do it all of the time and it gets worse when the car is hot from sitting in the AZ heat. I even hear the buzzing noise when the volume is low
__________________

2010 LEXUS ISF
FEATURES:
2007 GS350

Readers Rides of the month Modified Magazine December 2009
Readers Rides Super Street Magazine June 2010

2003 INFINITI G35 Rearders Rides Super Street Magazine 7/05
2007 Lexus GS350 / 2007 Lexus LS460 / 2010 Lexus ISF
I8ABMR is offline   Reply With Quote
Old 06-30-12, 03:23 PM   #45
oakpal
Driver School Candidate
Trader Score: (0)
 
Join Date: Sep 2011
Location: utah
Posts: 1
Default Mark Lev Nav system-sound cuts out

I have a 2004 with the ML and Nav system. The sound has started cutting out, all channels. I moved the fader control to the front speakers and the sound is fine, left and right. If I add the read speakers, the sound starts cutting out. If you turn the volume control down is works for all channels.
If the volume is turned up past 1/4, the sound cuts out. I presume this is a power amp issue but since it works on the front channels, I am not sure. The power supply for the power amp is working I guess since there is full front L/R sound. I also guess the subwoofer is driven off of the read channels. I am also getting DVD ERROR when I insert the magazine. Not sure if these are related as the system has a communication bus that talks to all of the components.

Any guesses??
oakpal is offline   Reply With Quote
Old 06-30-12, 03:23 PM
 
 
 
 
Reply

Tags
460, amp, amplifier, ca, car, fix, levinson, lexus, luxse, mark, repair, repairing, shop, stopped, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mark Levinson danspeeple GS - Fourth Generation 25 09-01-14 11:40 PM
NY FS: Mark Levinson Amp aliga 2Gen GS430 / 400/ 300 Classifieds (98-05) 0 04-07-14 08:45 AM
CA Wtb mark levinson amp chase350 LS460 / 430 / 400 / 600h Classifieds 1 11-17-13 09:51 PM
mark levinson amp output wattages per channel fng IS - Second Generation 20 04-22-13 02:55 PM
PA WTB: Mark Levinson Head Unit/AMP ISF MercuryISF 2Gen IS250 / IS350 / IS-F Classifieds (06-13) 0 02-06-13 01:12 PM

All times are GMT -7. The time now is 12:55 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info