Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS430
Sign in using an external account
Register Forgot Password?

Dead Mark Levinson amp on 04 LS430 - any other options?

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-05-13, 09:55 PM   #16
ddmavis
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2004
Location: Oklahoma
Posts: 16
Default

Quote:
Originally Posted by DocDenver View Post
Interesting question - how "good" is the sound of the ML? I've been listening for about 4 months now - my thoughts:

CLASSICAL MUSIC through the ML is really the best I've ever heard - and I can easily tell the difference between a really good classical CD and a merely good one. It has really opened my eyes up to classical music and a great de-stress after work.

JAZZ - Good, but I don't know enough to really know much difference. Sounds good for the instrumentals, tho.

POP/ROCK - Really doesn't do as much for me as my age-old aftermarket in my old Bimmer with a cheap power amp and a couple of 6-inch subwoofers. That thing had a great thump, a couple of nice tweeters, and was great. Not much "detail" maybe, but lots of "pow." ML seems a bit slack in the "pow" department.

SIRIUS - I got the VAIS system aftermarket and put it in - - it works well in terms of using the NAV screen - but it just doesn't sound as crisp or clear as the CD player at all. Nor does it sound as good as some of the XM radios I've heard in some new cars I've rented with built-in XM. Kind of stinks, since I am very lazy and liked someone playing music for me...
My 1996 LS400 had Nakamichi (got broad sided and totaled car); replaced with 2001 LS430 with Mark Levinson audio. I would pay the price of an OEM Nakamichi from Lexus to replace the ML audio in my LS430. At 33K mi the subwoofer blew and I do not play loud music. In the last couple years both front speakers have been replaced. Nakamichi sound wins hands down for me. I now have a DC level going to my right front door speaker; thumps when car is turned off. Took off door panel and can see the speaker cone move when car is turned on and radio is off. Trying to find someone who can repair it so I don't have to spend big $$$ at Lexus.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
ddmavis is offline   Reply With Quote
Old 07-06-13, 08:31 AM   #17
Lac
Driver
Trader Score: (3)
 
Join Date: Jun 2003
Location: Pennsylvania
Posts: 129
Default

Quote:
Originally Posted by ddmavis View Post
My 1996 LS400 had Nakamichi (got broad sided and totaled car); replaced with 2001 LS430 with Mark Levinson audio. I would pay the price of an OEM Nakamichi from Lexus to replace the ML audio in my LS430. At 33K mi the subwoofer blew and I do not play loud music. In the last couple years both front speakers have been replaced. Nakamichi sound wins hands down for me. I now have a DC level going to my right front door speaker; thumps when car is turned off. Took off door panel and can see the speaker cone move when car is turned on and radio is off. Trying to find someone who can repair it so I don't have to spend big $$$ at Lexus.
Agree! My original Nakamichi amp and sub on my '91 LS400 with over 300K miles are still working.
__________________
'04 GX470
'91 LS400
'04 LS430
Lac is offline   Reply With Quote
Old 07-09-13, 07:54 PM   #18
Oldguys
Rookie
Trader Score: (0)
 
Join Date: Nov 2009
Location: VA
Posts: 61
Default Cheap Fix

I called Mark Levinson.
They directed me to a local repair center.
I pulled the unit out of the trunk wrapped it up real nice and sent it in.
For $400 they fixed it and mailed it back.
Then something else popped within 10 minutes of re- installation so I mailed it back to the same place and they fixed it for free and mailed it back.
It's been running like a champ for a year now.
I thought they did an excellent job and were very helpful all the way around.
Taking the amp out wasn't all that difficult so I would not take it to Lexus unless you don't mind throwing your money away for something a kid could fix (at least a kid from the 80's or later).
Oldguys is offline   Reply With Quote
Old 07-09-13, 09:10 PM   #19
ddmavis
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2004
Location: Oklahoma
Posts: 16
Default

Quote:
Originally Posted by Oldguys View Post
I called Mark Levinson.
They directed me to a local repair center.
I pulled the unit out of the trunk wrapped it up real nice and sent it in.
For $400 they fixed it and mailed it back.
Then something else popped within 10 minutes of re- installation so I mailed it back to the same place and they fixed it for free and mailed it back.
It's been running like a champ for a year now.
I thought they did an excellent job and were very helpful all the way around.
Taking the amp out wasn't all that difficult so I would not take it to Lexus unless you don't mind throwing your money away for something a kid could fix (at least a kid from the 80's or later).
Oldguys,
Glad you got yours fixed. I didn't see what year your Lexus is. I found a repair place in CA that would repair and return; however I took one more search on eBay for a replacement. I ran across someone who explained the 2001 and 2002 LS430 ML amps were defective and Lexus had a new model for 2003 and on. They changed the model number from ...40 to ...41, which explains my difficulty in finding one with my model number. He claims to be an expert on ML systems for Lexus and has brand new factory ...41 amps for sale. Offers a 30-day money back guaranty and 4yr warranty on the amp. Not sure how an individual can do that, but if it works as advertised it is better than fixing a defective unit. It is on the way with free shipping and has ebay protection, so I am not worried about being taken. I will post the results when I get it installed.
ddmavis is offline   Reply With Quote
Old 07-10-13, 03:46 PM   #20
fensterlip
Driver
Trader Score: (0)
 
Join Date: May 2011
Location: CA
Posts: 147
Default

Quote:
Originally Posted by ddmavis View Post
Oldguys,
Glad you got yours fixed. I didn't see what year your Lexus is. I found a repair place in CA that would repair and return; however I took one more search on eBay for a replacement. I ran across someone who explained the 2001 and 2002 LS430 ML amps were defective and Lexus had a new model for 2003 and on. They changed the model number from ...40 to ...41, which explains my difficulty in finding one with my model number. He claims to be an expert on ML systems for Lexus and has brand new factory ...41 amps for sale. Offers a 30-day money back guaranty and 4yr warranty on the amp. Not sure how an individual can do that, but if it works as advertised it is better than fixing a defective unit. It is on the way with free shipping and has ebay protection, so I am not worried about being taken. I will post the results when I get it installed.
Can you share who you used for this? If he knows the ML stuff that well I think we should keep his name on our list of better stuff. Thanks
__________________
"It's nice to soar with the eagles but weasels don't get sucked into jet engines"
fensterlip is offline   Reply With Quote
Old 07-13-13, 06:16 AM   #21
ddmavis
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2004
Location: Oklahoma
Posts: 16
Default

Quote:
Originally Posted by fensterlip View Post
Can you share who you used for this? If he knows the ML stuff that well I think we should keep his name on our list of better stuff. Thanks
On vacation right now. Will post source and results after I receive and install amp and evaluate everything.
ddmavis is offline   Reply With Quote
Old 07-16-13, 04:26 PM   #22
Oldguys
Rookie
Trader Score: (0)
 
Join Date: Nov 2009
Location: VA
Posts: 61
Default Fixed

My car is a 2006 and has almost 200K on the clock. Runs like a champ including the rebuilt amp.
Oldguys is offline   Reply With Quote
Old 07-17-13, 03:46 PM   #23
ddmavis
Driver School Candidate
Trader Score: (0)
 
Join Date: Aug 2004
Location: Oklahoma
Posts: 16
Default

Quote:
Originally Posted by fensterlip View Post
Can you share who you used for this? If he knows the ML stuff that well I think we should keep his name on our list of better stuff. Thanks
I received the ML amp from "egusman" on eBay for $625. It works as advertised and fixed my RF Spkr "thump" problem. He has more of these amps for sale for $698 but will take offer of $625. He gave me a warranty number for the advertised 4yr warranty. Hopefully I won't have to use it. It has warranty seals on the amp, but cannot tell if they are factory or not. I'm just thankfull I can finally put my trunk back together. I will provide updates after Amp has been in service for awhile.
ddmavis is offline   Reply With Quote
Old 07-17-13, 09:42 PM   #24
Viper6
Driver
Trader Score: (0)
 
Join Date: Sep 2010
Location: TN
Posts: 197
Default

Anyone have a broken 04 or later ML Amp they are willing to part with... I like to tinker
Viper6 is offline   Reply With Quote
Old 03-22-14, 12:41 PM   #25
bblair3094
Driver School Candidate
Trader Score: (0)
 
Join Date: Mar 2013
Location: MA
Posts: 3
Default

I looked for a cheaper alternative to replacing my Mark Levinson amp and could find none. I removed my amp and sent it to United Radio in Syracuse NY. The amp was repaired for a flat fee of $450. I sent the amp on Sunday and had it back on the following Friday. When I called United Radio I did not have my call answered by a computer or someone who I could not understand on the phone. A polite, English speaking American answered the phone on the first ring. A technician called me to ask me a few questions and offer me some advice regarding speakers while he was completing the repair to my amp. Again, the technician was a polite English speaking American. Excellent quality work for exactly the repair I needed. I strongly recommend United Radio, the are a class act. Go to UnitedRadio.com and print out the form needed to send in your amp for repair. Great experience.
bblair3094 is offline   Reply With Quote
Old 03-22-14, 03:22 PM   #26
Bocatrip
Lexus Test Driver
Trader Score: (0)
 
Join Date: May 2006
Location: Fl
Posts: 1,079
Default

Quote:
Originally Posted by bblair3094 View Post
I looked for a cheaper alternative to replacing my Mark Levinson amp and could find none. I removed my amp and sent it to United Radio in Syracuse NY. The amp was repaired for a flat fee of $450. I sent the amp on Sunday and had it back on the following Friday. When I called United Radio I did not have my call answered by a computer or someone who I could not understand on the phone. A polite, English speaking American answered the phone on the first ring. A technician called me to ask me a few questions and offer me some advice regarding speakers while he was completing the repair to my amp. Again, the technician was a polite English speaking American. Excellent quality work for exactly the repair I needed. I strongly recommend United Radio, the are a class act. Go to UnitedRadio.com and print out the form needed to send in your amp for repair. Great experience.
Out of curiosity, what advice to you get regarding speakers?
__________________
Currently Own:
2001 Lexus LS430 Millenium Silver/Nav/ML
2010 Jaguar XK Coupe Liquid Silver
2004 Infiniti G35 Coupe - purchased new. (sold)
Bocatrip is offline   Reply With Quote
Old 03-22-14, 07:40 PM   #27
RushNatU
Rookie
Trader Score: (0)
 
Join Date: Mar 2014
Location: Indiana
Posts: 83
Default

Although the ML system does sound good at low to medium volumes, it's still got crappy paper speakers that look like they belong in an early 90s Hyundai. The horn loaded tweeters on the dash are the only redeeming quality. The Polk audio system I built for my Maxima absolutely destroys it and I paid a total of $1500 for the Kenwood DVD NAV touch screen head unit, top of the line front 6.5" components and rear 6.5" coaxial pair with two 500w 4 ch Kicker amps bridged to two channels each running the fronts and backs. Two 12" Polk DSi subs with 1000w Hifonics amp and a Kinetik 2400 battery (extra $220). Paying that much for a stupid factory ML amp is asinine. You can do much better. My neighbors hate me lol!

Last edited by RushNatU; 03-22-14 at 08:07 PM..
RushNatU is offline   Reply With Quote
Old 03-22-14, 07:40 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my factory Head Unit Dead? (01 w/ Nav and Mark Levinson) illspeed LS430 4 Today 12:56 AM
Q&A with A Mark Levinson Amp Repair Tech Tee LS460, LS460L and LS600h 25 05-23-14 05:09 PM
ML amp repair, if your amp died check in here g1kon1whee LS430 3 01-12-14 09:47 PM
Buying mom's '07 LS robert1408 LS460, LS460L and LS600h 24 12-30-13 11:26 PM
Fixed my Dead Nakamichi Amp kurbs62 Lexus Audio, Video, Security & Electronics 16 10-04-13 08:46 AM


Tags
04, 2002, 430, amp, amplifier, fuse, gs300, levinson, lexus, location, ls, ls430, mark, ml, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 05:46 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info