Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS400
Sign in using an external account
Register Forgot Password?

98 LS loud bang on speedbump in front after lowering!

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-06-14, 12:12 AM   #1
davincity
Driver School Candidate
Trader Score: (0)
 
Join Date: Dec 2012
Location: CA
Posts: 15
Default 98 LS loud bang on speedbump in front after lowering!

So I put the tanabee springs 2.0 drop in front and 1.5 in the back and now whenever I go over a bump at low speed or high speed I hear a loud bang up front as if the tire is hitting the frame or something I'm not sure. I also replaced the struts. Please help! 225k miles runs like a dream and always dealer maintained.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
davincity is offline   Reply With Quote
Old 08-06-14, 01:16 AM   #2
kevvo
Rookie
Trader Score: (0)
 
kevvo's Avatar
 
Join Date: Nov 2013
Location: Victoria (Australia)
Posts: 66
Default

If you look underneath the car is any part of it lower than the height of where the rim meets the tyre?
kevvo is offline   Reply With Quote
Old 08-06-14, 11:15 AM   #3
timmy0tool
Lexus Champion
Trader Score: (5)
 
timmy0tool's Avatar
 
Join Date: Sep 2008
Location: 909/626/714, SoCal
Posts: 2,648
Send a message via AIM to timmy0tool
Default

did you trim your bump stops when you installed the springs? could also be your upper a-arm hitting the inner wheel well but that is not likely since a 2" drop is very small.

also check if all the parts are nice and secure, swaybar, strut mount, etc.
__________________
lateral Gangsta
timmy0tool is offline   Reply With Quote
Old 08-06-14, 05:33 PM   #4
PureDrifter
BahHumBug
Trader Score: (10)
 
PureDrifter's Avatar
 
Join Date: Aug 2004
Location: California
Posts: 22,783
PureDrifter
Send a message via AIM to PureDrifter
Default

a-arm hitting the shock tower for $500 alex.
__________________
1. Black on Black 1999 LS400 PM-spec
-Maya-Megan-Magnaflow-LSportline-Xenondepot-PPE Engineering-Duce-Platinum VIP-Figs Engineering-R1Concepts-
2. Black 2001 MR2 Spyder -#muchroadster-
3. Black 2004 IS300 -Manaray-HKS-Eibach-Kumho-
4. Ebony Teal 1995 LS400 11-8-06
PureDrifter is offline   Reply With Quote
Old 08-06-14, 09:18 PM   #5
Caniac14
Driver
Trader Score: (0)
 
Join Date: May 2014
Location: NC
Posts: 128
@kennyneely_tsc
Default

Quote:
Originally Posted by timmy0tool View Post
did you trim your bump stops when you installed the springs? could also be your upper a-arm hitting the inner wheel well but that is not likely since a 2" drop is very small.

also check if all the parts are nice and secure, swaybar, strut mount, etc.
I can confidently say that it is the UCA(a-arm) hitting. My driving height is about 2-3" drop and I hit every time I enter my driveway unless I literally creep in.

My suggestion would be to take them at an angle if you aren't going to scrape, and be slow about it.
Caniac14 is offline   Reply With Quote
Old 08-06-14, 11:56 PM   #6
RA40
Moderator
Trader Score: (6)
 
RA40's Avatar
 
Join Date: May 2003
Location: California
Posts: 15,772
Default

Mine is at 2.5" drop up front and I've not hit the UCA. Possible on a hard compression but if the bump stop was cut at the first tapered neck, I don't see how it can contact in the wheel well. Mine is good for 2.25" of clear suspension travel. If the bump stops were not cut, that that leaves about 1/2-1" of suspension travel before it bottoms out. If it has an RCA installed, then yes it will be closer and possibly contact the wheel well. Easy to tell because the UCA will have left a mark.

My thought is that the caster bar bushings are very unhappy in this new position. The other big noise could be the engine and tranny bouncing around. Uncut bump stop, speed bump, engine and tranny get bounced up then back down. Check the engine and tranny mount.
__________________

Mike
RA40 is offline   Reply With Quote
Old 08-06-14, 11:56 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loud Bang Norman9208 SC 400/300 3 11-10-14 06:43 AM
SUSPENSION SHOCK went bad? JiTeng Suspension 3 10-11-14 07:25 AM
help! - loud clanging rattle under car at speed LScowboyLS LS400 5 12-12-12 06:27 PM
Loud bangs followed by white smoke!! Fatony LS430 13 12-26-11 11:44 PM
Loud bang!!! lkapimp216 GS - Third Generation 14 12-17-10 08:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 06:19 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info