Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS400
Sign in using an external account
Register Forgot Password?

LS 400 instrument cluster

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-14-14, 09:52 PM   #1
Xica
Driver School Candidate
Trader Score: (0)
 
Join Date: Feb 2014
Location: CA
Posts: 1
Default LS 400 instrument cluster

I have a 1990 LS400 and the instrument cluster is going wacky. First off the speedometer is reading 15 mph slower than actual speed. Also the indicator light that says there is a burned out tail light is on but all of the tail light bulbs are working. When I am driving the car and step on the brake pedal the brakes grab slightly and the "R" lights up on the shift light column and the dash light turns off. I am guessing I need to replace the instrument gauge cluster but would appreciate any input if anyone else has experienced this.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
Xica is offline   Reply With Quote
Old 07-15-14, 05:15 AM   #2
usoff89
Lexus Test Driver
Trader Score: (2)
 
usoff89's Avatar
 
Join Date: Jun 2012
Location: florida
Posts: 1,127
Default

Have you tried searching the forum? I see this is your first post..... You might want to post this in the actual LS400 thread and not the "Build" thread.
__________________
AKA "Dirty Mike"

(93 LS4) - Slammed DD - 5spd swap, Megan coils, 95+ big brakes with Goodridge stainless brake lines. S&S Headers with a custom exhaust, Motegi Touge's 18x9F and 18x10R. SAFC NEO and Innovative Wideband (no numbers yet), and turbo/procharger coming soon.....
usoff89 is offline   Reply With Quote
Old 07-15-14, 10:37 AM   #3
TaninAuto
Sponsor
Trader Score: (0)
 
TaninAuto's Avatar
 
Join Date: May 2012
Location: WI
Posts: 375
TaninAutoElectronix TaninElectronix
Default

We can fix all of these problems or sell you a good working cluster.

The gear shift assembly on the transmission triggers the gear lights so I would start there with that problem. The speedometer problem is the cluster.
__________________
--
Jason Tanin - Owner
Tanin Auto Electronix
Racine, WI
Office - 262-456-4147
www.TaninAutoElectronix.com

http://www.facebook.com/TaninAutoElectronix
TaninAuto is offline   Reply With Quote
Old 07-15-14, 10:37 AM
 
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Illuminating 92 ES300 Instrument Cluster? lluahs ES300 and ES330 0 08-13-14 05:54 PM
VA Cluster, tail lights spike_um SC400 / 300 Classifieds 7 11-01-13 04:13 PM
1992 SC400, instrument cluster stays JaySC400 Performance & Maintenance 1 02-16-13 07:28 AM
Swap SC400 1993 instrument cluster with 1995? scott8851 SC 400/300 1 08-06-12 06:05 PM
Lexus ls400 instument cluster light off anthonyini LS400 2 08-06-12 03:05 AM

All times are GMT -7. The time now is 09:58 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info