Club Lexus Forums

Club Lexus Forums (http://www.clublexus.com/forums/)
-   LS400 (http://www.clublexus.com/forums/ls400-183/)
-   -   What did you do to your LS400 today? (http://www.clublexus.com/forums/ls400/657775-what-did-you-do-to-your-ls400-today.html)

E36M3 09-29-12 08:46 AM

What did you do to your LS400 today?
 
Today is Saturday, 9/29/12, and I will be doing the radio antenna cable conversion to the cell phone cable. Since my radio antenna is stuck halfway, it is time to either replace it or get creative. I will try to take pictures as I go along and I will post them in here once it is completed.

So for those of you that have projects or repairs you want to do to your LS400, post in here.

hotdawwg 09-29-12 01:08 PM

Cool


I just detailed my LS so it looks almost brand new!

E36M3 09-29-12 03:24 PM

I did not continue the project or repair because my radio antenna cable isn't connected to either the radio antenna or the phone cable and yet I have a good reception. I don't know how I'm getting a signal.

Note: The previous owner installed a hi-tech Pioneer double din touch screen radio. I'm guessing during the install they installed an antenna somewhere.

hotdawwg 09-29-12 03:30 PM

I believe they Made an glass antenna for the newer radios...

E36M3 09-29-12 03:36 PM

Quote:

Originally Posted by hotdawwg (Post 7513170)
I believe they Made an glass antenna for the newer radios...

Maybe that explains it.

SpencerT 09-29-12 05:37 PM

you will get good reception regardless whether or not your antenna is plugged in.
Keep the antenna wire plugged up just unplug the antenna motors for increased reception.

JradCelly 09-29-12 06:10 PM

Yesterday and the day before ( thurs-friday ) I installed subs in my Celsior :) . Had to run the power wire through and tucked all the wires away in the kickpanels / side panels for a seamless install , took a while to do but looks great !

lonnie247 09-29-12 06:20 PM

Changed the air filter. It's not much, but you asked.

davids2k 09-29-12 06:27 PM

Today, I switched out my old fuel sending unit to a new one. my gas gauge finally works now yayyyy!

shoob 09-29-12 07:22 PM

Quote:

Originally Posted by hotdawwg (Post 7513018)
Cool


I just detailed my LS so it looks almost brand new!


same here, hopefully my new wheel setup will be on by sunday evening. i plan on shaving my oem antenna and perhaps running dual presidential style in the future, or just keep it shaved and go with a windsheild ant

Shmee 09-29-12 08:34 PM

I bought my first of what is likely to be many Lexus's today. got my hands on a nice Silver Metallic on grey 1996 LS400 with 180k km. paid $3600 out the door. it had a rebuilt title but i saw pictures of the damage and it was just bumped in the left rear corner which wrinkled the rear 1/4 and muffed up the bumper. the insurnace company didn't even assess the damages properly and just wrote it off on the spot! lucky me because the car is very clean otherwise.

Ordering depo tails, and headlights along with BC coilovers tomorrow or monday! I also got my hands on a free set of 06 GS 18s with brand new Conti-3s on them for the interim while i figure out what i want to run.

will also be ordering a bunch of require service parts right away as the front brakes need to be done pretty soon!

Timing belts and water pumps every 90,000MILES, right? Not KM?

cobalt91 09-30-12 10:37 AM

Welcome. Miles is correct. Post pics.

timmy0tool 10-02-12 01:26 PM

Quote:

Originally Posted by JradCelly (Post 7513381)
Yesterday and the day before ( thurs-friday ) I installed subs in my Celsior :) . Had to run the power wire through and tucked all the wires away in the kickpanels / side panels for a seamless install , took a while to do but looks great !

any tips on where to run the power wire through the firewall into the cabin? i need to do this as well and have no idea where to pass the power wire. pass side or drivers side?

Shmee 10-02-12 05:15 PM

So i go pick up a new battery today. I stop at Starbucks on my way home to grab a coffee with a buddy only to come out and have the car not want to start. To top it off, I find out they gave me the wrong battery at the parts store. YAY! Luckily it was close so I walk the 3 blocks back to parts store with the awkward 60lbs battery, get the right one, walk back an install on the side of the road! HAH-ZAAH!? she runs and all the little glitchy little electrical problems are now gone. old battery was 9 years old!

Also, I Just ordered almost all the parts needed to bring the Rexxus back up to top form: new brakes, BC BR coils, all the tune-up parts, 96k engine fluid service stuff, replacements for the broken headlight and taillight with Deop Crystal clear and LED stuff!

Still need to order all the timing and serpentine belt stuff, new motor mounts.

Oh and I installed the loner 06 GS430 wheels... Looks pretty good but definitely needs more lows and MUCH bigger wheels. 18s just look awkwardly small.... I think these cars need 20s to really fill out the wheel wells and get the right stance... could also be the width and offsets that are not helping the situation but i'm no longer looking for 19s....

I'll post some pics later tonight.


All times are GMT -7. The time now is 04:05 PM.


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved