Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS400
Sign in using an external account
Register Forgot Password?

What did you do to your LS400 today?

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 11-03-12, 01:27 AM   #151
hotdawwg
Pole Position
Trader Score: (0)
 
hotdawwg's Avatar
 
Join Date: Jan 2011
Location: Ca
Posts: 242
Hotdawwgman
Default

Yeah I guess... It was weird... I was driving on the 15 going to Vegas and the trains just acted like it wasn't engaged into drive as if it poped out of gear... It did it 3 times before I had it towed back to Fullerton and my buddies shop. We cracked it open today and the fluid was stinky burnt. Fluid was light red compared to dark red like Toyota IV is supposed to look... After I pulled the Trans cover off I noticed the filter was hella dirty. Took it off and tried to clean it but no, so I went and got a new one for $17 and replaced the fluid after I put the cover back back on... I will double check tomorrow to make sure it is full... So far it drives good but we will see....
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
__________________
1995 Ebony Teal Pearl with Black interior. LED's and tint for now... Stay tuned...


Team Outcast Vice President
hotdawwg is offline   Reply With Quote
Old 11-03-12, 11:41 AM   #152
Dranom
Lead Lap
Trader Score: (7)
 
Join Date: May 2009
Location: SoCal
Posts: 583
Default

Quote:
Originally Posted by hotdawwg View Post
Yeah I guess... It was weird... I was driving on the 15 going to Vegas and the trains just acted like it wasn't engaged into drive as if it poped out of gear... It did it 3 times before I had it towed back to Fullerton and my buddies shop. We cracked it open today and the fluid was stinky burnt. Fluid was light red compared to dark red like Toyota IV is supposed to look... After I pulled the Trans cover off I noticed the filter was hella dirty. Took it off and tried to clean it but no, so I went and got a new one for $17 and replaced the fluid after I put the cover back back on... I will double check tomorrow to make sure it is full... So far it drives good but we will see....
Damn! Good luck bro! Hopefully it doesnt act up anymore
Dranom is offline   Reply With Quote
Old 11-03-12, 03:06 PM   #153
Ls400RR
Rookie
Trader Score: (0)
 
Join Date: Sep 2012
Location: Md
Posts: 68
Default

A lot of buffing
Ls400RR is offline   Reply With Quote
Old 11-03-12, 03:33 PM   #154
SpencerT
Lead Lap
Trader Score: (0)
 
SpencerT's Avatar
 
Join Date: Jan 2012
Location: virginia
Posts: 470
Default

Tried to fix my speedometer.
It had the common problem of sticking at zero.
About 6 months ago, I installed pins to keep the needle from ever hitting zero.
They have never stuck since but...
Tach worked perfect. Speedo was 15 mph fast ever since.

Today I installed new pins, closer to zero for the speedo. Then started the car and reset the needle at zero hoping that I had solved my problem.

Speedo is now 7 mph fast... fml
All I suceeded in doing was to make my math more difficult to determine my actual speed.
Atleast my needles dont stick anymore...
__________________
DWP 95 LS400
Kyb + Tanabe, 18" IS350 wheels
200k + club!
More to come
SpencerT is offline   Reply With Quote
Old 11-03-12, 03:42 PM   #155
E36M3
Driver
Trader Score: (0)
 
E36M3's Avatar
 
Join Date: Sep 2012
Location: CA
Posts: 108
Default

Quote:
Originally Posted by SpencerT View Post
Tried to fix my speedometer.
It had the common problem of sticking at zero.
About 6 months ago, I installed pins to keep the needle from ever hitting zero.
They have never stuck since but...
Tach worked perfect. Speedo was 15 mph fast ever since.

Today I installed new pins, closer to zero for the speedo. Then started the car and reset the needle at zero hoping that I had solved my problem.

Speedo is now 7 mph fast... fml
All I suceeded in doing was to make my math more difficult to determine my actual speed.
Atleast my needles dont stick anymore...
Well the bright side is no more sticking needle.
__________________

1994 Lexus SC400 - Daily
2001 328Ci Supercharged / Show Car - 405 Hp / 398 Tq - FOR SALE
E36M3 is offline   Reply With Quote
Old 11-03-12, 03:55 PM   #156
SpencerT
Lead Lap
Trader Score: (0)
 
SpencerT's Avatar
 
Join Date: Jan 2012
Location: virginia
Posts: 470
Default

Quote:
Originally Posted by E36M3 View Post
Well the bright side is no more sticking needle.
Yea, its an improvement for sure. Ill get it right eventually.
It is just such a pita to remove the cluster to work on it.

To anybody with my original problem of sticky needles, I would be glad to give advice because I have been there and done that. Multiple times.
__________________
DWP 95 LS400
Kyb + Tanabe, 18" IS350 wheels
200k + club!
More to come
SpencerT is offline   Reply With Quote
Old 11-03-12, 04:39 PM   #157
Dutchy
Driver
Trader Score: (0)
 
Join Date: Oct 2012
Location: Netherlands
Posts: 138
Default

yesterday i bought a set coilovers second hand for a nice price. Next weekend i will install them on my work if i have the time for it



Dutchy is offline   Reply With Quote
Old 11-13-12, 10:42 PM   #158
DertyDOH
Rookie
Trader Score: (0)
 
Join Date: Apr 2012
Location: SC
Posts: 73
Default

put in phillis clearvision bulbs into the stock housings today, made a huge difference, only $25 via amazon, getting the corner lights out was a huge pain though
Attached Images
   
DertyDOH is offline   Reply With Quote
Old 11-14-12, 10:30 PM   #159
Dranom
Lead Lap
Trader Score: (7)
 
Join Date: May 2009
Location: SoCal
Posts: 583
Default

Washed my car since it was dirty but Looks like it might rain this weekend so FML -_-

Last edited by Dranom; 11-15-12 at 05:05 PM.. Reason: bad, censor is there for a reason. :|
Dranom is offline   Reply With Quote
Old 11-15-12, 04:53 PM   #160
Sc0pe
Lexus Test Driver
Trader Score: (1)
 
Sc0pe's Avatar
 
Join Date: Nov 2012
Location: Florida
Posts: 836
pcheriyan007
Default

Well, we bought it, if that counts
Sc0pe is offline   Reply With Quote
Old 11-15-12, 11:11 PM   #161
E36M3
Driver
Trader Score: (0)
 
E36M3's Avatar
 
Join Date: Sep 2012
Location: CA
Posts: 108
Default

Quote:
Originally Posted by Sc0pe View Post
Well, we bought it, if that counts
What did you buy?
__________________

1994 Lexus SC400 - Daily
2001 328Ci Supercharged / Show Car - 405 Hp / 398 Tq - FOR SALE
E36M3 is offline   Reply With Quote
Old 11-16-12, 08:45 PM   #162
Sc0pe
Lexus Test Driver
Trader Score: (1)
 
Sc0pe's Avatar
 
Join Date: Nov 2012
Location: Florida
Posts: 836
pcheriyan007
Default

Quote:
Originally Posted by E36M3 View Post
What did you buy?
The car itself Refer to my sort of intro/build thread if you want to see more.
Sc0pe is offline   Reply With Quote
Old 11-17-12, 01:33 AM   #163
IBOO57
Driver School Candidate
Trader Score: (0)
 
Join Date: Sep 2012
Location: Australia
Posts: 42
Default

Gave the Celsior a Polish today. My arms munted but it looks good now!
IBOO57 is offline   Reply With Quote
Old 11-17-12, 03:21 AM   #164
SPhoto
Lead Lap
Trader Score: (0)
 
SPhoto's Avatar
 
Join Date: Mar 2009
Location: Hawaii
Posts: 423
Default

I forgot to post, but this was yesterday...I finally received my parts for timing belt/water pump, and tune up job.

Click the image to open in full size.
SPhoto is offline   Reply With Quote
Old 12-01-12, 03:27 PM   #165
RA40
Moderator
Trader Score: (6)
 
RA40's Avatar
 
Join Date: May 2003
Location: California
Posts: 15,855
Default

Last night's pick-up. Local Toyota dealer sent out $3.99/quart coupon. I couldn't get to that dealer but the other one did a price match. One of the upcoming weekends I'll do the partial drain. As well, the Toyota dealer sold the crush washers at $2.30 not the $6.95 one Lexus dealer nailed me for.

Click the image to open in full size.

Click the image to open in full size.
__________________

Mike
RA40 is offline   Reply With Quote
Old 12-01-12, 03:27 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Antenna Mast wont go up or down???? $635.00 for a Radio Antenna rclab1 SC 430 12 05-03-13 01:30 PM
Has anyone installed the TRK-SR2 XM Kit ? PHOUND5 LS430 2 01-04-12 08:25 AM
Sirius Puck Antenna Problem... levinsoy GS - Third Generation 9 03-27-11 07:30 AM
Replace SC430 Antenna hlovepenn SC 430 13 07-09-09 11:21 PM
Power antenna probs BBriBro SC 400/300 7 05-25-09 01:21 PM


Tags
99, antenna, auto, automotive, car, cell, diy, home, hook, ls400, mans, phone, poor, ramps, splicing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 11:17 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info