Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS400
Sign in using an external account
Register Forgot Password?

engine problem

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-19-11, 08:57 AM   #1
weiss
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Location: va
Posts: 9
Default engine problem

1997 lexus ls400 204500 miles, engine light is on code P0340 (cam shaft position sensor bank 1), rough idle at start, once the car warms up it runs ok but loss of power, hesitates, if press more on gas pedal the car jerks. i have replaced both cam shaft position sensors and engine coolant temp sensor but no improvement. any ideas what could be the problem?
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
weiss is offline   Reply With Quote
Old 05-19-11, 09:02 AM   #2
Bill Dowd
Pole Position
Trader Score: (0)
 
Join Date: Jul 2007
Location: California
Posts: 393
Default

check the MAS to see if it is dirty they make a MAS cleaner you can buy mine did something similar and I cleaned it and works good now this may not be your problem just an idea
Bill Dowd is offline   Reply With Quote
Old 05-19-11, 10:49 AM   #3
PureDrifter
BahHumBug
Trader Score: (10)
 
PureDrifter's Avatar
 
Join Date: Aug 2004
Location: California
Posts: 22,713
PureDrifter
Send a message via AIM to PureDrifter
Default

check the wiring to the CPS and grab a timing light (and check lexls iirc) to confirm that the timing is right on.
__________________
1. Black on Black 1999 LS400 PM-spec
-Maya-Megan-Magnaflow-LSportline-Xenondepot-PPE Engineering-Duce-Platinum VIP-Figs Engineering-R1Concepts-
2. Black 2001 MR2 Spyder -#muchroadster-
3. Black 2004 IS300 -Manaray-HKS-Eibach-Kumho-
4. Ebony Teal 1995 LS400 11-8-06
PureDrifter is offline   Reply With Quote
Old 05-19-11, 09:57 PM   #4
weiss
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Location: va
Posts: 9
Default

What's a Timing light?
weiss is offline   Reply With Quote
Old 05-20-11, 01:12 AM   #5
PureDrifter
BahHumBug
Trader Score: (10)
 
PureDrifter's Avatar
 
Join Date: Aug 2004
Location: California
Posts: 22,713
PureDrifter
Send a message via AIM to PureDrifter
Default

Quote:
Originally Posted by weiss View Post
What's a Timing light?
.....google....
__________________
1. Black on Black 1999 LS400 PM-spec
-Maya-Megan-Magnaflow-LSportline-Xenondepot-PPE Engineering-Duce-Platinum VIP-Figs Engineering-R1Concepts-
2. Black 2001 MR2 Spyder -#muchroadster-
3. Black 2004 IS300 -Manaray-HKS-Eibach-Kumho-
4. Ebony Teal 1995 LS400 11-8-06
PureDrifter is offline   Reply With Quote
Old 05-20-11, 06:16 AM   #6
deanshark
Lexus Champion
Trader Score: (0)
 
Join Date: Dec 2009
Location: ct
Posts: 1,983
Default

Quote:
Originally Posted by weiss View Post
What's a Timing light?
It's what we used in the good ol' days to make the cars run correctly, before computors.
deanshark is offline   Reply With Quote
Old 05-20-11, 01:39 PM   #7
TrAPsTaR87
Driver School Candidate
Trader Score: (0)
 
TrAPsTaR87's Avatar
 
Join Date: May 2011
Location: ca
Posts: 28
Default

Sounds like the TPS sensor which stands for throttle position sensor
TrAPsTaR87 is offline   Reply With Quote
Old 05-20-11, 10:21 PM   #8
weiss
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Location: va
Posts: 9
Default

Where is TPS located at?
weiss is offline   Reply With Quote
Old 05-21-11, 09:21 AM   #9
deanshark
Lexus Champion
Trader Score: (0)
 
Join Date: Dec 2009
Location: ct
Posts: 1,983
Default

Quote:
Originally Posted by weiss View Post
Where is TPS located at?
Are you kidding me? Does everyone not know how to SEARCH? http://www.lexls.com/tutorials/EFI/tps.html
Throttle = fuel. Fuel = Throttle body. = Throttle position sensor. In the future try searching before asking.
deanshark is offline   Reply With Quote
Old 05-21-11, 12:38 PM   #10
deanbrown
Pole Position
Trader Score: (0)
 
deanbrown's Avatar
 
Join Date: Aug 2005
Location: NJ
Posts: 360
Default

Yep I would say if you don't know what a timing light is or where the tps is, you should either do a bunch of studying or go and fine a mechanic, or you risk frigging something up.
deanbrown is offline   Reply With Quote
Old 05-24-11, 09:42 AM   #11
weiss
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Location: va
Posts: 9
Default

I'm not a mechanic, just wanted to get some info.
weiss is offline   Reply With Quote
Old 05-24-11, 01:24 PM   #12
weiss
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Location: va
Posts: 9
Default

here is a youtube video link of how the car sounds...
http://www.youtube.com/watch?v=LgRYf-guWgg
weiss is offline   Reply With Quote
Old 05-25-11, 09:35 AM   #13
deanshark
Lexus Champion
Trader Score: (0)
 
Join Date: Dec 2009
Location: ct
Posts: 1,983
Default

Quote:
Originally Posted by kigkug View Post
I thing first you must check code engine
God bless computorized translation. Need a translator for the translator.
deanshark is offline   Reply With Quote
Old 05-25-11, 01:28 PM   #14
weiss
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2011
Location: va
Posts: 9
Default

code is P0340 camshaft position sensor which has already been replaced) , anyone has any suggestions?
weiss is offline   Reply With Quote
Old 05-25-11, 04:57 PM   #15
deanshark
Lexus Champion
Trader Score: (0)
 
Join Date: Dec 2009
Location: ct
Posts: 1,983
Default

Quote:
Originally Posted by weiss View Post
code is P0340 camshaft position sensor which has already been replaced) , anyone has any suggestions?
I would go with the suggestion already mentioned by PureDrifter "check the wiring to the CPS and grab a timing light (and check lexls iirc) to confirm that the timing is right on." If the timing is off just by a tick, it could throw a CPS code. If the wiring connections are all plugged in and the wires aren't cut somewhere then maybe there's a problem with the ECU.
deanshark is offline   Reply With Quote
Old 05-25-11, 04:57 PM
 
 
 
 
Reply

Tags
05, 1997, 400, cam, camshaft, car, cps, failure, is300, lexus, location, ls, ls400, position, sensor, tps

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No spark on driver side plugs kohatsu LS400 17 04-29-14 11:48 AM
1994 es 300 scotty9674 ES300 and ES330 4 06-16-13 07:24 PM
Cam Shaft Position Sensor landarc GS - Second Generation 6 05-13-13 07:22 AM
About code P1346 StopOnce IS - First Generation 2 10-27-12 11:10 PM
my first issue. check engine. (code- malfunctioning cam-angle sensor) RomanTPA LS430 16 07-14-10 08:07 AM

All times are GMT -7. The time now is 02:54 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info