Go Back   Club Lexus Forums > Lexus Model Forums > LS Models > LS400
Sign in using an external account
Register Forgot Password?

Mechanic Says Replace ECU/ECM - HELP!

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 04-23-04, 10:24 AM   #1
dknoxking
Rookie
Trader Score: (0)
 
Join Date: Apr 2004
Location: New York
Posts: 53
Default Mechanic Says Replace ECU/ECM - HELP!

My mechanic says I need to replace my ECU. It is a 93 LS 400. Do I go with a "new" or used?
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
dknoxking is offline   Reply With Quote
Old 05-18-04, 01:34 PM   #2
cnacne
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2002
Location: Illinois
Posts: 27
Send a message via AIM to cnacne
Default

Can you tell us a bit more? Why are you being told to replace the ECU? What symptoms were you having that made you bring the car to the mechanic?


Joe
cnacne is offline   Reply With Quote
Old 05-18-04, 01:47 PM   #3
dknoxking
Rookie
Trader Score: (0)
 
Join Date: Apr 2004
Location: New York
Posts: 53
Default

I did have the ECU replaced. Car would occasionally not start. Would run very rough when cold. It was odd. My mechanic hooked it up to his computer and could not get a reading. Hope this helps. david
dknoxking is offline   Reply With Quote
Old 05-21-04, 07:37 AM   #4
Strida
Rookie
Trader Score: (0)
 
Join Date: Oct 2002
Location: Canada
Posts: 94
Default

Quote:
Originally posted by dknoxking
I did have the ECU replaced. Car would occasionally not start. Would run very rough when cold. It was odd. My mechanic hooked it up to his computer and could not get a reading. Hope this helps. david
I think you just wasted your money on a replacement ECU. I dont think those problems are ECU related.
__________________
http://jp.z.com/HERITAGE/Z32/IMAGES/img01.jpg 1995 Dark Emerald LS400
Strida is offline   Reply With Quote
Old 05-21-04, 08:15 AM   #5
dknoxking
Rookie
Trader Score: (0)
 
Join Date: Apr 2004
Location: New York
Posts: 53
Default

If you say so, but the car runs perfect now!
dknoxking is offline   Reply With Quote
Old 05-21-04, 09:30 AM   #6
Strida
Rookie
Trader Score: (0)
 
Join Date: Oct 2002
Location: Canada
Posts: 94
Default

Quote:
Originally posted by dknoxking
If you say so, but the car runs perfect now!
If it worked, great. But those things could have been related to something else ie. cloged fuel filter, pcv, a much needed tune up? Did the check engine light even came on? But if changing the ECU worked, congrats.
__________________
http://jp.z.com/HERITAGE/Z32/IMAGES/img01.jpg 1995 Dark Emerald LS400
Strida is offline   Reply With Quote
Old 05-21-04, 09:34 AM   #7
dknoxking
Rookie
Trader Score: (0)
 
Join Date: Apr 2004
Location: New York
Posts: 53
Default

Thanks! Yes the check engine light did come on. I am glad it worked!
dknoxking is offline   Reply With Quote
Old 06-17-04, 09:05 PM   #8
LexLS
Lexus Test Driver
Trader Score: (0)
 
Join Date: Mar 2003
Location: Minnesota
Posts: 1,176
Default

So you had a new ECU installed, right? How much did that set you back?

Good to hear it worked .
__________________
Check out my LS website http://www.lexls.com/, updated 06/01/13.
LexLS is offline   Reply With Quote
Old 06-18-04, 08:42 AM   #9
dknoxking
Rookie
Trader Score: (0)
 
Join Date: Apr 2004
Location: New York
Posts: 53
Default

It was not cheap..........My mechanic, who is not affiliated with a Lexus Dealership, had to order the part from Lexus. The dealership sent a "remanufactured" ECU, so it was a little less than I originally thought. The part was $918 installed. So far so good!
dknoxking is offline   Reply With Quote
Old 06-27-04, 10:11 PM   #10
JPI Racing
Lexus Champion
Trader Score: (0)
 
Join Date: Jun 2003
Location: Texas
Posts: 2,079
Default

I'm glad you got it fixed. I hardly see an ECU fail though not on Lexus. What diagnost did he do? I;m just curious.
JPI
JPI Racing is offline   Reply With Quote
Old 06-27-04, 10:11 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone replaced brake actuator and accumulator? rhwimmers GS - Third Generation 6 09-19-14 11:46 PM
ECU replacement and compatability for my GS300 98,and general issues kondratus GS - Second Generation 5 08-11-13 09:35 AM
Looking for North Atlanta 1995 Sc300 Owner!s klobb92 Southeast 0 06-24-13 10:20 PM
Engine ECU Facts MUCH2PHAAT Performance & Maintenance 14 05-22-11 01:16 PM
Do i need to re-program my used "ecu"??????????????? 1WILLY1 SC 400/300 4 07-27-10 09:51 PM


Tags
1995, 300, 400, 92, computer, ecm, ecu, forum, fuel, gs, lexus, ls400, lx470, photo, reman, replace, replaced, replacing, starting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 01:17 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info