Mark Levinson Amp Repair - Club Lexus Forums

Log In 

Mark Levinson Amp Repair

Reply
 
 
 
Thread Tools Search this Thread
Old 10-14-10, 11:04 AM   #1
oscarls460
Driver School Candidate
Thread Starter
 
Join Date: Jun 2010
Location: CA
Posts: 4
Default Mark Levinson Amp Repair

I just wanted to let eveyone one that has had Mark Levinson AMP issues that there is help out there. I sent my AMP to

United Radio
5705 Enterprise Pkwy
East Syracuse NY 13507
315-446-5570

They repaired it for 325.00 dollars and shipped it back with in a day of receiving it.

plugged it back in and back in business.

Oscar
oscarls460 is offline   Reply With Quote
Old 10-14-10, 12:00 PM   #2
HyperMKIV
Lexus Champion
iTrader: (1)
 
HyperMKIV's Avatar
 
Join Date: Feb 2001
Location: ca
Posts: 2,266
Default

good to know... thanks!!!
HyperMKIV is offline   Reply With Quote
Old 10-14-10, 12:26 PM   #3
cmasten
Lead Lap
 
Join Date: Jun 2009
Location: ca
Posts: 740
Default

has anyone with a non-ML system ever had a Panasonic amp go bad? I dont know who makes the ML amps, but they seem to have a very high failure rate from what I read
cmasten is offline   Reply With Quote
Old 02-18-11, 03:33 PM   #4
yenyunt
Driver School Candidate
 
Join Date: Oct 2010
Posts: 10
Wink

Quote:
Originally Posted by oscarls460 View Post
I just wanted to let eveyone one that has had Mark Levinson AMP issues that there is help out there. I sent my AMP to

United Radio
5705 Enterprise Pkwy
East Syracuse NY 13507
315-446-5570

They repaired it for 325.00 dollars and shipped it back with in a day of receiving it.

plugged it back in and back in business.

Oscar
Thanks so much for your valuable information, my LX-470 suffering same thing and i will be sending to United Radio, i just learned about they company and they are BIG and highly reputable company. Quote is same as flat $325. I will not buy use from ebay with high risk nor exchange from dealer. Because United Radio still offer one year warranty. Company seems very organized. I sopke with CS lady and they are very professional. How is your unit working as of now? I can be reached at yenyunt@bcbg.com
Thanks again
Ye
yenyunt is offline   Reply With Quote
Old 02-18-11, 05:56 PM   #5
CJITTY
Moderator
 
CJITTY's Avatar
 
Join Date: Jul 2010
Location: The South
Posts: 4,564
Default

wow, thank you for posting..i got the 100K warranty, so hopefully if mine goes out, it will do it before then, but this will make a lot of folks feel better
CJITTY is online now   Reply With Quote
Old 04-13-11, 07:02 AM   #6
AirRideFan
Pole Position
iTrader: (1)
 
Join Date: Sep 2010
Location: PA
Posts: 268
Default

This is FANTASTIC info!!! Thanks so much for the info, OP --> oscarls460! This is great. What year is your LS? '07? ...and the amp went bad already !?!?!? Jeeez. My GS430 is an '01.. really a "MINT" car- but I'm surprised my ML amp has made it THIS far before blowing...with all the things I've read about their interals/heat sinks, etc.
WOW.
AirRideFan is offline   Reply With Quote
Old 04-13-11, 07:38 AM   #7
Nospinzone
Moderator
 
Nospinzone's Avatar
 
Join Date: Mar 2007
Location: MA
Posts: 2,932
Default

Maybe it only seems to me like a lot of these thing are blowing, but there appears to be a real problem with these amps. If that is truly the case, Lexus should warrant these for a longer period. If not it might be cause for a class action suit.
Nospinzone is offline   Reply With Quote
Old 04-13-11, 09:18 AM   #8
marky2mark
Driver
 
Join Date: Nov 2010
Location: CA
Posts: 142
Default

The car audio shop that did my aftermarket upgrade said they get a LOT of people coming in to replace blown ML amps.
marky2mark is offline   Reply With Quote
Old 04-13-11, 06:55 PM   #9
Shibumi1
Lexus Champion
 
Shibumi1's Avatar
 
Join Date: May 2010
Location: Orlando STRONG!!
Posts: 1,688
Default

Quote:
Originally Posted by marky2mark View Post
the car audio shop that did my aftermarket upgrade said they get a lot of people coming in to replace blown ml amps.
thats a 19 channel amp how could they replace that for anywhere near $325..

Im workin on upgrading the whole system (minus headunit) an to do it properly and retain dolby dts u need no less than (3)4 channel amps b4 u even start w sub bass.. I know phoenix gold jus released something "plug n play" but thats a 5 channel w a built in sub.. Plz get me some more info
Shibumi1 is offline   Reply With Quote
Old 04-14-11, 03:17 AM   #10
marky2mark
Driver
 
Join Date: Nov 2010
Location: CA
Posts: 142
Default

I think he has a place where he can get refurbished ML amps. But I'm sure they charge a lot more than 325. Sounds like United is your best bet unless you want to spend some jack.

Mine was non-ML so I only needed one JL amp and an oem interface unit.
marky2mark is offline   Reply With Quote
Old 04-14-11, 03:52 AM   #11
Shibumi1
Lexus Champion
 
Shibumi1's Avatar
 
Join Date: May 2010
Location: Orlando STRONG!!
Posts: 1,688
Default

that makes sense..
Shibumi1 is offline   Reply With Quote
Old 04-14-11, 06:36 AM   #12
vancouverl
Driver
 
Join Date: Dec 2010
Location: canada
Posts: 120
Default

My amp just went it is ml on a 07 .Speakers front began to rattle at high volumes and only on hot days . I started to notice it when the trunk was full but thought it had to do with distortion of the base seing the trunk was full .Had 1 day of warranty left when I took it in .Waiting for new amp .
vancouverl is offline   Reply With Quote
Old 04-14-11, 05:23 PM   #13
wrc7732
Driver School Candidate
 
Join Date: Feb 2011
Location: GA
Posts: 25
Default

Mine was replaced under warranty at around 25,000 miles. After noticing where the ML amp is in the trunk, my thought is that perhaps they are overheating. I imagine that with the high quantity of speakers and the relatively high quality sound for a factory system, that the amp may generate a decent amount of heat. I wonder if removing the part of the trunk floor covering the amp or adding some type of cooling ventilation to the amp area would increase the life of these amps. I have certainly experienced amp failure in the past due to over heating and I wonder if that's what's happening to these amps.
wrc7732 is offline   Reply With Quote
Old 04-14-11, 05:34 PM   #14
Shibumi1
Lexus Champion
 
Shibumi1's Avatar
 
Join Date: May 2010
Location: Orlando STRONG!!
Posts: 1,688
Default

cooling fan sounds like an excellent idea... as it drive so many speakers an has a very small footprint.. that means it has little surface area for heat to dissipation.. an trunks tend to stay warmer longer..
Shibumi1 is offline   Reply With Quote
Old 04-19-11, 09:37 AM   #15
AirRideFan
Pole Position
iTrader: (1)
 
Join Date: Sep 2010
Location: PA
Posts: 268
Default

Quote:
Originally Posted by marky2mark View Post
I think he has a place where he can get refurbished ML amps. But I'm sure they charge a lot more than 325. Sounds like United is your best bet unless you want to spend some jack.

Mine was non-ML so I only needed one JL amp and an oem interface unit.
Are you talking about in an LX ? I have an '01 GS430... 8 speakers, total. My amp is not turning on, when I first turn the car on... then after about 5 mins, the music will start playing (Nav voice works fine- all the time though)
It's driving me crazy!!!

NOW, it started popping and crackling.. almost like it has a bad connection, but I'm pretty sure it's INTERNAL, in the ML amp...

I'm going to call this United Radio and see what they think it might be.

Also- I know the '02-'05 (ALL "OTHER" years of my body style GS) use a different part # Mark Levinson amp. Go figure.. '01's are the most unreliable, I'm pretty sure.
AirRideFan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
CA WTB: wheel hub SEXC SC400 / 300 Classifieds 5 12-27-15 02:57 AM
Mark Levinson audio dead ChuckB669 LX - 1st and 2nd Gen (1997-2007) 2 04-14-15 09:39 PM
Mark Levinson Amp Mhobizal ES - 6th Gen (2013-present) 12 03-09-15 06:41 PM
Will adding a amp and sub to a CPO IS F void warranty AshyAnklez IS F (2008-2014) 11 01-03-15 09:30 AM
Mark Levinson danspeeple GS - 4th Gen (2013-present) 25 09-01-14 11:40 PM


Tags
460, amp, amplifier, ca, car, fix, levinson, lexus, luxse, mark, repair, repairing, shop, stopped, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 05:39 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved