LS 430 Acceleration issues - Page 2 - Club Lexus Forums

Log In 

LS 430 Acceleration issues

Reply
 
 
 
Thread Tools Search this Thread
Old 07-14-14, 08:01 PM   #16
forthewin
Driver School Candidate
 
forthewin's Avatar
 
Join Date: Jun 2014
Location: Ontario
Posts: 42
Default

Good to know
forthewin is offline   Reply With Quote
Old 07-15-14, 04:50 PM   #17
Nojoi
Driver School Candidate
 
Join Date: Oct 2009
Location: MO
Posts: 32
Default

MAF or TB.
Nojoi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Upshifting early RushNatU LS - 3rd Gen (2001-2006) 6 04-02-16 03:57 PM
accelerator - hard to push? johnnylt LS - 3rd Gen (2001-2006) 3 08-15-15 06:15 AM
1994 es300 slow acceleration/ hesitation at take off Betsy1994 ES - 1st to 4th Gen (1990-2006) 1 06-26-15 04:29 AM
Thump noise with quick acceleration tgonder GS - 2nd Gen (1998-2005) 17 02-05-15 11:14 AM
engine misses panhead52 LS - 1st and 2nd Gen (1990-2000) 7 10-18-14 10:41 AM


Tags
2001, 430, accelaration, acceleration, car, info, issue, lexus, ls, ls430, lsmodels, models, poor, problem, problems, thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 05:11 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved