AFS OFF Light flashing - Club Lexus Forums

Log In 

AFS OFF Light flashing

Reply
 
 
 
Thread Tools Search this Thread
Old 01-30-08, 03:02 AM   #1
scottmcc
Rookie
Thread Starter
 
Join Date: Dec 2007
Location: Michigan
Posts: 92
Default AFS OFF Light flashing

Hello all

I am on a business trip hundreds of miles away from my home and MANUALS.. It has been raining alot while I have been traveling and now my AFS OFF light is flashing. Continues to flash for many minutes and then quits.. My headlights seem to be lower (top cutoff line) than normal.. Do the manuals say anything about the Flashing AFS OFF indicator. Is this a auto height leveling problem? I thought maybe that my lights were dirty from the excessive rain so I cleaned them and now it seems like the AFS OFF light does not flash as long but I am not sure.. Just hoping maybe.. Still the lights are adjusted low..

PS.. AFS OFF light continues to flash even if I turn on the AFS OFF switch.. Once the flashing stops and I press the switch the light will come on normally..

Thanks
scottmcc is offline   Reply With Quote
Old 01-30-08, 02:03 PM   #2
GRAND_LS 4
3UZ-FEEEE
iTrader: (2)
 
GRAND_LS 4's Avatar
 
Join Date: May 2004
Location: Northern VA
Posts: 6,224
Default

The AFS indicator will flash for several reasons, including if the sensors are unplugged, or having issues.

Could be your AFS sensors are misaligned, or not operating in good order. Can you count the flashes? or is it constant?

Like i said, i had this problem when i disconnected one of the AFS sensors while i was adjusting my air suspension.


My recommendation: If your going to be doing night time driving, and the lights are aimed too low, i'd drop by a Lexus dealer in your area, and have them look at it.
GRAND_LS 4 is offline   Reply With Quote
Old 02-05-08, 11:07 AM   #3
scottmcc
Rookie
Thread Starter
 
Join Date: Dec 2007
Location: Michigan
Posts: 92
Default AFS Flashing resolved

Finally made it home...Turns out the right rear height control subassy burned up. causing the AFS OFF light to flash.. All charred on the inside.. Looks just like a potentiometer with an O ring around it.. Part is around $300...not under warranty..
scottmcc is offline   Reply With Quote
Old 02-15-08, 04:02 PM   #4
cat6man
Driver School Candidate
 
Join Date: Feb 2008
Location: NJ
Posts: 8
Default

Hi,
Just replaced by 1994 ls400 with a 2005 ls430, 35K miles.
I have the same flashing AFS light problem. You said yours
was not under warranty.....is that because it is not included
in the basic original warranty coverage or because you are beyond
the basic limit on time or mileage?

(background....had the car for just one week and had to go from NJ to MA
for the weekend.....halfway there, this AFS starts flashing and I have no
clue what AFS means yet.......fortunately, it wasn't my engine about to
explode as I learned when I pulled over to read the owner's manual)
cat6man is offline   Reply With Quote
Old 02-15-08, 11:26 PM   #5
GRAND_LS 4
3UZ-FEEEE
iTrader: (2)
 
GRAND_LS 4's Avatar
 
Join Date: May 2004
Location: Northern VA
Posts: 6,224
Default

Quote:
Originally Posted by cat6man View Post
Hi,
Just replaced by 1994 ls400 with a 2005 ls430, 35K miles.
I have the same flashing AFS light problem. You said yours
was not under warranty.....is that because it is not included
in the basic original warranty coverage or because you are beyond
the basic limit on time or mileage?

(background....had the car for just one week and had to go from NJ to MA
for the weekend.....halfway there, this AFS starts flashing and I have no
clue what AFS means yet.......fortunately, it wasn't my engine about to
explode as I learned when I pulled over to read the owner's manual)
Most likely he is over the mileage limit, as warranty covers the AFS system.

Did the problem arise after you turned on your headlights? Maybe one of the sensors was knocked out some point in the trip.
GRAND_LS 4 is offline   Reply With Quote
Old 02-16-08, 05:48 AM   #6
cat6man
Driver School Candidate
 
Join Date: Feb 2008
Location: NJ
Posts: 8
Default

Quote:
Originally Posted by GRAND_LS 4 View Post
Most likely he is over the mileage limit, as warranty covers the AFS system.

Did the problem arise after you turned on your headlights? Maybe one of the sensors was knocked out some point in the trip.
Thanks....great to hear it will be covered......I had the lights on for a while before the problem started.....Since then it is intermittent at startup, sometime not occurring for 5 or 10 minutes........If I'm not mistaken, it sometimes comes on when lights are off as well
cat6man is offline   Reply With Quote
Old 02-16-08, 08:05 PM   #7
mikevanle
Lexus Test Driver
iTrader: (1)
 
mikevanle's Avatar
 
Join Date: Nov 2004
Location: South Jersey
Posts: 1,526
Default

I just recently acquired an LS430 too. The past few days the "AFS OFF" has also been flashing on and off from time to time. But when it does, it does it for hours.

Is there any plugs or self diagnosis I can do myself?
mikevanle is offline   Reply With Quote
Old 02-17-08, 11:36 AM   #8
cat6man
Driver School Candidate
 
Join Date: Feb 2008
Location: NJ
Posts: 8
Default

Quote:
Originally Posted by cat6man View Post
Thanks....great to hear it will be covered......I had the lights on for a while before the problem started.....Since then it is intermittent at startup, sometime not occurring for 5 or 10 minutes........If I'm not mistaken, it sometimes comes on when lights are off as well
confirmed today that it comes on and flashes sometimes even when lights are not turned on........time for a visit to my lexus dealer
cat6man is offline   Reply With Quote
Old 02-18-08, 03:19 AM   #9
mikevanle
Lexus Test Driver
iTrader: (1)
 
mikevanle's Avatar
 
Join Date: Nov 2004
Location: South Jersey
Posts: 1,526
Default

I dunno, I resetted the ECU and it's now gone. So if it doesn't come up again I guess I won't take it to Lexus.
mikevanle is offline   Reply With Quote
Old 02-18-08, 07:56 AM   #10
scottmcc
Rookie
Thread Starter
 
Join Date: Dec 2007
Location: Michigan
Posts: 92
Default

My main reason for getting this fixed was that fact that my lights were shinning considerably too low.. I probably could have lived with the AFS flashing light until I found a cheaper fix. The AFS light would always stop flashing eventually and sometimes it would not flash at all but the HID beams would always be low. I had assumed if I turned OFF the AFS system that the lights should not try to adjust and stay level.

After having it done and seeing how simple the part was to replace, I should have waited but It was more important to have night vision than save a few dollars.

My total repair cost was over $500 but that included an oil change too..

If it happens again, I probably won't replace the part by the dealer as I found there is an adjustment to manually align the HID beams higher..until I can fix it myself..

I have 66000 miles on the car that is why it was not covered under warranty. I have chosen not to spend $2700 on an extended warranty (3yr /30k )as I don't believe I will be needing it. I only drive about 10K a year and the warranty will expire by time before mileage. Yes I know its a crap shoot but I am meticulous on maintenance and care.. I am sure this sensor would not have burned up had I not been in the hellious driving conditions that I was in.. (freezing rain, snow and crap). The car should have stayed home and I should have taken the company vehicle. But I have only put 2k miles on the car and I have owned it for 6 months. I was going through withdrawl..
I will not make that mistake again.. That said, I figure I still have $2200 in the bank for any problems that may occur in the next 3 years.. With Proper care, maintenance and driving decisions I believe I will be O.K.
However I have heard of people getting thier extended warranty for considerably less which I may research..
scottmcc is offline   Reply With Quote
Old 02-21-08, 03:16 PM   #11
cat6man
Driver School Candidate
 
Join Date: Feb 2008
Location: NJ
Posts: 8
Default

Quote:
Originally Posted by mikevanle View Post
I dunno, I resetted the ECU and it's now gone. So if it doesn't come up again I guess I won't take it to Lexus.
1. the problem has disappeared for 3 days now
2. what is 'resetting the ECU'?

thanks
cat6man is offline   Reply With Quote
Old 05-16-11, 12:09 AM   #12
Qnzgs350
Driver School Candidate
 
Join Date: Apr 2011
Posts: 2
Default Had hids put in

I had replace the factory lights with 6000 k hid kits and the fog lights also and I have been drink in rain and not in rain my afs light starts to flash did putting those lights did that void my warranty
Qnzgs350 is offline   Reply With Quote
Old 05-16-11, 12:37 AM   #13
fergo308
Pole Position
 
Join Date: May 2010
Location: NSW - Australia
Posts: 331
Default

I've had this happen on my car a few times recently. Applying the microsoft fix (shutdown and restart) has fixed it each time so far. My headlight alignment doesn't seem to be any different to usual,and once reset,the system tracks as normal.

Might have to check the connections on the lights...


Justin...
fergo308 is offline   Reply With Quote
Old 04-03-16, 10:35 PM   #14
jaunas
Driver School Candidate
 
Join Date: Apr 2016
Location: KLP
Posts: 6
Default

Hello guys,

Pleasure of becoming a part of this forum.
I just acquired IS220d German.
I have couple questions and would love any suggestion or advice you guys have.


First of all, my headlamps does go up/down on start up but does not move left/right while driving. AFS off blinking. So I found this part broken.
Marker no.1 - Ball moves perfectly.
Marker no.2 - Completely stoned ball
Marker no.3 - Broken piece.

Can someone advice if some DIY could fix it ? Does any piece of metal can be put instead of the please no3 ? Is it possible to free the ball no.2 by soaking the part in some kind of liquid ?


Maybe someone knows the part number of this piece as I'm struggling to find any info online?
Any help is much appreciated


jaunas is offline   Reply With Quote
Old 04-05-16, 07:45 PM   #15
Arcturus
Lead Lap
 
Join Date: Nov 2013
Location: Quebec, Canada
Posts: 427
Default

Quote:
Originally Posted by jaunas View Post
Hello guys,

Pleasure of becoming a part of this forum.
I just acquired IS220d German.
I have couple questions and would love any suggestion or advice you guys have.


First of all, my headlamps does go up/down on start up but does not move left/right while driving. AFS off blinking. So I found this part broken.
Marker no.1 - Ball moves perfectly.
Marker no.2 - Completely stoned ball
Marker no.3 - Broken piece.

Can someone advice if some DIY could fix it ? Does any piece of metal can be put instead of the please no3 ? Is it possible to free the ball no.2 by soaking the part in some kind of liquid ?


Maybe someone knows the part number of this piece as I'm struggling to find any info online?
Any help is much appreciated


Don't want to be rude, but this is the LS forum and it seems like you have an IS vehicle. For the part number you may want to try there.

It seems like that whole link and ball assembly is shot so I would replace the whole thing if it's not too expensive.

However, that being said I have seen links like this repaired with a coat hanger. There is a video of a guy doing that on youtube with the Prius AFS sensor:


You could try something like that for a cheap fix. You could also make something up out of ball joints and a metal plate. Just make sure it's the same length of the original and that it can swivel around and not bind up when the suspension moves.

Good luck!
Arcturus is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2006 GS 300 -AFS Flashes, Headlights too low joshphp GS - 3rd Gen (2006-2011) 10 02-02-16 10:56 PM
IS 220D - AFS flashing Sidian IS - 2nd Gen (2006-2013) 4 07-12-15 10:35 AM
AFS OFF - Light Flashing - 07 IS250 RWD Monique023 IS - 2nd Gen (2006-2013) 3 05-20-15 06:01 PM
AFS OFF flashing tofu LS - 4th Gen (2007-present) 27 03-01-15 08:09 PM
AFS Light See5 IS - 2nd Gen (2006-2013) 3 09-02-13 03:18 AM


Tags
400, afs, cost, fix, flashing, indicator, lexus, light, ls430, off, replace, rx, rx350, sensor, service, subassy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 03:39 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved