HID's installed! - Club Lexus Forums


HID's installed!

Reply
 
 
 
Thread Tools Search this Thread
Old 01-02-13, 01:43 PM   #1
usoff89
Lexus Test Driver
Thread Starter
iTrader: (2)
 
usoff89's Avatar
 
Join Date: Jun 2012
Location: florida
Posts: 1,142
Default HID's installed!

So before buying the kit I got, I did alot of reading on the forum. I own a 93 LS and was reading about people having all kinds of problems with installing the HID's and having them work right. I ended up buying from DDMtuning. I ONLY bought from them because I have purchased a few other kits from them and never had any problems. If I based my desicion off of reviews, I would not have purchased from them. The kit I got from them was the slim ballast Raptor kit 8k added the high/low option and went with the 55w kit. Total was about $60 plus shipping, which in my opinion was not too bad. Shipping wasn't too bad, took just under two weeks, and was coming from china.

The install was very simple and took about two hours. The kit has a seperate harness that gets power straight from the battery, so takes a little longer to wire up. I also wanted to tuck all of the wires and hide the ballasts. So far the lights have worked great and YES my fog lights still work! I have high and low beams. The fogs go off when you hit the highs just like normal. I didn't have to switch any wiring around on the car harness or the HID kit.

I just wanted to share my experience to help any other people considering HID's. I also just purchased a set of the eagle eye clear headlights from another forum member. I will post before and after pics of them installed next week.

Mike
usoff89 is offline   Reply With Quote
Old 01-02-13, 02:06 PM   #2
python
Lexus Champion
iTrader: (4)
 
python's Avatar
 
Join Date: Jan 2008
Location: ca
Posts: 1,601
Default

your eagle eyes are on the way..cant wait to see the hids installed...hope this works out for you, i didnt have much luck and dumped them in the trash
python is offline   Reply With Quote
Old 01-02-13, 02:46 PM   #3
usoff89
Lexus Test Driver
Thread Starter
iTrader: (2)
 
usoff89's Avatar
 
Join Date: Jun 2012
Location: florida
Posts: 1,142
Default

What kind of problems were you having with yours?
usoff89 is offline   Reply With Quote
Old 01-02-13, 05:53 PM   #4
python
Lexus Champion
iTrader: (4)
 
python's Avatar
 
Join Date: Jan 2008
Location: ca
Posts: 1,601
Default

when i turned the lights on initially..one bulb was a different hue..had to turn off and on a couple of times to have both the same..sometimes one wouldnt come on..then maybe the other the next time..got tired of it
python is offline   Reply With Quote
Old 01-03-13, 01:26 AM   #5
Shmee
Lexus Test Driver
iTrader: (3)
 
Shmee's Avatar
 
Join Date: Dec 2007
Location: Victoria, BC. Canada
Posts: 1,471
Default

^^^^
That sounds like one of the crap harness connectors on some HID kits.

I've had similar happen on other cars and as soon as I clipped both the stock and the hid bulb connectors and replaced the with either fresh new connectors or hard wired them in, the problem went away...

Not saying that was your problem but something for others to check before they bin $50-150 of HID kit!
Shmee is offline   Reply With Quote
Old 01-03-13, 02:38 PM   #6
timmy0tool
Lexus Champion
iTrader: (5)
 
timmy0tool's Avatar
 
Join Date: Sep 2008
Location: 909/626/714, SoCal
Posts: 3,648
Default

Quote:
Originally Posted by python View Post
when i turned the lights on initially..one bulb was a different hue..had to turn off and on a couple of times to have both the same..sometimes one wouldnt come on..then maybe the other the next time..got tired of it
the hue difference is due to different warm up times. since it sounded like you had a harness problem, one bulb would turn on faster than the other. the bulbs would eventually be at the same temp hence the same color after a few on/offs.
timmy0tool is offline   Reply With Quote
Old 01-03-13, 02:40 PM   #7
timmy0tool
Lexus Champion
iTrader: (5)
 
timmy0tool's Avatar
 
Join Date: Sep 2008
Location: 909/626/714, SoCal
Posts: 3,648
Default

usoff89, post some against-the-wall pictures of your setup now, and then again with the eagle eyes. this will help with future buyers interested.

i too have the DDM tuning 55W kit, but i don't have the hi/lo feature. i opted only for 6000k as well. i'm curious to see what yours looks like.
timmy0tool is offline   Reply With Quote
Old 01-03-13, 02:50 PM   #8
usoff89
Lexus Test Driver
Thread Starter
iTrader: (2)
 
usoff89's Avatar
 
Join Date: Jun 2012
Location: florida
Posts: 1,142
Default

I will post some pics up next week before the install and after. I will say that the 55w 8k kit is more white than the 35w 8k kit. A friend at work has the 35w 8k kit and is really blue compared to mine.
usoff89 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HID lights LS460 hiyabuddy LS - 4th Gen (2007-present) 7 09-12-16 05:00 AM
HID Fog Install DIY w/PICS for LS460 CJITTY LS - 4th Gen (2007-present) 116 11-21-15 04:20 PM
Hid replacement for Normal Halogen headlight Whitigir RX - 3rd Gen (2010-2015) 14 03-05-14 01:51 PM
your ballast wattage? c-low Lighting 2 08-26-11 11:53 PM
Hid Not Working 93SC300. Lighting 0 08-01-07 01:08 AM


Tags
ct, eagle, eye, hid, hidf, install, lexus

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 11:52 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved