What did you do to your LS400 today? - Page 5 - Club Lexus Forums


What did you do to your LS400 today?

Reply
 
 
 
Thread Tools Search this Thread
Old 10-14-12, 12:28 AM   #61
SPhoto
Lead Lap
 
SPhoto's Avatar
 
Join Date: Mar 2009
Location: Hawaii
Posts: 423
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Glidin316 View Post
pics!!

heres a pic of my curtains
I'll get pics up hopefully tomorrow.
SPhoto is offline   Reply With Quote
Old 10-14-12, 01:12 AM   #62
Shmee
Lexus Test Driver
iTrader: (3)
 
Shmee's Avatar
 
Join Date: Dec 2007
Location: Victoria, BC. Canada
Posts: 1,471
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Picked up a ton of parts yesterday, hope to start installing them in the next week or so, as time allows!
Shmee is offline   Reply With Quote
Old 10-16-12, 09:14 PM   #63
E36M3
Driver
Thread Starter
iTrader: (1)
 
E36M3's Avatar
 
Join Date: Sep 2012
Location: CA
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I didn't like the tail lights on my car so I removed both lamps next to the reverse lamps. I feel like they are scattered and it looks busy. Anyway, the pictures below will show which lamps I removed. Excuse the pictures quality.


E36M3 is offline   Reply With Quote
Old 10-16-12, 10:44 PM   #64
YAK00Z
Driver School Candidate
 
YAK00Z's Avatar
 
Join Date: Oct 2012
Location: NSW
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

will be doing the power steering pump and alternator tomorrow. Alternator carked itself today from the power steering leaking ontop of it
YAK00Z is offline   Reply With Quote
Old 10-16-12, 11:00 PM   #65
Dranom
Lead Lap
iTrader: (7)
 
Join Date: May 2009
Location: SoCal
Posts: 591
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did a complete interior detail yesterday and today.
Used a bissell autocare proheat to clean the carpets and used leatherique to recondition the seats and door leather. Still need to clean the headliner though and spray some chemicals to clean up the AC so it doesnt stink up when I turn it on sometimes

Last edited by Dranom; 10-16-12 at 11:45 PM.
Dranom is offline   Reply With Quote
Old 10-16-12, 11:43 PM   #66
hotdawwg
Pole Position
 
hotdawwg's Avatar
 
Join Date: Jan 2011
Location: Ca
Posts: 338
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please help me with mine Broski....
hotdawwg is offline   Reply With Quote
Old 10-17-12, 12:00 AM   #67
Dranom
Lead Lap
iTrader: (7)
 
Join Date: May 2009
Location: SoCal
Posts: 591
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by hotdawwg View Post
Please help me with mine Broski....
Pretty easy bro! just time consuming
you can also use a ShopVac and just buy this



mix it with water and put it on a spray bottle.
Spray and scrub and vacuum
smell good too
Dranom is offline   Reply With Quote
Old 10-17-12, 11:54 AM   #68
nosaji
Driver School Candidate
 
Join Date: Aug 2010
Location: california
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just installing coilovers.Im missing some parts to the rear rcas. so i couldnt install it yet.





http://i858.photobucket.com/albums/a...alandsskit.jpg
nosaji is offline   Reply With Quote
Old 10-17-12, 12:47 PM   #69
timmy0tool
Lexus Champion
iTrader: (5)
 
timmy0tool's Avatar
 
Join Date: Sep 2008
Location: 909/626/714, SoCal
Posts: 3,676
Thanks: 0
Thanked 0 Times in 0 Posts
Default

^ nice coils, came with SS kit too?
timmy0tool is offline   Reply With Quote
Old 10-17-12, 01:19 PM   #70
Shmee
Lexus Test Driver
iTrader: (3)
 
Shmee's Avatar
 
Join Date: Dec 2007
Location: Victoria, BC. Canada
Posts: 1,471
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sealed up and installed my tails and front signals yesterday, might do my headlights today
Shmee is offline   Reply With Quote
Old 10-19-12, 05:16 AM   #71
SPhoto
Lead Lap
 
SPhoto's Avatar
 
Join Date: Mar 2009
Location: Hawaii
Posts: 423
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Glidin316 View Post
pics!!
Here's photos of my grille that I said I'd get up. Sprayed these black cuz I didn't like the stock grayish color it came in


SPhoto is offline   Reply With Quote
Old 10-20-12, 12:36 AM   #72
Mugen_1
Lexus Test Driver
 
Mugen_1's Avatar
 
Join Date: May 2008
Location: Illinois
Posts: 811
Thanks: 0
Thanked 0 Times in 0 Posts
Default



Had it towed :/

Was driving it along just fine, then the battery light came on, the radio turned off, the dash lights dimmed, power steering slowly became heavy, then the car sputtered to a stop and wouldn't shift to park. Luckily I had managed to make it to a Wal-Mart right outside it's tire/lube/express department, and had the guy check the battery, which he said tested good (was purchased 11/11) but was barely drawing a charge. Let the car sit for a few minutes, fired it back up, everything worked again - guy tested it again, showed it was getting full power and charging fine - put it in drive, the battery light came back on, and the lights all dimmed until the car idled itself to a halt. Figure it's got to be the alternator, so there's money I didn't want to spend, seeing as the 180k interval is approaching in about 6,000 miles...
Mugen_1 is offline   Reply With Quote
Old 10-20-12, 12:45 AM   #73
Dranom
Lead Lap
iTrader: (7)
 
Join Date: May 2009
Location: SoCal
Posts: 591
Thanks: 0
Thanked 0 Times in 0 Posts
Default

^ mice got towed too
damn drive belt broke so i might aswell do my 90k service and change spark plugs
coilovers and airbag money gone
Dranom is offline   Reply With Quote
Old 10-20-12, 01:15 AM   #74
cobalt91
Lead Lap
 
Join Date: May 2012
Location: MI
Posts: 586
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just put a new drive belt on it. Sounds like the timing belt is ok. You can still get get your coilovers.
cobalt91 is offline   Reply With Quote
Old 10-20-12, 01:22 AM   #75
Dranom
Lead Lap
iTrader: (7)
 
Join Date: May 2009
Location: SoCal
Posts: 591
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by cobalt91 View Post
Just put a new drive belt on it. Sounds like the timing belt is ok. You can still get get your coilovers.
yeah but 90k is due so might aswell do it.
coils can wait
Dranom is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
98 antenna location ? vette22 LS - 1st and 2nd Gen (1990-2000) 8 01-11-16 01:14 PM
Replacing radio antenna igorxx SC430 - 2nd Gen (2001-2010) 3 01-24-12 09:50 PM
Sirius Puck Antenna Problem... levinsoy GS - 3rd Gen (2006-2011) 9 03-27-11 07:30 AM
Antenna Mast Install V8drummer SC- 1st Gen (1992-2000) 2 07-17-10 09:04 PM
91 pionneer radio what is the 2nd 91ls400own LS - 1st and 2nd Gen (1990-2000) 1 04-01-09 10:36 AM


Tags
99, antenna, auto, automotive, car, cell, diy, home, hook, ls400, mans, phone, poor, ramps, splicing

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 10:55 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved