What did you do to your LS400 today? - Page 17 - Club Lexus Forums

Log In 

What did you do to your LS400 today?

Reply
 
 
 
Thread Tools Search this Thread
Old 05-28-14, 05:47 PM   #241
RA40
Moderator
iTrader: (6)
 
RA40's Avatar
 
Join Date: May 2003
Location: California
Posts: 17,254
Default

Last night it read 3.26V. Had the charger on it overnight and it read 3.4V after 12 hours. (It is a maintenance charger but it has been useful for batteries above 9V but not at 3.2V) Called AAA out and he gave it a 50/50 chance after it got a better charge. At 5+ years old, I figured it was going to come due so the decision was made to replace it. $118 later.

Don't know what it is, the neg terminal is smaller so the clamp was loose when snugged up. Easily fixed but I've noticed on the last several batteries, the neg terminals seem to be incrementally smaller and smaller.
RA40 is offline   Reply With Quote
Old 06-19-14, 09:07 PM   #242
Finn
Driver
 
Finn's Avatar
 
Join Date: Nov 2013
Location: Finland
Posts: 181
Default

What did you do to your LS400 today?

Well, I took my LS out for a 500 mile working trip making 25 mpg. What a wonderful car this is.
Finn is offline   Reply With Quote
Old 07-12-14, 04:07 PM   #243
CMDSlick
Driver School Candidate
 
CMDSlick's Avatar
 
Join Date: Jul 2014
Location: Idaho
Posts: 45
Default

I replaced my engine coolant temperature sensor... seems to have a bit more pep... I'll see if my mileage improves from about 15.5 mpg.
CMDSlick is offline   Reply With Quote
Old 07-12-14, 05:21 PM   #244
lexmoose
Pole Position
 
lexmoose's Avatar
 
Join Date: Jul 2014
Location: Can
Posts: 217
Default

Ok so I was getting water in the trunk, used the hose to find where it came from and it appear to come from under the seal near the light on the driver side.

So today I removed the seal cleaned everything with adhesive remover and use 3M 80119 Weatherstrip Adhesive and hope it will work.

Test without seal (trunk open) didn't show any infiltration so I'm confident it will be good.
lexmoose is offline   Reply With Quote
Old 07-26-14, 09:16 PM   #245
Hiroshi12
Lead Lap
iTrader: (1)
 
Hiroshi12's Avatar
 
Join Date: Mar 2012
Location: CA
Posts: 548
Default My next unecessary modification, part II

So I finally got rid of my 90's-era upturned, elbow-style Magnaflow tips and replaced them with these more modern tips. Has a BMW or Audi look to them I think.
Attached Thumbnails
What did you do to your LS400 today?-imag0610.jpg   What did you do to your LS400 today?-imag0620.jpg  

Last edited by Hiroshi12; 09-25-14 at 01:15 PM.
Hiroshi12 is offline   Reply With Quote
Old 09-23-14, 05:12 PM   #246
OMAHA
Pole Position
 
OMAHA's Avatar
 
Join Date: Jan 2014
Location: Nebraska
Posts: 228
Default

put some new Pirellis on (P7 all season)......also new Brembo rotors with toyota brakes....NICE!
OMAHA is offline   Reply With Quote
Old 09-24-14, 02:43 AM   #247
cgawelko
Pole Position
 
Join Date: Mar 2014
Location: Oregon
Posts: 397
Default

two days ago, spark plugs... pulled dirty crusty *** denso double plats out that had a gap of over 0.06 from being so old... im amazed the damn thing still ran! MPG has jump DRASTICALLY.

Exhaust was finished the other day.

Ordering lowering suspension today...

Friday ordering a new radiator... Stupid banjo bolt thing is leaking and it gets warm once in a while....nothing a new radiator and a flush wont fix... I hope....
cgawelko is offline   Reply With Quote
Old 10-09-14, 07:20 PM   #248
xswingkidx
Driver School Candidate
 
xswingkidx's Avatar
 
Join Date: May 2013
Location: AZ
Posts: 9
Default

Today I had the 20 years of dents pulled out of it and got the pin stripes removed. Since the last post, it also got H&R springs and KYB struts. For some reason, the pic has a weird glare on it

xswingkidx is offline   Reply With Quote
Old 03-21-15, 04:09 PM   #249
Toyofhate
Driver School Candidate
 
Toyofhate's Avatar
 
Join Date: Mar 2015
Location: Wa
Posts: 42
Default What did you do to your car today?

Hi names josh. Been around cars a long time. Thought I would start a thread. Didn't happen without pics LOL.

Got new family car and did lots of cleaning.
Toyofhate is offline   Reply With Quote
Old 03-21-15, 04:34 PM   #250
JJDAG
Rookie
 
JJDAG's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 99
Default

My LS is in my buddies shop started the full maintenance. Timing belt, water pump, thermostat, ps pump. valve cover gaskets, spark plugs, trans filter and flush, rear diff fluid change, oil change, motor mounts, trans mount . 88k on it have all 5 pages of maintenance history, want to start nice and fresh, cant wait till its done.
JJDAG is offline   Reply With Quote
Old 03-21-15, 04:42 PM   #251
Toyofhate
Driver School Candidate
 
Toyofhate's Avatar
 
Join Date: Mar 2015
Location: Wa
Posts: 42
Default

Quote:
Originally Posted by JJDAG View Post
My LS is in my buddies shop started the full maintenance. Timing belt, water pump, thermostat, ps pump. valve cover gaskets, spark plugs, trans filter and flush, rear diff fluid change, oil change, motor mounts, trans mount . 88k on it have all 5 pages of maintenance history, want to start nice and fresh, cant wait till its done.
No **** can't wait to see more man.
Toyofhate is offline   Reply With Quote
Old 03-21-15, 04:45 PM   #252
JJDAG
Rookie
 
JJDAG's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 99
Default

Its getting done after hours so it will be a few days but I will post how it comes out. The mounts were the worst thing with the vibration, although when the timing covers came off the belt had a lot of cracks so im glad its getting done...
JJDAG is offline   Reply With Quote
Old 03-21-15, 04:51 PM   #253
JJDAG
Rookie
 
JJDAG's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 99
Default

What are your wheels off of they are nice, Your whole car looks nice !
JJDAG is offline   Reply With Quote
Old 03-21-15, 05:24 PM   #254
Toyofhate
Driver School Candidate
 
Toyofhate's Avatar
 
Join Date: Mar 2015
Location: Wa
Posts: 42
Default

Thanks the wheels are supposed to look like Sc430 wheels came with car not that bad.
Toyofhate is offline   Reply With Quote
Old 03-29-15, 03:20 PM   #255
JJDAG
Rookie
 
JJDAG's Avatar
 
Join Date: Mar 2015
Location: Connecticut
Posts: 99
Default

Quote:
Originally Posted by Toyofhate View Post
No **** can't wait to see more man.
Ok all the maintenance and mounts are finally done ! The new mounts cleared up the vibration for sure, drives smooth as butter. Did the timing belt, water pump, thermostat, of course new coolant, pulleys cam seals, serpentine belt, valve cover gaskets with spark plug seals, spark plugs, power steering pump, motor mounts, trans mount, mobile 1 oil change, transmission filter and BG flush service ( 88000 miles trans filter changed 3 times and bg flush done twice) rear end fluid change.
Had to drive my wife to work all week I like her v8 4Runner but I really missed my Lexus . Cant wait till the snow stops falling so I can do a major detailing that will last more than 3 feet...
JJDAG is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Replace SC430 Antenna hlovepenn SC430 - 2nd Gen (2001-2010) 20 05-21-16 09:36 PM
98 antenna location ? vette22 LS - 1st and 2nd Gen (1990-2000) 8 01-11-16 12:14 PM
Has anyone installed the TRK-SR2 XM Kit ? PHOUND5 LS - 3rd Gen (2001-2006) 2 01-04-12 07:25 AM
Questions re FM reception e-man Lexus Audio, Video, Security & Electronics 3 09-16-11 02:14 PM
91 pionneer radio what is the 2nd 91ls400own LS - 1st and 2nd Gen (1990-2000) 1 04-01-09 09:36 AM


Tags
99, antenna, auto, automotive, car, cell, diy, home, hook, ls400, mans, phone, poor, ramps, splicing

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 06:55 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved