Battery, alternator fuse questions - Club Lexus Forums

Log In 

Battery, alternator fuse questions

Reply
 
 
 
Thread Tools Search this Thread
Old 05-16-11, 04:35 PM   #1
ramo1246
Driver School Candidate
Thread Starter
 
Join Date: Mar 2011
Location: AZ
Posts: 30
Default Battery, alternator fuse questions

hello all,
i got a 1990 ls 400 with a brand new battery that keeps dying every couple days or even a day of not using it. i havnt checked the altenator but does anyone else have a clue what it is if its not the altenator.
ramo1246 is offline   Reply With Quote
Old 05-16-11, 04:44 PM   #2
LiveWire
Rookie
 
Join Date: Dec 2010
Location: FL
Posts: 71
Default

It.s probably the alternator.
LiveWire is offline   Reply With Quote
Old 05-16-11, 05:31 PM   #3
rennwerkes
Rookie
 
Join Date: Apr 2011
Location: Hawaii
Posts: 76
Default

Quote:
Originally Posted by ramo1246 View Post
hello all,
i got a 1990 ls 400 with a brand new battery that keeps dying every couple days or even a day of not using it. i havnt checked the altenator but does anyone else have a clue what it is if its not the altenator.
There's a good chance you've also got a drain from a short or similar. I'd suggest just taking it to a auto electric shop and have them diagnose the problem.
rennwerkes is offline   Reply With Quote
Old 05-16-11, 06:44 PM   #4
Nospinzone
Moderator
 
Nospinzone's Avatar
 
Join Date: Mar 2007
Location: MA
Posts: 2,932
Default

From what you describe it's not the alternator. Obviously it is recharging the battery, but the battery is failing when the car sits. You either have a drain or the battery itself is weak and does not take a full charge.
Nospinzone is offline   Reply With Quote
Old 05-26-11, 02:42 PM   #5
ramo1246
Driver School Candidate
Thread Starter
 
Join Date: Mar 2011
Location: AZ
Posts: 30
Default

ok i found out that it wasnt the altenator, its a short in the car. But now i have a new problem, i accidentaly hooked up my jumper cable wrong and blew my 120 A fuse, i replaced the fuse and everything worked again, but my dome lights dont turn on, sunroof doesnt work, radio doesnt turn on, and my lock buttons dont work. i checked all the fuses and they are all good, anybody have any ideas
ramo1246 is offline   Reply With Quote
Old 05-26-11, 06:19 PM   #6
Nospinzone
Moderator
 
Nospinzone's Avatar
 
Join Date: Mar 2007
Location: MA
Posts: 2,932
Default

Are you sure you checked all the fuse boxes? I don't know about a 1990 model, but my 2007 has four different fuse panels. Check your owners manual for the locations of yours.
Nospinzone is offline   Reply With Quote
Old 05-27-11, 04:50 PM   #7
ramo1246
Driver School Candidate
Thread Starter
 
Join Date: Mar 2011
Location: AZ
Posts: 30
Default

ok my bad i did have two bad fuses but i also got another problem, my radio turns on but i get no sound coming from the speakers, everytime i try to put a fuse where it belongs it fries the fuse instantly, is this a short as well and if it is, is it related to why my battery keeps dying or a whole differnt short?

thanks for the help
ramo1246 is offline   Reply With Quote
Old 05-27-11, 05:26 PM   #8
Lazy
Lexus Champion
iTrader: (2)
 
Lazy's Avatar
 
Join Date: Jun 2007
Location: Socal
Posts: 1,719
Default

if it fries right when u put a new one in then u have a short somewhere. Did u find the short for the drain yet? any recent mods to the car? sub, suspension, stereo etc?
Lazy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Altenator died. Replacement options? yuri.ber LS - 3rd Gen (2001-2006) 19 12-13-15 09:27 AM
93 SC400 Power Steering issue ***PLEASE HELP*** ercfrmr Suspension and Brakes 25 04-16-15 07:56 PM
Correct voltage for altenator ?? DMPesso GS - 2nd Gen (1998-2005) 7 11-16-14 07:26 PM
altenator install Manny83 GS - 2nd Gen (1998-2005) 0 06-23-14 11:20 AM
Bad Altenator/Corroded Battery Terminals truman363 GS - 2nd Gen (1998-2005) 1 05-07-08 06:45 PM


Tags
1990, 92, 99, alternator, battery, breaker, check, circuit, fuse, fuses, hook, is300, lexus, location, ls400, sunroof

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 05:20 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved