ml amp help! - Club Lexus Forums


Go Back   Club Lexus Forums > Lexus Special Interest Forums > Lexus Audio, Video, Security & Electronics
Log In 

ml amp help!

Reply
 
 
 
 
Thread Tools Search this Thread
Old 08-07-14, 05:02 PM   #1
LEXZILLA
Driver
Trader Score: (1)
 
Join Date: Dec 2006
Location: LA.
Posts: 186
Default ml amp help!

hello i have a 03 sc430 with a weird problem.
i think i have a loose plug on my ml amp and my sub and drivers side (6x9)speaker
dont play all the time
does anyone have a diy(with pictures) to show me how to gain access to the plugs on the amp?

thanks in advance
LEXZILLA is offline   Reply With Quote
Old 08-07-14, 06:03 PM   #2
LEXZILLA
Driver
Trader Score: (1)
 
Join Date: Dec 2006
Location: LA.
Posts: 186
Default

and where should i check for short (plug location)

thanks again
LEXZILLA is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Beatsonic mva24L question lvLS430 LS - 3rd Gen (2001-2006) 5 09-23-15 06:30 PM
Mark Levinson Head unit WORKS, without ML amp tqlla3k IS - 2nd Gen (2006-2013) 28 03-19-15 02:03 AM
Non-ML Amp Location hjones4841 LS - 4th Gen (2007-present) 0 12-16-13 06:08 PM
Installing an aftermarket amp & subs Franco09 GS - 3rd Gen (2006-2011) 30 11-28-13 07:47 PM
Upgrading a IS350 premium to ML system GaaraOTS IS - 2nd Gen (2006-2013) 17 07-11-13 04:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 06:39 AM.



Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS