ml amp help! - Club Lexus Forums

Log In 

ml amp help!

Reply
 
 
 
Thread Tools Search this Thread
Old 08-07-14, 04:02 PM   #1
LEXZILLA
Driver
Thread Starter
iTrader: (1)
 
Join Date: Dec 2006
Location: LA.
Posts: 197
Default ml amp help!

hello i have a 03 sc430 with a weird problem.
i think i have a loose plug on my ml amp and my sub and drivers side (6x9)speaker
dont play all the time
does anyone have a diy(with pictures) to show me how to gain access to the plugs on the amp?

thanks in advance
LEXZILLA is offline   Reply With Quote
Old 08-07-14, 05:03 PM   #2
LEXZILLA
Driver
Thread Starter
iTrader: (1)
 
Join Date: Dec 2006
Location: LA.
Posts: 197
Default

and where should i check for short (plug location)

thanks again
LEXZILLA is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ML amp wiring diagram vstyle444 LS - 4th Gen (2007-present) 1 03-13-16 08:03 AM
Will an ML amp from a 2005 LS be compatible with a 2001 LS yuri.ber LS - 3rd Gen (2001-2006) 1 02-10-16 04:03 PM
new amp in protection mode when preamp in is plugged! why?? guyrat7 Lexus Audio, Video, Security & Electronics 0 02-02-16 03:45 AM
Beatsonic mva24L question lvLS430 LS - 3rd Gen (2001-2006) 5 09-23-15 05:30 PM
Does anyone have pics of the ML amp connectors? tqlla3k IS - 2nd Gen (2006-2013) 2 09-18-06 06:29 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 03:11 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved