Go Back   Club Lexus Forums > Lexus Model Forums > IS Models > IS - Second Generation
Sign in using an external account
Register Forgot Password?

Amp is shot

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-20-14, 12:19 PM   #1
venom1515
Driver School Candidate
Trader Score: (0)
 
venom1515's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 9
Default Amp is shot

Well I have done my research and my 06 is250 amp appears that it has taken a crap on me. There is power to the radio but there is no sound and this happens off and on and today there is no sound at all. My question is should I replace the amp with an OEM one or has anyone replaced with an aftermarket. Please any suggestions would be greatly appreciated.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
venom1515 is offline   Reply With Quote
Old 07-20-14, 12:43 PM   #2
Gville350
Lexus Fanatic
Trader Score: (8)
 
Gville350's Avatar
 
Join Date: Mar 2011
Location: South Carolina
Posts: 6,422
Default

I'd recommend another good, used OEM unit. If you want to upgrade the thump in the trunk or other speakers, you run a signal input box and use the signal from the factory lines to feed new amps and those new speakers.
__________________
'06 IS350 - 8.6468 @ 81.81MPH
Mods - SRI, BCRs, full GFX kit
Gville350 is online now   Reply With Quote
Old 07-20-14, 04:48 PM   #3
yamahaSi
Driver School Candidate
Trader Score: (0)
 
Join Date: Dec 2010
Location: VA
Posts: 4
Default

I had the exact same thing happen this past week on my 07 IS250. Would replacing the OEM amp with an aftermarket be an easy swap with OEM Navi?
yamahaSi is offline   Reply With Quote
Old 07-20-14, 07:11 PM   #4
venom1515
Driver School Candidate
Trader Score: (0)
 
venom1515's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 9
Default

yamaha if you hear anything about an aftermarket amp let me know
venom1515 is offline   Reply With Quote
Old 07-20-14, 07:11 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cracking from Single Speaker - RX330 Arkdawg Lexus Audio, Video, Security & Electronics 0 11-15-13 11:58 AM
Pioneer HU comes with amps now? vbacky GS - Second Generation 1 05-03-13 05:00 AM
Enhancing Sound in ES 300h JerryKK ES350 and ES300h (2013+) 1 10-26-12 06:16 PM
LX470 Amplifier Problem runutzzzzz Lexus Audio, Video, Security & Electronics 0 12-03-07 10:39 AM
Lx470 Amp Location Dsquare Lexus Audio, Video, Security & Electronics 1 08-11-04 08:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 07:48 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info