Go Back   Club Lexus Forums > Lexus Model Forums > IS Models > IS - Second Generation
Sign in using an external account
Register Forgot Password?

2008 IS350 navigation screen is completely black

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-10-13, 06:48 PM   #1
gastric
Driver School Candidate
Trader Score: (0)
 
Join Date: Jan 2008
Location: NC
Posts: 12
Default 2008 IS350 navigation screen is completely black

After months of enjoying our used 08 IS350 the navigation screen decided to go completely black and the hard buttons are not lit up. I don't believe this is the same as the digitizer issue as those users have a working display but it won't respond to touch commands.

My issue is the screen is physically off, including all of the buttons to the left / right of the screen, and the climate controls immediately below the screen. The clock works, security light blinks, the hazard light is lit. The buttons below the CD drive work fine, I can turn on the radio, switch from FM to CD, etc. As best I can tell everything else works on the vehicle.

I was thinking it was probably a fuse but for the life of me I cannot identify one that seems blown.

Thoughts?
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
Attached Images
 
gastric is offline   Reply With Quote
Old 07-10-13, 07:39 PM   #2
Uda880
Pole Position
Trader Score: (7)
 
Uda880's Avatar
 
Join Date: Nov 2011
Location: CA
Posts: 323
Default

Fuse or connection short. This entire unit relies on multiple ECUs to power and function. The digitizer issue is a physical malfunction, but you also have to consider the multiple PC boards behind the unit that can malfunction due to power/shorts or even physical/heat destruction. This includes both the navigation/HVAC unit itself and the DVD drive attached underneath it.
__________________
Pseudo-Stock TP IS350
Uda880 is offline   Reply With Quote
Old 07-10-13, 07:46 PM   #3
RX469
Lexus Champion
Trader Score: (1)
 
Join Date: Feb 2003
Location: Maryland
Posts: 2,094
Send a message via AIM to RX469
Default

Curious to know what the issue may be? Please let us know what you find, thanks.
__________________

Wanted: Toyota Back-up camera - Video Rearview Mirror - Air Bag for MR-S or Celica GT-S Steering Wheel
RX469 is offline   Reply With Quote
Old 07-12-13, 03:35 PM   #4
gastric
Driver School Candidate
Trader Score: (0)
 
Join Date: Jan 2008
Location: NC
Posts: 12
Default

Dealer gave it an initial diagnosis as the ECU for the navigation at a potential cost of $4,000. However, they need to look at the vehicle some more and discuss it with the shop manager on Monday to fully flesh it out, including the cost.

Obviously that is pretty ludicrous considering that's nearly 20% of the value of the entire vehicle, and there's not a computer I'm aware of that costs $4,000 in general. Well, except one in a Lexus, apparently.

Part # 8611153150 which doesn't seem like an ECU to me, but the entire navigation system.

The adventure continues!

Last edited by gastric; 07-12-13 at 03:41 PM..
gastric is offline   Reply With Quote
Old 07-12-13, 04:24 PM   #5
Uda880
Pole Position
Trader Score: (7)
 
Uda880's Avatar
 
Join Date: Nov 2011
Location: CA
Posts: 323
Default

Quote:
Originally Posted by gastric View Post
Dealer gave it an initial diagnosis as the ECU for the navigation at a potential cost of $4,000. However, they need to look at the vehicle some more and discuss it with the shop manager on Monday to fully flesh it out, including the cost.

Obviously that is pretty ludicrous considering that's nearly 20% of the value of the entire vehicle, and there's not a computer I'm aware of that costs $4,000 in general. Well, except one in a Lexus, apparently.

Part # 8611153150 which doesn't seem like an ECU to me, but the entire navigation system.

The adventure continues!
I had the same issue with the navigation ECU. There's a shop in Los Angeles that repairs these units for around $900 (assuming you have someone that can dissemble and ship the unit).
__________________
Pseudo-Stock TP IS350
Uda880 is offline   Reply With Quote
Old 07-12-13, 04:51 PM   #6
Nikon
Lead Lap
Trader Score: (2)
 
Nikon's Avatar
 
Join Date: Apr 2011
Location: WA
Posts: 488
Default

what is the exterior color of your car? just curious. good luck with this and hopefully you hear back some positive news from the dealership.

they really have to make these units cheaper.
Nikon is offline   Reply With Quote
Old 07-12-13, 05:14 PM   #7
gastric
Driver School Candidate
Trader Score: (0)
 
Join Date: Jan 2008
Location: NC
Posts: 12
Default

Quote:
Originally Posted by Nikon View Post
what is the exterior color of your car? just curious. good luck with this and hopefully you hear back some positive news from the dealership.

they really have to make these units cheaper.
Dark grey IS350 with 73k on the odometer.

This replaced an 02 ES300 NAV with 185k. That one stopped reading nav DVDs (probably a cheap replacement of just the drive in the trunk, never cared enough to investigate as the map updates cost more than an entire Garmin GPS) and had various electrical issues with the power windows. But otherwise was rock solid the entire time we owned it.

Note that even if this unit was $2,000 I'd still say it's outrageously priced. Though at least approaching normal car dealer overpriced.
gastric is offline   Reply With Quote
Old 07-15-13, 10:26 AM   #8
gastric
Driver School Candidate
Trader Score: (0)
 
Join Date: Jan 2008
Location: NC
Posts: 12
Default

Nav is currently functional again.

Deal disconnected battery, cleared codes, nav returned from the grave.
gastric is offline   Reply With Quote
Old 07-15-13, 12:01 PM   #9
Nikon
Lead Lap
Trader Score: (2)
 
Nikon's Avatar
 
Join Date: Apr 2011
Location: WA
Posts: 488
Default

wow good news!!! did they say what was wrong?
Nikon is offline   Reply With Quote
Old 07-15-13, 12:08 PM   #10
gastric
Driver School Candidate
Trader Score: (0)
 
Join Date: Jan 2008
Location: NC
Posts: 12
Default

Quote:
Originally Posted by Nikon View Post
wow good news!!! did they say what was wrong?
No. Hence my level of confidence is low.

I do have a vague recollection of reading a blurb about some similar sequence of disconnecting the battery to cycle the computers in the vehicle. I suppose that's like a hard reboot for the vehicle? Which means I suppose it could get back into the state / scenario that cause the issue to begin with.

Beats me, I'm just a car owner, not a mechanic.
gastric is offline   Reply With Quote
Old 07-15-13, 01:37 PM   #11
whitebeast
Lexus Champion
Trader Score: (5)
 
whitebeast's Avatar
 
Join Date: May 2011
Location: CA
Posts: 1,610
Send a message via AIM to whitebeast
Default

That's problem could be seen when you're battery is being bad. Make sure to check your battery at your local auto for free. I have that problem before and turn out my alternator being bad causing battery being as well.
A few mins could save you a lot of headache and worry free
__________________
whitebeast is offline   Reply With Quote
Old 08-20-13, 08:59 PM   #12
aira
Pole Position
Trader Score: (0)
 
aira's Avatar
 
Join Date: Sep 2006
Location: ks
Posts: 381
Send a message via AIM to aira
Default

I have this exact issue and I've still yet to find a solution. I've replaced my battery with a red top optima and I've replaced the screen. Don't know what else I can do.
aira is offline   Reply With Quote
Old 08-21-13, 01:40 PM   #13
Gville350
Lexus Fanatic
Trader Score: (8)
 
Gville350's Avatar
 
Join Date: Mar 2011
Location: South Carolina
Posts: 6,462
Default

Regardless, at least you have it back up and running! Report back if it does it again!
__________________
'06 IS350 - 8.6468 @ 81.81MPH
Mods - SRI, BCRs, full GFX kit
Gville350 is offline   Reply With Quote
Old 08-21-13, 10:50 PM   #14
07IS350
Pole Position
Trader Score: (0)
 
Join Date: Oct 2006
Location: California
Posts: 298
Default

You're one lucky dude!
07IS350 is offline   Reply With Quote
Old 07-17-14, 02:01 AM   #15
LADavidGS
Driver
Trader Score: (2)
 
Join Date: Jan 2012
Location: CA
Posts: 153
Default

i have similar situation, gastric how's your navigation?
LADavidGS is offline   Reply With Quote
Old 07-17-14, 02:01 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
another navigation problem. *with PIC* LADavidGS IS - Second Generation 9 07-19-14 09:20 AM
Touch screen, and button around navi, not turning on. 07 IS250 Please help! cardona707 IS - Second Generation 15 06-25-14 05:46 AM
Navigation Screen/Buttons Not Working Msfit804 IS - First Generation 0 04-20-14 05:04 PM
Navigation touch screen problem f111f444 IS - Second Generation 3 04-18-13 05:47 PM
Navigation Screen is Deader than a Door Nail. JackieBfly IS - Second Generation 1 08-23-12 06:11 PM


Tags
06, 2008, 350, access, black, digitizer, ecu, es, is350, lexus, light, nav, navigation, part8611153150, radio, screen, security, turning

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 10:20 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info