Go Back   Club Lexus Forums > Lexus Model Forums > IS Models > IS - First Generation
Sign in using an external account
Register Forgot Password?

Limping in

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-06-14, 04:38 AM   #1
blovely
Driver School Candidate
Trader Score: (0)
 
Join Date: Mar 2013
Location: Florida
Posts: 9
Exclamation Limping in

Took my IS-250 into Lexus dealership for scheduled 100,000 mile check up. All reported well. Left dealership and for the next few days experienced intermittent (need oil change maintenance soon) light. Then yesterday, oil light came on, engine made weird noise and acceleration would not go past 60mph. (limp mode symptoms)

Can anyone tell me what this could be? Dealership coming to get vehicle. My husband checked oil level and all fine. During 100,000 mile check up there was a flush of a 'lifetime fluid product' for transmission or coolant? Doesn't list on maintenance.

I am concerned because every time I bring my car into this Lexus dealership, something always goes wrong. Beginning to think it's sabotage for more money. I just gave the dealership $300 just for the check-up that came with oil change.

Help! Don't want to be caught off-guard with an unnecessary expense.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
blovely is offline   Reply With Quote
Old 08-11-14, 08:56 AM   #2
Black1129
Rookie
Trader Score: (0)
 
Black1129's Avatar
 
Join Date: Mar 2014
Location: Florida
Posts: 53
Default

Yup they did something to keep the money flow coming... Go to another lexus dealership explain yourself so they know are aware of the car being tampered
Black1129 is offline   Reply With Quote
Old 08-11-14, 08:59 AM   #3
Black1129
Rookie
Trader Score: (0)
 
Black1129's Avatar
 
Join Date: Mar 2014
Location: Florida
Posts: 53
Default

Oh yeah there's a way to reset the maintenance light. Try this and it'll probably fix your problem for free
But if the light comes back on take it to the dealership

Black1129 is offline   Reply With Quote
Old 08-11-14, 08:59 AM
 
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL Flashing & TRAC OFF = Limp Mode jermzisf IS F 36 09-04-14 01:13 PM
2007 GS350 burning oil - an issue? (+ compression test) Soccer1809 GS - Third Generation 2 05-10-14 04:40 AM
1994 Lexus LS400 Lexxs048 LS400 3 04-03-14 10:00 AM
What Are The Required Maintenences? sleekbrian RX - Third Generation 12 08-15-12 09:27 AM
08 IS250 AWD just cleared 100,000 miles - any maintenance needed? Chekmi21 IS - Second Generation 4 08-13-12 08:19 AM

All times are GMT -7. The time now is 06:36 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info