my engine cut-offs on Drive when brutally accelerating - Club Lexus Forums


Go Back   Club Lexus Forums > Lexus Model Forums > IS Models > IS F (2008-2014)
Log In 

my engine cut-offs on Drive when brutally accelerating

Reply
 
 
 
 
Thread Tools Search this Thread
Old 06-08-15, 08:14 AM   #1
gtouma
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2015
Location: Dubai
Posts: 11
Default my engine cut-offs on Drive when brutally accelerating

Hello, to start with i bought a 08 isf a week ago and its not in a really good condition it has done 177k miles and its moded with a k &N air intake and nameless exhaust.. According to its performance it still feels like 5.0 v8 and it gets to 60 less than five.. However the engine automatically cut-offs during a full throttle on 2nd and 3rd gear (during drive) so i was wondering if this thing is normal or the previous owners have done some tuning to its ECU. I really need your help guys and looking forward to restore the car
gtouma is offline   Reply With Quote
Old 06-08-15, 08:19 AM   #2
Ltaboso
Pole Position
Trader Score: (0)
 
Join Date: Nov 2014
Location: new york
Posts: 234
Default

Try reseting your ecu by pulling the fuse....search here and you will see which fuses to pull...im not sure which fuses to pull....
Ltaboso is offline   Reply With Quote
Old 06-08-15, 08:23 AM   #3
Justind27
Lexus Test Driver
Trader Score: (6)
 
Justind27's Avatar
 
Join Date: Jan 2014
Location: Washington
Posts: 912
Justind2772
Default

Wanna see a video of what your experiencing
Justind27 is offline   Reply With Quote
Old 06-08-15, 08:46 AM   #4
idoke1
Lead Lap
Trader Score: (4)
 
idoke1's Avatar
 
Join Date: Oct 2013
Location: California
Posts: 705
Default

It may need a tune up. Replace spark plugs with oem ones and see if that could help resolve it. Also, how bad is the cut off? Need more details.
__________________
Current rides:
2008 Lexus ISF
2009 Toyota Highlander Hybrid Limited AWD
2009 Jeep Wrangler Unlimited X

Pervious:
2007 Lexus IS350, 2006 VW Jetta GLI, 2005 Subaru WRX, 2004 Mazda RX8, 2002 BMW M3, 2000 Honda Civic Si, 1991 Toyota Supra Turbo
idoke1 is offline   Reply With Quote
Old 06-08-15, 10:08 AM   #5
KOKISF
Lead Lap
Trader Score: (0)
 
Join Date: Dec 2012
Location: pr
Posts: 409
Default

Weird never heard something like that!
KOKISF is offline   Reply With Quote
Old 06-08-15, 10:10 AM   #6
KOKISF
Lead Lap
Trader Score: (0)
 
Join Date: Dec 2012
Location: pr
Posts: 409
Default

Are u shifting w the paddles? If so probably you are hitting the rev limit, is the only reasson i can think of other than that should be an issue w the car
KOKISF is offline   Reply With Quote
Old 06-08-15, 01:01 PM   #7
aIRpeACE
Driver School Candidate
Trader Score: (0)
 
aIRpeACE's Avatar
 
Join Date: Jan 2015
Location: PA
Posts: 41
Default

this is a safety feature to prevent you from wrecking your car
aIRpeACE is offline   Reply With Quote
Old 06-08-15, 01:09 PM   #8
I8ABMR
Lexus Fanatic
Trader Score: (0)
 
I8ABMR's Avatar
 
Join Date: Sep 2007
Location: Waiting for next track day
Posts: 21,262
Default

Quote:
Originally Posted by Justind27 View Post
Wanna see a video of what your experiencing
me too ...... sounds odd
__________________

2010 LEXUS ISF / F Sport rear Sway Bar / PTS Joe Z exhaust/ RR Racing A/O separator and USRS / HRE wheels / 255/35/19 and 295/30/19 Yokohama Advan Neova AD08R

The ISF......The perfect car for an enthusiast. It can be driven to the track, run hard all day , and then transport me hundreds of miles to my home in luxury and comfort to pick up the wife for dinner and a movie....
I8ABMR is offline   Reply With Quote
Old 06-08-15, 02:04 PM   #9
gtouma
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2015
Location: Dubai
Posts: 11
Default

Quote:
Originally Posted by Ltaboso View Post
Try reseting your ecu by pulling the fuse....search here and you will see which fuses to pull...im not sure which fuses to pull....
Did that didn't work
gtouma is offline   Reply With Quote
Old 06-08-15, 02:05 PM   #10
gtouma
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2015
Location: Dubai
Posts: 11
Default

Quote:
Originally Posted by I8ABMR View Post
me too ...... sounds odd
Yes ill post a video tomorrow

Last edited by gtouma; 06-08-15 at 02:09 PM.
gtouma is offline   Reply With Quote
Old 06-08-15, 02:07 PM   #11
gtouma
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2015
Location: Dubai
Posts: 11
Default

Quote:
Originally Posted by aIRpeACE View Post
this is a safety feature to prevent you from wrecking your car
I dont think so dude its a "safety" thing because im facing it while drving auto amd not even sport mode
gtouma is offline   Reply With Quote
Old 06-08-15, 02:08 PM   #12
gtouma
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2015
Location: Dubai
Posts: 11
Default

Quote:
Originally Posted by KOKISF View Post
Are u shifting w the paddles? If so probably you are hitting the rev limit, is the only reasson i can think of other than that should be an issue w the car
No im not the gear is set on drive and not even sport mode
gtouma is offline   Reply With Quote
Old 06-08-15, 02:10 PM   #13
gtouma
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2015
Location: Dubai
Posts: 11
Default

Quote:
Originally Posted by idoke1 View Post
It may need a tune up. Replace spark plugs with oem ones and see if that could help resolve it. Also, how bad is the cut off? Need more details.
Its around 2 seconds before automatically shifting to the next gear and the spark plugs are in good shape
gtouma is offline   Reply With Quote
Old 06-08-15, 02:24 PM   #14
chris07is
Lexus Champion
Trader Score: (8)
 
chris07is's Avatar
 
Join Date: Nov 2007
Location: 818/323/562
Posts: 2,264
Default

Wow, did u test drive this cae purchasing it?...take ut back the dealer were u got this from....NO CEL?
__________________
stock
08 IS-F 1IF2
07 IS 250 X PAC

RIP>>>ASIANGIRL007/LEXUS DIVA/818
chris07is is offline   Reply With Quote
Old 06-08-15, 02:38 PM   #15
gtouma
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2015
Location: Dubai
Posts: 11
Default

Quote:
Originally Posted by chris07is View Post
Wow, did u test drive this cae purchasing it?...take ut back the dealer were u got this from....NO CEL?
I knew the car wasnt in a good condition before buying it according to its price.. No cell.. just check system thatcorrespond to the tyre pressure which needs a reset
gtouma is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unfortunately, getting rid of my SC4 sc400injen Lexus Vehicles Classifieds 27 02-02-16 05:06 AM
Gauge placement/interior question zneubauer Performance & Maintenance 19 12-17-15 05:16 PM
Blue/Purple Projector Lens Color Flicker stiles17 GS - 3rd Gen (2006-2011) 2 01-10-15 08:37 AM
A Lernaean Hydra of a car DonMolina LS - 3rd Gen (2001-2006) 2 09-17-14 03:07 AM
TRS LED Fog Light Install BailsVT GS - 4th Gen (2013-present) 11 08-03-14 04:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 04:25 PM.



Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS