Blower motor perfomance - Club Lexus Forums

Blower motor perfomance

Thread Tools Search this Thread
Old 01-18-16, 07:06 PM   #1
Driver School Candidate
Thread Starter
Join Date: Nov 2010
Location: texas
Posts: 1
Default Blower motor perfomance

MY '08 IS250 blower motor doesn't have a lot of flow on high setting except when set to defrost (windshield only). When on defrost it seems like it is on a higher setting. It changes speeds from low to high on any mode but definitely changes to a higher speed on defrost. Is this normal?
jimmymunny is offline   Reply With Quote
Old 01-18-16, 07:12 PM   #2
Join Date: May 2015
Location: Ne
Posts: 107

My 07 is350 does the same. I questioned it at first but after checking that the defrost still blows hard assumed it was normal and intentional for noise reasons or something like that.
DickH is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Blower Motor Stopped Working 1991 LS400 Guywithcar LS - 1st and 2nd Gen (1990-2000) 8 02-02-16 02:51 PM
A/C malfunction Dozerman RX - 1st Gen (1999-2003) 1 09-24-15 07:04 PM
1996 LS400 fan blower problem whokidd LS - 1st and 2nd Gen (1990-2000) 29 09-05-15 05:40 PM
front defroster nht48823 HS 250h Model (2010-2012) 5 10-27-14 07:15 AM
Defrost problems... pmonag RX - 1st Gen (1999-2003) 1 10-26-04 02:24 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 07:47 AM.

Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved