Acceleration Problems - Club Lexus Forums


Go Back   Club Lexus Forums > Lexus Model Forums > IS Models > IS - 2nd Gen (2006-2013)
Log In 

Acceleration Problems

Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-21-14, 01:55 PM   #1
AceDon111
Driver School Candidate
Trader Score: (0)
 
AceDon111's Avatar
 
Join Date: May 2014
Location: PA
Posts: 4
Exclamation Acceleration Problems

3 weeks ago when i was driving on highway RT22 in pa happen to run over a big rock in the middle of the highway, and the panel with that filter broke off and got replace because, it was hanging. After that night my 07 IS 250 awd started move completely slow as in i would have to be flooring the gas pedal to get some form of speed going. need to have a idea of what i'm dealing with here before i go spend money on what can be simple problem.
AceDon111 is offline   Reply With Quote
Old 07-21-14, 02:09 PM   #2
idoke1
Lead Lap
Trader Score: (3)
 
idoke1's Avatar
 
Join Date: Oct 2013
Location: California
Posts: 597
Default

It can be a simple problem or a huge problem. You need to put it on a lift it and inspect the whole bottom half of the car. You could had damage more then just the bottom half of the engine cover.
__________________
Current rides:
2008 Lexus ISF
2009 Toyota Highlander Hybrid Limited AWD
2009 Jeep Wrangler Unlimited X

Pervious:
2007 Lexus IS350, 2006 VW Jetta GLI, 2005 Subaru WRX, 2004 Mazda RX8, 2002 BMW M3, 2000 Honda Civic Si, 1991 Toyota Supra Turbo
idoke1 is online now   Reply With Quote
Old 07-21-14, 02:14 PM   #3
Sceanzo
Driver
Trader Score: (0)
 
Join Date: Oct 2013
Location: NC
Posts: 157
Default

What panel with what filter? Take some pics.
Sceanzo is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help.. Hessitation under hard acceleration ExpoGeorgi LS - 1st and 2nd Gen (1990-2000) 5 12-18-13 09:51 PM
99 ES300 shakes at highway speeds gtg302s ES - 1st to 4th Gen (1990-2006) 6 09-26-12 10:30 AM
ac help on 98 ls 400 cheapboy LS - 1st and 2nd Gen (1990-2000) 2 06-14-11 08:32 PM
Humming Sound while driving Tmntman4 RX - 1st Gen (1999-2003) 1 09-28-10 09:52 AM
steering vibrating when drive on "some" highway speed over 70/mph lovelexus2 LS - 3rd Gen (2001-2006) 17 05-12-10 06:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 11:19 AM.

Copyright © 2000-2015 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS