need all the wiring experts HELP!!! - Club Lexus Forums


need all the wiring experts HELP!!!

Reply
 
 
 
Thread Tools Search this Thread
Old 03-24-14, 05:54 PM   #1
Wyzdum
Rookie
Thread Starter
 
Join Date: Dec 2012
Location: Fl
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Default need all the wiring experts HELP!!!

I have a 01 is300 and the cluster lights turn on but none of the needles work ... Also my security light keeps flashing even after I unplug the theft box ...
Wyzdum is offline   Reply With Quote
Old 03-27-14, 07:57 AM   #2
mitsuguy
Maintenance Moderator
iTrader: (2)
 
mitsuguy's Avatar
 
Join Date: May 2005
Location: AZ
Posts: 6,382
Thanks: 0
Thanked 0 Times in 0 Posts
Default

checked fuses, etc, I assume???

does the car start and run?

Initial thought is something wrong with the ECU, but the tachometer is not driven off the ECU, and if the engine runs, but the tach does not, then the ecu might still be bad, but there is something else wrong as well...
mitsuguy is offline   Reply With Quote
Old 04-16-14, 07:54 AM   #3
LEDHI
Driver School Candidate
 
Join Date: Apr 2014
Location: Hawaii
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try reset battery
LEDHI is offline   Reply With Quote
Old 05-25-14, 08:40 PM   #4
Wyzdum
Rookie
Thread Starter
 
Join Date: Dec 2012
Location: Fl
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried to reset the battery... The cats runs and drives great just that none of the needles read.. And the gear display doesn't show. All the lights light up tho ..that's why I'm stuck
Wyzdum is offline   Reply With Quote
Old 05-26-14, 03:22 AM   #5
LEDHI
Driver School Candidate
 
Join Date: Apr 2014
Location: Hawaii
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

There is also a plug that controls your dash odometer reading. Might be unplugged or bad harness. Not sure what the plug is called but it is located by your trans. Try search "odometer plug engine bay is300." It's illegal to unplug this plug cause it stops your odometer reading (if unplugged/damaged tach and speed needles don't work).
LEDHI is offline   Reply With Quote
Old 05-26-14, 10:02 PM   #6
Wyzdum
Rookie
Thread Starter
 
Join Date: Dec 2012
Location: Fl
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do u know the exact location by any chance ? I've looked non plugs look unplugged.. And its weird that all the lights turn on but the needles and display don'twork
Wyzdum is offline   Reply With Quote
Old 06-02-14, 02:32 AM   #7
LEDHI
Driver School Candidate
 
Join Date: Apr 2014
Location: Hawaii
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://my.is/forums/f115/dont-work-s...er-mpg-441853/

Check out this forum this might help.
LEDHI is offline   Reply With Quote
Old 06-06-14, 06:54 PM   #8
Wyzdum
Rookie
Thread Starter
 
Join Date: Dec 2012
Location: Fl
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK I think its either a wiring issue or BC I removed my abs... Idk bit I got all the lights in the cluster working ..still no needles work ..also the odometer screen is blank ...
Wyzdum is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Led lighting for driving lights kennyw418 RX - 2nd Gen (2004-2009) 2 06-07-14 02:25 PM
No Left Brake Light!!! JoelD IS - 1st Gen (2001-2005) 2 11-29-07 03:26 PM
fog light leinadmiih GS - 2nd Gen (1998-2005) 11 10-09-07 06:06 PM
No trunk lights? cdiddy IS - 2nd Gen (2006-2013) 5 08-25-06 05:54 AM
fog light indicator light Arvin SC430 - 2nd Gen (2001-2010) 8 04-03-03 02:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 12:57 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved