O2 Sensor replaced and engine light is back on - Club Lexus Forums


O2 Sensor replaced and engine light is back on

Reply
 
 
 
Thread Tools Search this Thread
Old 07-17-14, 01:45 PM   #1
ismike420
Driver School Candidate
Thread Starter
 
Join Date: Jul 2014
Location: Missouri
Posts: 4
Default O2 Sensor replaced and engine light is back on

I got the error code P0051 and I researched this forum and everything said to replace the bank 2 sensor 1. So I did that, I bought an $80 Bosch sensor and put it in. Everything seemed fine for about 50 miles and now the check engine, and vsc lights came back on. I am not sure what to do at this point... Anyone else had this happen? What should I do?
ismike420 is offline   Reply With Quote
Old 07-17-14, 02:33 PM   #2
ismike420
Driver School Candidate
Thread Starter
 
Join Date: Jul 2014
Location: Missouri
Posts: 4
Default

I just ran the new code and now it is saying P0031 B1S1... Is that common for both sides to go out at the same time like that or do I have something else going on possibly?
ismike420 is offline   Reply With Quote
Old 07-17-14, 02:41 PM   #3
burny
Lexus Champion
 
Join Date: Dec 2008
Location: VA
Posts: 1,609
Default

Our cars do not like Bosch. Buy Denso next time
burny is offline   Reply With Quote
Old 07-17-14, 02:57 PM   #4
ismike420
Driver School Candidate
Thread Starter
 
Join Date: Jul 2014
Location: Missouri
Posts: 4
Default

So you do think it is the O2 sensors? Even though I replaced B2S1 with a Bosch and that code didnt come back on? I just dont want to buy more sensors if it could be soemthing else. It just seems weird that I replace B2S1 and now B1S1 went out... I dont like coincedences
ismike420 is offline   Reply With Quote
Old 07-18-14, 06:48 AM   #5
chiph9
Lexus Test Driver
 
Join Date: Feb 2014
Location: TX
Posts: 953
Default

I've had both headlights burn out at the exact same time -- so yeah, sometimes identical parts fail at the same time. (I spent an afternoon testing the wiring harness and the switch, sure that it was in there and it couldn't be the bulbs -- it was the bulbs)

I concur on buying Denso next time.

Chip H.
chiph9 is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
catalytic converter issue please help. Iparkcars GS - 2nd Gen (1998-2005) 8 04-11-16 01:35 PM
Check Engine Light - OBD Code P2189 - Help! Seadaddy RX - 2nd Gen (2004-2009) 9 03-13-16 08:15 PM
Po 171 code thomasjti ES - 1st to 4th Gen (1990-2006) 3 02-01-16 08:57 AM
Transmission not shifting into over drive sometimes Bumbobee ES - 1st to 4th Gen (1990-2006) 26 08-02-14 06:29 PM
02 sensors...Can anyone help? MrHimbert GS - 2nd Gen (1998-2005) 11 07-24-14 10:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 06:40 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved