Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - Third Generation
Sign in using an external account
Register Forgot Password?

changed bearing, now "BRAKE MALFUNCTION/CHECK ABS/CHECK AWD" comes on. Lil help?

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 12-21-13, 12:00 PM   #1
bklynchris
Rookie
Trader Score: (0)
 
Join Date: Dec 2010
Location: NY
Posts: 62
Default changed bearing, now "BRAKE MALFUNCTION/CHECK ABS/CHECK AWD" comes on. Lil help?

Hi all,
We had a pretty good snowstorm in the northeast last week. While driving my '09 Gs350 awd I skidded and slammed my left rear wheel into a metal gutter. Ended up having to replace the wheel and tire. When that didn't get rid of the vibration at speed, I ended up changing the bearing/hub. About 10 mins after I left the mechanics shop I got the brake light on, the ABS light on, the TCS light on, and the display reads "BRAKE MALFUNCTION/CHECK ABS/CHECK AWD."

WHAT THE HELL DID THE MECHANIC JUST BREAK?
I hooked up my code reader to what codes its throwing up, but no codes appear. Can anyone give some guidance?

Thanks,
Chris
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
bklynchris is offline   Reply With Quote
Old 12-22-13, 02:44 AM   #2
XxGoKoUxX
Lexus Champion
Trader Score: (0)
 
XxGoKoUxX's Avatar
 
Join Date: Jul 2009
Location: FL
Posts: 2,870
Send a message via AIM to XxGoKoUxX Send a message via MSN to XxGoKoUxX Send a message via Yahoo to XxGoKoUxX
Default

Did the codes disappear? if it disappeared you should be okay.... He probably accidentally pinched the brake hose or something and it just acted up for a second and fixed itself. Otherwise I'd bring it back.

On the other note, glad you're okay!
XxGoKoUxX is offline   Reply With Quote
Old 12-22-13, 08:27 AM   #3
bklynchris
Rookie
Trader Score: (0)
 
Join Date: Dec 2010
Location: NY
Posts: 62
Default

I have a pretty simple OBDII scanner. When I hooked it up it read no scans, so there was nothing to delete. But there's obviously something wrong because its throwing up all those messages. I was gonna try disconnecting the battery for a couple hours to see if that would clear out the error messages. Anyone have any other tips?

Thanks,
Chris
bklynchris is offline   Reply With Quote
Old 12-23-13, 12:37 AM   #4
XxGoKoUxX
Lexus Champion
Trader Score: (0)
 
XxGoKoUxX's Avatar
 
Join Date: Jul 2009
Location: FL
Posts: 2,870
Send a message via AIM to XxGoKoUxX Send a message via MSN to XxGoKoUxX Send a message via Yahoo to XxGoKoUxX
Default

I meant, did it disappear from your dashboard as the indicator? I didn't mean on your OBD II scanner.

If it's still there, maybe hit the battery trick and come back with results!

GL!

Last edited by XxGoKoUxX; 12-23-13 at 12:38 AM.. Reason: (forgot to say GL lol)
XxGoKoUxX is offline   Reply With Quote
Old 12-23-13, 09:14 PM   #5
bklynchris
Rookie
Trader Score: (0)
 
Join Date: Dec 2010
Location: NY
Posts: 62
Default

So I disconnected the battery for about 18 hours in the hopes that the extended loss off battery power would erase whatever ABS AWD codes still persisted. Reconnected the terminals this morning: no luck. The messages still appear. Can anyone shed some light on what may have been damaged while the rear left bearing was changed?

thanks,
Chris
bklynchris is offline   Reply With Quote
Old 12-24-13, 01:22 AM   #6
ibidu1
Lexus Champion
Trader Score: (1)
 
Join Date: Mar 2012
Location: FL
Posts: 1,604
Default

Sounds to me as if the abs sensor, is not picking up a signal or is broken or maybe just unplugged.

I would start by taking off the wheel and examining the sensor, aswell as the opposite side sensor. From what I understand, you can use a multimeter to test the sensors to make sure they are functioning properly.

But before you start dumping big money into it, take it to the dealer for an hours worth of diagnostics.
ibidu1 is offline   Reply With Quote
Old 12-24-13, 01:22 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Warning Lights on: Check VSC, ABS, Brakes Tajai7 IS - Second Generation 4 07-03-14 02:49 PM
Help!!! Check AWD Scless IS - Second Generation 8 04-13-14 03:26 PM
Abs sensor 99es300LM ES300 and ES330 4 08-23-12 07:42 PM
I have ABS but it does not work..though no error light or fault is shown... Patsum LS400 9 11-01-11 08:38 PM
Check Engine Light - Code 71 EGR System Malfunction phollero GS - First Generation 10 05-03-07 03:27 PM


Tags
abs, awd, brake, check, lexus, lights, malfunction

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 09:36 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info