Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - Third Generation
Sign in using an external account
Register Forgot Password?

Check Engine Light - Check VSC

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 03-25-10, 06:19 AM   #91
Brian06
Driver School Candidate
Trader Score: (0)
 
Join Date: Apr 2009
Location: CA
Posts: 38
Default

Same here for me in my 06 GS. I only have 35k and the VSC came on. Went to the dealer and they replaced the cap under the emissions warranty and cleared the codes.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
Brian06 is offline   Reply With Quote
Old 04-07-10, 11:34 AM   #92
cino
Lexus Test Driver
Trader Score: (1)
 
Join Date: Dec 2009
Location: WA
Posts: 1,295
Default VSC light on

I was driving home from school, suddenly, the VSC and Check engine lights popped up. Acceleration was good when I give gas. Can anyone help me with this?
cino is offline   Reply With Quote
Old 04-07-10, 11:37 AM   #93
TWong350
Moderator
Trader Score: (8)
 
TWong350's Avatar
 
Join Date: Jul 2009
Location: SoCal
Posts: 2,482
Default

It could be anything, really. You'll need to get it checked for codes and go from there. It could be as simple as not tightening your gas cap enough though.
TWong350 is offline   Reply With Quote
Old 04-08-10, 07:28 AM   #94
IXI187IXI
Lexus Fanatic
Trader Score: (3)
 
IXI187IXI's Avatar
 
Join Date: May 2008
Location: Philly
Posts: 8,114
http://www.facebook.com/profile.php?id=100000548829927 AWD GS
Default

did anyone even read this thread?
__________________

2006 Lexus GS 300 AWD Glacier Frost Mica - Black - ML Package
20" x 8.5" Status Knight Wheels Black with Machine Face | Bridgestone G-Force Tires 245/30/20 | BC Racing Coilovers | Carson Tuned Lip Kit | 3000k HID Fogs | Prestigious Society Navi/DVD Override Kit | 15% Tint | Black Roof and Window Trim
IXI187IXI is offline   Reply With Quote
Old 04-27-10, 03:22 PM   #95
AmirLexus
Rookie
Trader Score: (0)
 
AmirLexus's Avatar
 
Join Date: Apr 2010
Location: NJ
Posts: 61
pak_aa_01 SirCrazy25
Default same

i just got my engine light on yesterday! ahh its so anoying to know i just bought it a month ago used. And didnt buy the warranty. I tightened my gas cap so hopefully that will fix it withing 4 days ( so ive read).
AmirLexus is offline   Reply With Quote
Old 04-28-10, 05:51 PM   #96
AmirLexus
Rookie
Trader Score: (0)
 
AmirLexus's Avatar
 
Join Date: Apr 2010
Location: NJ
Posts: 61
pak_aa_01 SirCrazy25
Default My VSC light turned off along with the check engine light

So i figured its from me not tightening my gas cap. I tightened the cap until 1 click!. i waited 2 and 1/2 days and it went off. It took about 20 on/off cycles and it went away. hope that helped =) I have a is250 thats why it was one click btw
AmirLexus is offline   Reply With Quote
Old 05-10-10, 11:01 PM   #97
84GTS
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2002
Location: MA
Posts: 46
Default Blinking Check Engine, VSC on, and loss of power

Hi-

I got 06 is250 AWD.. While driving in the rain, I got Blinking Check Engine, VSC on, and loss of power. Got home, restarted the car and everything is back to normal now.. Will I be able to retrieve any error codes from that incident or it can only be done while Check Engine is on? Is loss of power in my case = misfiring = problem with exhaust valves (Lexus TSB)? Thank you in advance.
84GTS is offline   Reply With Quote
Old 05-26-10, 11:49 AM   #98
ego93
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2010
Location: TX
Posts: 1
Default

2006 GS 300 here and still under warranty. I had this VSC issue come up over a year ago. Dealer replaced the oxygen sensor and said it was because we were putting bad gas in. we put nothing but premium as suggested so I let it be. Fast forward to a month and a half ago and the Check VS light comes back on. Took the car in to another Lexus dealer. One and a half days later I was told it was a broken valve spring. Will get the car by end of next day. Techs do a test drive and notice the problem returns.

The notice a few TSB from Lexus on it and proceed to tell me that the valves need to be replaced because of carbon buildup. They will need Lexus to oversee the operation and measure the parts before they are put back. Several weeks later and still no car. Apparently one of Lexus' chief engineers from Atlanta was called in. According to the service rep, the carbon buildup has to be cleaned off of the cylinders and they can only do two a day. Needless to say I'm not happy.

Can this car be declared a lemon? What guarantee will I have that it won't happen again? Maybe you guys should have your dealer check that angle.
ego93 is offline   Reply With Quote
Old 06-17-10, 04:58 PM   #99
kahuna2
Driver School Candidate
Trader Score: (0)
 
Join Date: May 2010
Location: AZ
Posts: 24
Default

My wife's '06 GS300 had the same problem, and the gas cap was the culprit. The dealer told me that the cap should be replaced after about 35-40k miles, as the rubber seal gets worn out. The gas cap keeps the fuel tank pressurized, which is needed for other sensors to work properly.


Quote:
Originally Posted by hziemba View Post
I had the same problem with my 06 GS. Turned out to be the gas cap not cranked down. I took it off, put it back on until I heard 3-4 clicks. A couple of days later, the light went out. Problem solved without a trip to the dealer.
kahuna2 is offline   Reply With Quote
Old 06-24-10, 02:51 PM   #100
84GTS
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2002
Location: MA
Posts: 46
Default

Yes, but I do not think a worn out gas cap will result in power loss.
84GTS is offline   Reply With Quote
Old 11-07-10, 02:28 PM   #101
HamBurglar
Driver
Trader Score: (0)
 
HamBurglar's Avatar
 
Join Date: Feb 2010
Location: TX
Posts: 153
Default

I had the samething happen all of sudden last night around 2:30am on my way home.

2006 GS300

The check engine light came on and the (!) light next to it and also I believe the traction control light (top left yellow light looks like a car swirving). The LCD was also saying Check VSC. I also have the Check Status light on before because when I changed my rims out a while back my shop wasn't able to mount my stock TPMS Sensors on my aftermarket rims, Discount said the could do it with an adapter for $70 but I haven't had time to go and get it done, but they said they couldn't reprogram the TPMS Sensors to different PSI but they could just reset it, so I figure I'd have to go to the dealer to have them do that (anyone know how much they charge to reprogram the TPMS Sensor to a different PSI?)

I digress...

After reading this thread I checked gas cap sealing o-ring, it didn't look worn out or old, so I put it back on. When I removed the cap it seamed a little lose but I'm usually pretty good about making it click 3-5 times when I fill up.
I drove around today turned the car on and off a handful of times while running errands and they remained on when I turned the car back on each time.

I changed my oil a few weeks ago to Royale Purple Sythentic and the oil filter but not the air filter.
I've been busy and had been looking at various auto stores for a K&N but no one has it in stock. After reading one guys post on page 3 or 4, he said his problem was a dirty air filter and a dirty MAF Sensor.

Well I just went to AutoZone and and had them run the ODBII scan and it came up with this code:

P0014
Definition
Camshaft position "B" timing over advance-
bank 1

Probable cause
1.Engine mechanical condition
2.Camshaft actuator condition

Now I don't know what all this means if anyone could translate I'd appreciate it.

When I left started my car up and left AutoZone and all those lights (check engine, the (!), and the traction control (swirvy car)) were all off? I don't know if it's because of the ODBII scan he did that temporarily turned it off and maybe it might turn back on after a few days or if it was just the gas cap?

Either way, if someone could translate or has had some more input let know.
I'll keep ya'll posted if the horrible error lights come back on.

Thanks.
HamBurglar is offline   Reply With Quote
Old 11-07-10, 05:06 PM   #102
BinaryJay
Lexus Champion
Trader Score: (0)
 
Join Date: Oct 2009
Location: Toronto
Posts: 2,994
Default

Quote:
Originally Posted by HamBurglar View Post
I had the samething happen all of sudden last night around 2:30am on my way home.

2006 GS300

The check engine light came on and the (!) light next to it and also I believe the traction control light (top left yellow light looks like a car swirving). The LCD was also saying Check VSC. I also have the Check Status light on before because when I changed my rims out a while back my shop wasn't able to mount my stock TPMS Sensors on my aftermarket rims, Discount said the could do it with an adapter for $70 but I haven't had time to go and get it done, but they said they couldn't reprogram the TPMS Sensors to different PSI but they could just reset it, so I figure I'd have to go to the dealer to have them do that (anyone know how much they charge to reprogram the TPMS Sensor to a different PSI?)

I digress...

After reading this thread I checked gas cap sealing o-ring, it didn't look worn out or old, so I put it back on. When I removed the cap it seamed a little lose but I'm usually pretty good about making it click 3-5 times when I fill up.
I drove around today turned the car on and off a handful of times while running errands and they remained on when I turned the car back on each time.

I changed my oil a few weeks ago to Royale Purple Sythentic and the oil filter but not the air filter.
I've been busy and had been looking at various auto stores for a K&N but no one has it in stock. After reading one guys post on page 3 or 4, he said his problem was a dirty air filter and a dirty MAF Sensor.

Well I just went to AutoZone and and had them run the ODBII scan and it came up with this code:

P0014
Definition
Camshaft position "B" timing over advance-
bank 1

Probable cause
1.Engine mechanical condition
2.Camshaft actuator condition

Now I don't know what all this means if anyone could translate I'd appreciate it.

When I left started my car up and left AutoZone and all those lights (check engine, the (!), and the traction control (swirvy car)) were all off? I don't know if it's because of the ODBII scan he did that temporarily turned it off and maybe it might turn back on after a few days or if it was just the gas cap?

Either way, if someone could translate or has had some more input let know.
I'll keep ya'll posted if the horrible error lights come back on.

Thanks.
Did you really need to post this here AND create a new thread with the same information in it?
__________________
http://i42.tinypic.com/30mmpe1.jpg
BinaryJay is offline   Reply With Quote
Old 11-08-10, 03:38 PM   #103
HamBurglar
Driver
Trader Score: (0)
 
HamBurglar's Avatar
 
Join Date: Feb 2010
Location: TX
Posts: 153
Default

Quote:
Originally Posted by BinaryJay View Post
Did you really need to post this here AND create a new thread with the same information in it?
For one, I just wanted to add my experience and keep this thread alive since many people have had the same problem the VSC and Check Engine light and different results.

The second post was mainly just to get the error code translated but I did add a brief discription so that they have a little background info on why it happened?

Savy?
HamBurglar is offline   Reply With Quote
Old 11-15-10, 02:47 PM   #104
Boomer99
Driver School Candidate
Trader Score: (0)
 
Join Date: Nov 2010
Location: NJ
Posts: 1
Default

Has anyone experienced this and also had their acceleration be affected? I had this occur last week. While travelling on a very busy highway, the lights came on and my car failed to accelerate "normally" even though I had it floored. As got off the highway and went up the exit, the accelaration was up in the 4 RPM's and yet I was barely going 20 MPH. I restarted the car and it went away. Oddly, it seems also to have shorted out my cigarette lighters as well, as now they do not work.
thanks!
Boomer99 is offline   Reply With Quote
Old 11-16-10, 08:15 PM   #105
marshmallo
Lexus Champion
Trader Score: (0)
 
marshmallo's Avatar
 
Join Date: Jun 2005
Location: MA
Posts: 2,184
Default

Quote:
Originally Posted by Boomer99 View Post
Has anyone experienced this and also had their acceleration be affected? I had this occur last week. While travelling on a very busy highway, the lights came on and my car failed to accelerate "normally" even though I had it floored. As got off the highway and went up the exit, the accelaration was up in the 4 RPM's and yet I was barely going 20 MPH. I restarted the car and it went away. Oddly, it seems also to have shorted out my cigarette lighters as well, as now they do not work.
thanks!
Yes, I just had this happen over the weekend... The VSC light flashed and I could not accelerate like I wanted on the highway.

On Monday the light became solid. I called the service dept and they said if the light is solid then it is not dangerous (which means it was dangerous when it was flashing??? Go figure ).

I took it in today and they took care of it free of charge. There was a TSB for my particular problem that was covered under the 70,000 mile drivetrain warranty. The cause of the problem was DIRT and the solution was PERFORM TOP ENGINE CLEAN. Seems like a common problem...

For reference my car has about 56K miles on it.
__________________
2006 GS300 AWD - Flint Mica
19'' Work Euroline FE, Toyo T1-R 245/40/19, Madico Tint 35%
Fabulous front lip | Wald sideskirts | INGS rear trunk spoiler | INGS rear half spoiler

Last edited by marshmallo; 11-16-10 at 08:45 PM..
marshmallo is offline   Reply With Quote
Old 11-16-10, 08:15 PM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Major repairs needed after only 80k miles. Need some advices kissbang GS - Third Generation 8 04-25-14 05:48 AM
Check engine light and Check VSC codes on, can anyone give me some advice-lexus techs anthraciteboy LS430 20 11-24-13 04:32 PM
LXT Automotive in Rockville, MD jayr0422 NELOC 5 01-13-10 02:25 PM
2001 LS430-Check engine light and Check VSC codes on, can anyone give me some advice anthraciteboy Maintenance 8 11-26-07 04:26 PM
2 Oxygen sensors out...No new ones being made?? jamesbl GS - Second Generation 20 11-13-06 12:56 PM


Tags
06, brake, cap, cel, check, engine, gas, gs300, gs430, is250, lexus, light, lights, ls430, reset, vsc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 04:54 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info