Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - Second Generation
Sign in using an external account
Register Forgot Password?


Faulty Positive Battery Terminal...

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 12-16-10, 01:15 PM   #1
GS300-2002
Pole Position
Trader Score: (0)
 
Join Date: Jun 2009
Location: Oklahoma
Posts: 283
Default Faulty Positive Battery Terminal...

So this week my car died

It showed all signs of a dead alternator so naturally we had it towed to the dealership (a whopping 4.5 miles away) which cost 177 DOLLARS!!! expecting to shell out alot more clams for a new alternator

Good news- The clamp on the positive battery terminal was faulty... WTF??? Has anyone ever had this problem before? and the new terminal that they installed is completely different so now my nice plastic cover for the positive terminal doesnt fit

Bad News- We shouldnt have gotten the car towed, it is a super easy install.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
__________________
2002 GS 300
Blitz Nur Exhaust
SRT Intake
Passport 8500 radar detector
Oklahoma City
GS300-2002 is offline   Reply With Quote
Old 12-16-10, 11:03 PM   #2
Big Mack
Lexus Champion
Trader Score: (1)
 
Join Date: May 2004
Location: Arizona
Posts: 2,670
Cool

I've had that problem in other cars, but not my Lex, thankfully.

As for the towing...this is why roadside assistance is handy. If you don't have a warranty, pay the extra $40-50 a year for it through your insurance. Pays off big time in situations like this or if you get a bad blow out. They take care of the towing, you pay only for the tire (or whatever repairs are needed).

Big Mack
__________________
Friends help you move. Real friends help you move bodies.

To my fallen brethren, you are not forgotten. To the usurpers of freedom, you are not forgiven.
Big Mack is offline   Reply With Quote
Old 12-17-10, 08:08 AM   #3
97JZA80
Driver
Trader Score: (0)
 
97JZA80's Avatar
 
Join Date: Jan 2007
Location: DE
Posts: 185
Default

Both of mine got corroded and gave me issues with starting, cut them both off and put some nice aftermarket stuff on and all problems were solved. Always thought it was odd that they corroded like they did, never had another car do that and this is a garage kept car...idk...
__________________
Mike
88 AllTrac - Project
92 SR5 Pickup - Project
97 Supra - Garage Queen
98 GS400 - Wifey
07 GX470 - Daily
97JZA80 is offline   Reply With Quote
Old 12-17-10, 08:08 AM
 
 
 
 
Reply

Tags
2007, 250, 470, battery, batterys, clam, corroded, es, gs, gs430, lexus, positive, rx350, terminal, terminals

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 02:54 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info