Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - Second Generation
Sign in using an external account
Register Forgot Password?

Please help! 3 lights on (vsc, vsc off, and cel)

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 09-14-04, 11:03 PM   #1
2redhots
Driver School Candidate
Trader Score: (0)
 
Join Date: Sep 2004
Location: New Mexico
Posts: 8
Default Please help! 3 lights on (vsc, vsc off, and cel)

Greetings all,

I am in need of some serious help. I recently purchased a 1998 gs 300. One day, I lost all power on the freeway, then I had these three lights on. I have taken it to lexus had it scanned in their computer. They informed me that i should replace the tps sensor, and the throttle motor. Both i have replaced, but to no avail have the lights dissappeared. I have disconnected the battery several times to reset the computer. I have no control over the throttle. The throttle is non existant, i have to floor it to get it to go anywhere.

I recently took it into a local shop (closer than lexus) that has equipment to read the ecu. They said i need to replace the ecu, because there was a spike that caused the computer to fry. Is this plausable? Are they just telling me that to get $1300.00 out of me? Any help is appreciated. Dunno where to go from here, have not had the car long enough to really enjoy it, or drive anywhere with the family. PLEASE HELP!
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
2redhots is offline   Reply With Quote
Old 09-14-04, 11:13 PM   #2
Seattle IS300
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2001
Location: Washington
Posts: 15
Default

Hi,

It could be 1 of 2 things:

Needs the TPS Sensor replaced.
or
It could be that it will need the ECU replaced. I had this problem with my 2001 GS300 and I continued to have it, till I had my car repurchased under the lemon law.

The part you will need is: 89666-30132 (ECU)

Danny Z
Seattle IS300 is offline   Reply With Quote
Old 09-15-04, 10:10 AM   #3
Automan
Lexus Test Driver
Trader Score: (3)
 
Automan's Avatar
 
Join Date: Oct 2002
Location: Alabama
Posts: 1,386
Send a message via AIM to Automan
Default

This has also happend to my 1998 GS 300 a few times but it has not happened in a while so I thought that maybe something had happened that had just fixed itself. Please keep me informed.
__________________
Automan is offline   Reply With Quote
Old 09-19-04, 10:48 AM   #4
2redhots
Driver School Candidate
Trader Score: (0)
 
Join Date: Sep 2004
Location: New Mexico
Posts: 8
Default took it to the dealer

Well took it to the stealer, they also diagnosed it as an engine computer. Three days and $1200 later we have our gs back. I was really starting to like the rx they loan us. They feel real nimble and sporty. They are real noisy though.

That is really horrible that an engine computer would go out in such a high dollar car. I have never had this kind of problem with my previous european cars. I bought the Lexus for reliabilty. period. So far i have put more money and time into this car than i have ever put into our 5 series

Time will tell though, hopefully it will get better!
2redhots is offline   Reply With Quote
Old 09-19-04, 10:48 AM
 
 
 
 
Reply


Tags
1998, 8966630132, ecu, gs300, vsc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 06:38 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info