Go Back   Club Lexus Forums > Lexus Model Forums > GS Models > GS - First Generation
Sign in using an external account
Register Forgot Password?

Luxury Performance: JZS161 motor & JZZ30 R154 5 speed swap

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 02-11-13, 02:23 PM   #46
10thMtnLex
Driver
Trader Score: (1)
 
Join Date: Oct 2012
Location: Colorado
Posts: 123
Default

Yoo Hoo!!! Congratulations Joe! Must have been a fun weekend, did you ever stop driving? How does it feel? Liven things up a bit getting off the line? Are you still running the OE 4.08 Diff? I have pondered swapping my SCs 4.27 gear into the GS just to try to liven it up. Post up the first weekend's driving test review!

Congratulations!!!! Have fun!, so jealous!
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
10thMtnLex is offline   Reply With Quote
Old 02-12-13, 07:26 PM   #47
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

Thanks! It just so happened my keyboard broke over the weekend so I put about 100 miles on the car. Few things to mention... Upon deceleration the drifeshaft clunks, not sure if my stock motor mounts are completely shot or what. Also occasionally at a higher speed I am getting something ticking, perhaps a plug hanging down... I also finished up my center console. Check it out.

Click the image to open in full size.
also doesn't mess up the function of my ash tray which I am excited about.
Click the image to open in full size.
joewitafro is offline   Reply With Quote
Old 02-14-13, 12:13 PM   #48
10thMtnLex
Driver
Trader Score: (1)
 
Join Date: Oct 2012
Location: Colorado
Posts: 123
Default

Looks great Joe! Console looks much better with the complete Shifter, boot and trim ring! Tones down the stainless nicely. I'd definitely be checking for the source of the clunk. Last time I had something like that, the center bearing support and mount were about 2 threads from falling out. Yikes!! Check everything over thoroughly. Tick would seem more minor. Have lots of fun on all the test runs! Holler back with more driving reviews!
10thMtnLex is offline   Reply With Quote
Old 02-14-13, 11:59 PM   #49
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

I will be giving it a look over this weekend.. I really think the clunk might be the dust shield clunking.. though not sure if its a good idea to trim it off or what. The clicking seems to start happening around 75 to 80 mph.. its very strange. I also plan to get some footage!
joewitafro is offline   Reply With Quote
Old 02-27-13, 12:13 AM   #50
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

Curious what spring rates you all would recommend for some coilovers? Thinking of picking up this set from circuit motorsports.

jzs147 BC coilovers for $995, without the swift springs.

Just ordered a set of xxr 521 18x8.5+25f 18x10+25r machined silver, cheap but I plan on driving on them to college for the next two years and more appropriate funding can come in. Going for the "performance" appeal and not hella flush VIP. I would eventually like to be able to go drifting with the car but it is mainly a daily "spirited" driver for now. What tires would you guys recommend? I was thinking 235/45/18f 275/45/18r and renting a roller to clean up the edge and pull a little. I've still been trying to find a front drivers fender.

As for maintenance updates: EGR code 71 is on but I have an okay idle.. Though I feel I have been a bit hard on the throttle lately, I think I'll get about 275 miles to this tank if I'm lucky.. Got a set of EGR gaskets and I am hoping its just clogged and will be an easy fix as I'm wanting to take the car on its first little road voyage up north to Seattle with some friends.

Currently have 400 miles on it and the ticking went away, could have been a hanging clip that I didn't tie up enough though I haven't had the ability to lift it up to see. Cruise control works great, same with my reverse lights, even lights up on the dash. Although I do have the blinking O/D light. I plan on removing that bulb once I get my LED kit in.

Put my old amplifier back in the car to get my antenna to at least partially lower and my trunk has seemed rather dry, but when I turn my radio on I get no sound from the speakers at any volume.. Would it not being bolted in have something to do with it?
joewitafro is offline   Reply With Quote
Old 02-28-13, 04:37 PM   #51
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

Thinking of going 12 front/ 10 rears on the springs... They offer stock 10/8.. What do you all think?
joewitafro is offline   Reply With Quote
Old 03-02-13, 03:44 PM   #52
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

Thinking about considering the PBM coilovers instead for our car, but I don't want to slam it on the ground. Will these coilovers be able to sit at a reasonable ride height and not just be so VIP?

By the way.. Updates! Tires are ordered..
Click the image to open in full size.
joewitafro is offline   Reply With Quote
Old 03-02-13, 06:56 PM   #53
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

fitment pictures.. staggered xxr 521
18x8.5 +25f, 18x10 +25r.
Going with hankook ventus v12 evo tires 245/45/18f and 275/40/18r.
Click the image to open in full size.
Click the image to open in full size.
joewitafro is offline   Reply With Quote
Old 03-04-13, 06:09 PM   #54
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

Click the image to open in full size.
joewitafro is offline   Reply With Quote
Old 03-04-13, 10:49 PM   #55
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

Just ordered some Max VIP 18/14 coilovers.
joewitafro is offline   Reply With Quote
Old 03-05-13, 08:21 AM   #56
10thMtnLex
Driver
Trader Score: (1)
 
Join Date: Oct 2012
Location: Colorado
Posts: 123
Default

Looks great Joe! Love the BBS look, have 17" RXs on mine. Do the XXRs have clearance for the LS BBK??
10thMtnLex is offline   Reply With Quote
Old 03-05-13, 08:29 AM   #57
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

The fronts should clear supra TT 4 pot front brakes (18x8.5 +25). Thanks! I need to find a fender ASAP and get a roll!
joewitafro is offline   Reply With Quote
Old 03-11-13, 07:48 PM   #58
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

Got the coil overs installed! Had to raise it up a bunch cause it was slammed as heck! Also got it aligned today and thankfully there isn't any more rubbing but its pretty stiff, and I am fully turned to "hard" and one click soft in the fronts. Need to borrow or buy a fender roller and replace the driverside front fender before it goes any lower. Also, do you guys think its fine to pull out the fender liner? Its rubbing in the back/front of the front fender.

Click the image to open in full size.
joewitafro is offline   Reply With Quote
Old 04-28-13, 09:29 PM   #59
twojayzee
Lexus Champion
Trader Score: (0)
 
Join Date: Aug 2001
Location: Emerald City
Posts: 1,837
Default

Any updates on this project ?
__________________
TEIN WARNING - http://www.clublexus.com/forums/susp...dangerous.html
twojayzee is offline   Reply With Quote
Old 04-28-13, 09:43 PM   #60
joewitafro
Lead Lap
Trader Score: (0)
 
joewitafro's Avatar
 
Join Date: Jun 2007
Location: Washington
Posts: 644
Send a message via AIM to joewitafro
Default

I'm in finals this week so I haven't really focused on the car much, but... I did pick up a replacement green drivers fender, and put a single din stereo in the car and wired it without an amplifier. The speed sensor went out sadly so I have no speedometer right now, I plan on using a supra cable speedometer with marlin crawler adapter to get it working again. Will update you guys more once I throw the fender on. The suspension has been feeling pretty good, and I have been wanting to rebuild the motor badly with a turbo to get a little more pep out of it! But that will probably come after summer.
joewitafro is offline   Reply With Quote
Old 04-28-13, 09:43 PM
 
 
 
 
Reply

Tags
1993, 240sx, 93gs, adaptor, doesnt, driftmotion, driver, flange, gs300, lexus, light, r154, reverse, speedometer, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Photoshop need Duane1 Photoshop Forum 0 03-20-13 08:13 AM
MD For sale- 18"x8" Enkei Tarmac rims/wheels and tires for RX300 Smartazz91 Wheels and Tires Classifieds 5 02-01-13 04:35 PM
I think this is complete bulb swap :) 2k11sfrx RX - Third Generation 34 01-30-13 03:50 AM
1UZ-FE swap complete. S366, Haltech, E85 enslaved87 Performance & Maintenance 52 10-17-12 11:15 AM

All times are GMT -7. The time now is 09:50 AM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info