Check Engine Light - Check VSC - Page 14 - Club Lexus Forums


Check Engine Light - Check VSC

Reply
 
 
 
Thread Tools Search this Thread
Old 10-01-14, 10:26 PM   #196
drew1976
Driver School Candidate
 
Join Date: Oct 2014
Location: CA
Posts: 2
Default

I have a 2007 GS350 and all of the lights (Check 4WD, Check VSC, Brake, Engine Warning, etc.) are on.

I bought a scanner, hooked it up and it came back with no codes. I know the scanner is working because it came back with the correct VIN, but no codes at all. From reading this thread and elsewhere, I'm thinking it is either a fuse (how to tell which fuse) or something with the battery? Can't figure out what else it could be since the reader is coming back with no codes. Also want to make sure it is safe to drive since there are no actual codes flipped. The fact that the Brake (emer brake) light is on too makes me believe it's something electrical. Battery is less than a year old from Autozone.

Any other ideas or something I'm missing?
drew1976 is offline   Reply With Quote
Old 10-02-14, 04:30 AM   #197
burny
Lexus Champion
 
Join Date: Dec 2008
Location: VA
Posts: 1,609
Default

Alternator or battery would be my guess.
burny is offline   Reply With Quote
Old 10-13-14, 04:29 PM   #198
drew1976
Driver School Candidate
 
Join Date: Oct 2014
Location: CA
Posts: 2
Default

So my GS350 mentioned above with all the lights (brake, VSC, 4WD, CEL, etc.) - the battery tested out ok but alternator tested bad.

We had the alternator replaced but all the lights are still coming on. Taking it to the dealer tomorrow, but anything else I should check before taking it in? It's still coming back with no codes reported on the scanner.
drew1976 is offline   Reply With Quote
Old 10-13-14, 10:44 PM   #199
warandcar
Lead Lap
 
warandcar's Avatar
 
Join Date: Jul 2014
Location: ca
Posts: 500
Default

please keep us updated to what the dealer says… thanks
warandcar is offline   Reply With Quote
Old 10-14-14, 01:47 PM   #200
drone6
Driver School Candidate
 
Join Date: Oct 2010
Location: NE
Posts: 22
Default

I just had this situation happen this past week with my 2006 GS RWD.

The code was:

P0031
Heated Oxygen
Sensor Heater
Control Circuit Low
Bank 1 Sensor 1

10 dollar gas cap, a few days (3) of regular use and the lights/code are gone.

I made a different thread thinking it was the O2 sensors, so wanted to post in this thread in case anyone else has the same code in future.
drone6 is offline   Reply With Quote
Old 10-21-14, 07:29 PM   #201
pakilegacy
Driver School Candidate
 
Join Date: Oct 2014
Location: TX
Posts: 1
Default VSC light wont go away

The following post can go in multiple threads but I'll post it here and post a link in other threads if needed.

Ok, so my alternator died and I got it replaced. A few days after that, my car would jerk when shifting from 5th to 6th gear. I thought it was transmission but after researching here I decided do a ECU reset. I know I pulled and put the fuse back in correctly. However, after this, I had several issues.

1. VSC light is on with CHECK VSC message.
2. Remote won't unlock the door.
3. The unlock button on the door won't work.
4. Door lights won't come on.
5. cabin lights won't come on.
6. AFS light blinks constantly.

# 2 - #5 works fine once I start the car though.

My question...what may have I inadvertently done wrong while trying to reset ECU? How come so many things stopped working all of a sudden?

By the way, the issue with my transmission stuttering between 5th and 6th gear is still there. If this turns out to be transmission issue, I would dump the car and get a new one, however, I want the lights gone otherwise dealer won't pay anything for it. I just got new tires, batteries and alternater so I have quite a bit invested in the car already but I am willing to cut my losses if it is transmission.

Last edited by pakilegacy; 10-21-14 at 10:52 PM.
pakilegacy is offline   Reply With Quote
Old 10-21-14, 08:14 PM   #202
BinaryJay
Moderator
 
Join Date: Oct 2009
Location: Toronto
Posts: 3,145
Default

Quote:
Originally Posted by drone6 View Post
I just had this situation happen this past week with my 2006 GS RWD.

The code was:

P0031
Heated Oxygen
Sensor Heater
Control Circuit Low
Bank 1 Sensor 1

10 dollar gas cap, a few days (3) of regular use and the lights/code are gone.

I made a different thread thinking it was the O2 sensors, so wanted to post in this thread in case anyone else has the same code in future.
Completely coincidental... there is no way a gas cap sets that code. It will probably come back again.
BinaryJay is offline   Reply With Quote
Old 02-08-15, 01:12 PM   #203
jagzz
Driver School Candidate
 
Join Date: Feb 2015
Location: onatrio
Posts: 1
Default check vsc light

I have been dealing with the check engine and vsc light for about 1 year on my 2006 gs awd.

Here's my story about how I eventually got it fixed. The first thing was the gas cap which is usually never the problem just a quick fix and a reset. After doing this the light came back on so I took it to another mechanic. He told me after inspecting the car their where no leaks in the exhaust and the O2 sensors seemed ok as well. The mechanic then suggested a $2200 cat convertor replacement. I was not happy to hear this. I did not go through with the repair and continued to drive for 6 months.

Eventually I started hearing a leak in the exhaust so I took to a professional muffler and exhaust place. They notices the leak in 2 minutes and swapped the pipe that was leaking. Finally the vsc light turned off after 2 weeks and has not returned in a week. Before it would turn off once I a while but return within a day. Would suggest that talking your gs to a professional muffler and exhaust place. He even gave me a way better qoute to change the cats if iI had too around 1000 bucks which seems reasonable thank god it looks good for now
jagzz is offline   Reply With Quote
Old 06-23-15, 03:12 AM   #204
iqballubna
Driver School Candidate
 
Join Date: Jun 2015
Location: tamil nadi
Posts: 2
Default

Quote:
Originally Posted by wassabie View Post
I had my ECU replaced due to the check VSC and VDIM warning messages. This was back in november. It took the dealer about 1 week to order the parts...and then half a day to replace the ECU. So far so good...although I had recently had the light come on once...maybe it was just a random instance...*cross finger*



hi my car was problem vsc system i dont know how to rectified
iqballubna is offline   Reply With Quote
Old 06-23-15, 03:16 AM   #205
iqballubna
Driver School Candidate
 
Join Date: Jun 2015
Location: tamil nadi
Posts: 2
Default

how to rectified the vsc system warning when while driving the car suddenly vsc warning will come the car will be going slow below 80km per h can u pls tel me how to rectified
iqballubna is offline   Reply With Quote
Old 06-24-15, 08:15 AM   #206
designo
Lexus Champion
iTrader: (4)
 
designo's Avatar
 
Join Date: Sep 2009
Location: Bahrain
Posts: 2,203
Default

Had to replace the starter and crankshaft postion sensor.

designo is offline   Reply With Quote
Old 07-27-15, 09:29 AM   #207
Drawde
Driver School Candidate
 
Drawde's Avatar
 
Join Date: Jul 2015
Location: CA
Posts: 2
Default check VSC and blinking engine light, etc

Mine was a 2006 Lexus IS 250

The codes read out as:

Cylinder 5 misfire
Cylinder 6 misfire

Solution: changed spark plugs; used NGK Iridium ones and then mechanic reset the OBD. Mechanic also transferred the coil packs 5 and 6 from the back to the front, just in case the coil packs go bad, they are easily reachable.

mechanic also charged 3 hrs for labor so quite expensive though at $70/hour .

car now drives smoothly like new. =)


After driving for two days, check VSC has not come back (hope it'll never come back due to these cylinder misfires)
Drawde is offline   Reply With Quote
Old 04-21-16, 10:59 AM   #208
samik
Driver School Candidate
 
Join Date: Apr 2016
Location: -
Posts: 1
Default

So my lexus is 220d dies after drift. I try to start it and the start just runs like ten seconds. it may start or may not. But it will start second or third time. After it starts there is no problem with the car. Works fine unless i drift it. Any solutions to that ?
samik is offline   Reply With Quote
Old 05-06-16, 05:30 PM   #209
gr8fulRed
Pole Position
 
Join Date: Jan 2015
Location: Oklahoma
Posts: 206
Default

2009 GS350 RWD sitting at 95,500mi. Today the "check engine light" and the "VSC/Slip Control light" came on. Car had zero difference in performance/drive/sound, etc. I, coincidently, had topped off my coolant resivoir this morning and when I did....I cleaned/wiped that front black plastic clean, where the air intake scoops are, with a shop rag and some tire shine. I dried it off pretty well, but a drop or two of the tire shine was left down in the hood latch area. Was wondering if some of that could've got sucked into an area that would have fouled up the MAF sensor or something ??

Or...did I just have my MAF/O2 sensor just crap the bed on me all of the sudden?? Any ideas? I'll drop by a parts store tonight and have them pull codes. Assuming it's a O2 sensor....is this a DIY type fix ? I've done them on my Honda's...hopefully the GS's are easy.
gr8fulRed is offline   Reply With Quote
Old 05-06-16, 06:49 PM   #210
gr8fulRed
Pole Position
 
Join Date: Jan 2015
Location: Oklahoma
Posts: 206
Default

O'Reily's Parts store pulled codes and got... C1201 Electronic Control System Malfunction, C1241 Low or High Power supply voltage, P0101 Mass Air Flow Sensor and P0136 Oxygen Sensor Bank 1 Sensor 2


Then went to AutoZone and had them pull codes.... they came back with P0136 (O2) and P0101 MAF

So...Safe to say that P0136 and P0101 need replacing. I'm sure they both didn't crap out at the same time. Is it just that possibly one was not "quite bad enough" to trip the light but still can show on the scan?? That is what the AutoZone guy said. Crap...I should've had him reset them..then wait to see if they come back on.

I had the guy check the battery too (since some people have found that to be the source) but it's only a little over a year old/18k mi and it checked out ok.

Last edited by gr8fulRed; 05-07-16 at 05:44 AM.
gr8fulRed is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2007-2012 Lexus ES350 VSC light, Check Engine Light, & Explanation Lights on! Local500 ES - 5th Gen (2007-2012) 26 08-15-16 11:05 AM
Major repairs needed after only 80k miles. Need some advices kissbang GS - 3rd Gen (2006-2011) 8 04-25-14 04:48 AM
Service Excellence, but not from a Lexus Dealership WISLUGGO SC430 - 2nd Gen (2001-2010) 8 08-17-10 12:00 PM
3GS almost wrecked, caused by dealership negligence, thoughts? 3GSdriver GS - 3rd Gen (2006-2011) 49 05-23-10 12:00 AM
Check engine light/VSC Check failed jboyle034 GS - 3rd Gen (2006-2011) 17 09-19-09 07:32 PM


Tags
06, brake, cap, cel, check, engine, gas, gs300, gs430, is250, lexus, light, lights, ls430, reset, vsc

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 08:16 AM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved