Go Back   Club Lexus Forums > Lexus Model Forums > ES Models > ES300 and ES330
Sign in using an external account
Register Forgot Password?

Air Bag Light Flashing

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 02-22-11, 06:53 PM   #1
angmedic91
Lexus Test Driver
Trader Score: (5)
 
angmedic91's Avatar
 
Join Date: Jun 2009
Location: Moorpark, CA
Posts: 857
Angmedic911 angmedic
Default Air Bag Light Flashing

Got a question for the experts or the ones who have experienced this themselves. I did do some research on here and found some good info, but my situation is weird. So, I thought I would ask on here. I have a 98 ES300 with about 155,000 miles on it and just the other day I noticed the air bag light was flashing. I read the advice on here and took it to the Lexus dealer and my friend that works there, had them scan for a code and to my surprise, there was no code. The tech even drove my car for awhile and the indicator light did not flash. I picked up my car on President's day and was told to bring it in when the light stays on. Well, when I got home, 8 mile drive from the dealer, I decided to wash the car. When I finished, I looked into the car and noticed the air bag light was on. It was not on when I got home, it turned on while washing the car. I then started the car and the light stayed on and as soon as I put in into drive the light went off. I placed back in park and the light went on, put back in drive and turned off. I then drove about 20 minutes, 14 miles and then placed it in park and the light never came back on. I then drove back home on the freeway and light would blink occasionally, but now the light stays off. I'm wondering if there is a lose wire or a wire that got wet when I washed my car. Any suggestions or ideas. Thanks for the input.
This ad is not displayed to registered members.
Register your free account today and become a member on Club Lexus!
__________________
Robert

http://www.clublexus.com/forums/es30...-es-300-a.html

HID 8K LB & 6K DL/TSW Snetterton/K-Sport Coilovers/Drilled & Slotted Rotors/VIS Front Lip/Eyebrows/Clear Corners/NST Underpulley/Rebored TB/01 Front Grill/Optima Battery/Solara SB/Window Tint/01 Wood Grain Steering Wheel/Wood Dash Kit/RX300 Wood/Leather Shift ****/LED Int. & License Plate Lights/ED Side Skirts/Chrome Pillar Posts/Chrome Magna Flow Exhaust/LED Rear Spoiler/TRD RSB/01 Taillights
angmedic91 is offline   Reply With Quote
Old 02-22-11, 08:12 PM   #2
Lexus2000
Lexus Champion
Trader Score: (0)
 
Lexus2000's Avatar
 
Join Date: Sep 2010
Location: Alberta
Posts: 1,668
Default

That's a weird problem, but it does sound like a flaky connection. I do know on these systems that the ECU will flag a problem if the airbag light indicator itself (or the associated circuit) is bad, that might be what's going on with your car.

What throws me off is the light is not always on or flashing, bad ECU?
__________________

My cars: 2000 ES300 | 1990 Camry
Lexus2000 is online now   Reply With Quote
Old 02-23-11, 01:03 AM   #3
GEORGE_JET
Lead Lap
Trader Score: (0)
 
Join Date: Apr 2008
Location: tx
Posts: 745
Default

You could try cleaning the connector to the airbag control unit. Radio shack has a contact cleaner called De-ox, comes in a small spray can. Make sure that you disconnect the grd cable on the battery, and wait at least 5 min before removing any of these connectors.
GEORGE_JET is offline   Reply With Quote
Old 02-24-11, 12:28 AM   #4
angmedic91
Lexus Test Driver
Trader Score: (5)
 
angmedic91's Avatar
 
Join Date: Jun 2009
Location: Moorpark, CA
Posts: 857
Angmedic911 angmedic
Default

Quote:
Originally Posted by Lexus2000 View Post
That's a weird problem, but it does sound like a flaky connection. I do know on these systems that the ECU will flag a problem if the airbag light indicator itself (or the associated circuit) is bad, that might be what's going on with your car.

What throws me off is the light is not always on or flashing, bad ECU?
I was wondering myself if I could have a bad ECU. I did scan for a code when the air bag light was on using an OBD II scanner and no code at all.

Quote:
Originally Posted by GEORGE_JET View Post
You could try cleaning the connector to the airbag control unit. Radio shack has a contact cleaner called De-ox, comes in a small spray can. Make sure that you disconnect the grd cable on the battery, and wait at least 5 min before removing any of these connectors.
Where is the air bag control unit located? Im wondering if one of the wires going to the bumper sensor is causing this issue. Just weird that it came on while washing my car. Wondering if water got into the sensor or a wire that is exposed and water got in. Thanks George and Lexus2000 for your input.
__________________
Robert

http://www.clublexus.com/forums/es30...-es-300-a.html

HID 8K LB & 6K DL/TSW Snetterton/K-Sport Coilovers/Drilled & Slotted Rotors/VIS Front Lip/Eyebrows/Clear Corners/NST Underpulley/Rebored TB/01 Front Grill/Optima Battery/Solara SB/Window Tint/01 Wood Grain Steering Wheel/Wood Dash Kit/RX300 Wood/Leather Shift ****/LED Int. & License Plate Lights/ED Side Skirts/Chrome Pillar Posts/Chrome Magna Flow Exhaust/LED Rear Spoiler/TRD RSB/01 Taillights
angmedic91 is offline   Reply With Quote
Old 03-03-11, 10:48 AM   #5
angmedic91
Lexus Test Driver
Trader Score: (5)
 
angmedic91's Avatar
 
Join Date: Jun 2009
Location: Moorpark, CA
Posts: 857
Angmedic911 angmedic
Default

Wondering if anyone else has insight into my problem or has experienced this issue. Thank you!
__________________
Robert

http://www.clublexus.com/forums/es30...-es-300-a.html

HID 8K LB & 6K DL/TSW Snetterton/K-Sport Coilovers/Drilled & Slotted Rotors/VIS Front Lip/Eyebrows/Clear Corners/NST Underpulley/Rebored TB/01 Front Grill/Optima Battery/Solara SB/Window Tint/01 Wood Grain Steering Wheel/Wood Dash Kit/RX300 Wood/Leather Shift ****/LED Int. & License Plate Lights/ED Side Skirts/Chrome Pillar Posts/Chrome Magna Flow Exhaust/LED Rear Spoiler/TRD RSB/01 Taillights
angmedic91 is offline   Reply With Quote
Old 03-03-11, 01:03 PM   #6
download
Rookie
Trader Score: (0)
 
download's Avatar
 
Join Date: Jan 2011
Location: Sol 3
Posts: 56
Default

My ex. 94 camry, the gauge cluster lights would dance when rainning, I could not find any reason till one day - changed the noisy alternator.
All the flashing lights gone.
download is offline   Reply With Quote
Old 03-03-11, 06:07 PM   #7
Lexus2000
Lexus Champion
Trader Score: (0)
 
Lexus2000's Avatar
 
Join Date: Sep 2010
Location: Alberta
Posts: 1,668
Default

From the service manual, hopefully it will help you out.

http://img818.imageshack.us/img818/9...rbagsystem.png
__________________

My cars: 2000 ES300 | 1990 Camry
Lexus2000 is online now   Reply With Quote
Old 03-03-11, 06:30 PM   #8
angmedic91
Lexus Test Driver
Trader Score: (5)
 
angmedic91's Avatar
 
Join Date: Jun 2009
Location: Moorpark, CA
Posts: 857
Angmedic911 angmedic
Default

Quote:
Originally Posted by download View Post
My ex. 94 camry, the gauge cluster lights would dance when rainning, I could not find any reason till one day - changed the noisy alternator.
All the flashing lights gone.
Hmmmm, that was a weird thing for you, especially the alternator causing it. The only light the dances is the air bag light, all other lights are fine.

Quote:
Originally Posted by Lexus2000 View Post
From the service manual, hopefully it will help you out.

http://img818.imageshack.us/img818/9...rbagsystem.png
Thanks bro for the schematic, it helped as far as where to find it.


Update: The air bag icon continues to flash, but now seems to stay on more and is even on when the car off. From my observation, it seems to be a bad sensor or something thats senses motion. For instance, if im at a stop light, the icon will be on and as soon as I accelerate if goes off, but comes on again when I drive at a constant speed. If I hit the brakes it will turn off, but then come back on at a stop light. Im probably going to take it back to the dealer and have them scan for a code. The first time I took it to them, it barely flashed and was not on when I took it to them and when they scanned it, no code. Im hoping now, with it more on than off, it will have a code as to what is wrong with it.
__________________
Robert

http://www.clublexus.com/forums/es30...-es-300-a.html

HID 8K LB & 6K DL/TSW Snetterton/K-Sport Coilovers/Drilled & Slotted Rotors/VIS Front Lip/Eyebrows/Clear Corners/NST Underpulley/Rebored TB/01 Front Grill/Optima Battery/Solara SB/Window Tint/01 Wood Grain Steering Wheel/Wood Dash Kit/RX300 Wood/Leather Shift ****/LED Int. & License Plate Lights/ED Side Skirts/Chrome Pillar Posts/Chrome Magna Flow Exhaust/LED Rear Spoiler/TRD RSB/01 Taillights

Last edited by angmedic91; 03-24-11 at 05:48 PM..
angmedic91 is offline   Reply With Quote
Old 03-24-11, 06:10 PM   #9
angmedic91
Lexus Test Driver
Trader Score: (5)
 
angmedic91's Avatar
 
Join Date: Jun 2009
Location: Moorpark, CA
Posts: 857
Angmedic911 angmedic
Default Update

Update on my issue for those that it may help out in the future.

Well, I took my car back into the Lexus Dealer about two weeks ago. I have a good friend that is a service Rep. at my local Lexus dealer and she really takes care of me with service and cost. Anyways, took it back because the airbag light is back on and stays on. Well, the tech had narrowed it down to either the airbag unit or the wire loom to the engine compartment. He scanned for a code and no code came up, so he was leaning towards a problem with the wire loom. The other day I got an update and low and behold it's the wire loom/data link cable that runs out to the front of the car in the engine compartment. Apparently, this data link cable is old school, obselete in a sense to Lexus. This was the old school way of reading codes from the airbag unit, but apparently Lexus can now plug into the unit via another cable link behind the glove box which actually gives the Lexus tech a trouble code on a scanner. Well, the old school cable in the engine compartment is apparently frayed somewhere and is ground, causing the airbag light to flash and pretty much stay on. He came to this conclusion when him and another tech were working on it and one tech moved the wire cable and the other tech noticed the airbag light turn off, when he pulled the wire back it came back on. Conclusion, the tech suggested, since the data cable is obselete, he suggested to uplug if from the other cable link behind the glove box. The other choices I had was to place that old school data link cable or have them run new wire to the the other end of the cable in the engine compartment. I opted to have them disconnect the old school cable, easier to do and cost effective. They have assured me the SRS system is properly working. I hope this may help others in the future with maybe the same issue. I have to admit this issue was very unique, even the tech had never experienced this before on another ES300. Oh well, just my luck.
__________________
Robert

http://www.clublexus.com/forums/es30...-es-300-a.html

HID 8K LB & 6K DL/TSW Snetterton/K-Sport Coilovers/Drilled & Slotted Rotors/VIS Front Lip/Eyebrows/Clear Corners/NST Underpulley/Rebored TB/01 Front Grill/Optima Battery/Solara SB/Window Tint/01 Wood Grain Steering Wheel/Wood Dash Kit/RX300 Wood/Leather Shift ****/LED Int. & License Plate Lights/ED Side Skirts/Chrome Pillar Posts/Chrome Magna Flow Exhaust/LED Rear Spoiler/TRD RSB/01 Taillights
angmedic91 is offline   Reply With Quote
Old 04-08-14, 12:35 AM   #10
5H2DA
Driver School Candidate
Trader Score: (0)
 
Join Date: Jun 2007
Location: Washington
Posts: 2
Default Flashing air bag light

I have a '99 Lexus RX300 with 180K miles. While driving the car on the freeway today for several hours, the air bag light began flashing on/off at about a 1 second rate. This flashing duration became more random until I stopped for gas about 30 minutes later. When I restarted the car, the light was out, and remained out for over 3 hours. Just before I stopped again for gas, the light began flashing. Restarting the car and driving another 2 hours and the light stayed out.

Reading through the thread, it sounds as though a wire in the engine compartment may be the issue. Since the thread is 5 years old, is there any new information which can be shared from the talented masses?
5H2DA is offline   Reply With Quote
Old 04-08-14, 12:35 AM
 
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Warning lights staying on Packers RX - Second Generation 3 09-03-13 08:39 PM
Air Bag and ABS light on in my 92 SC 400 crrc5508 SC 400/300 2 07-02-13 10:06 PM
Air Bag and ABS light on crrc5508 SC 400/300 1 07-02-13 10:11 AM
Runnign rough after radiator leak/swap... luvmyaussy Performance & Maintenance 12 07-08-11 10:08 PM
Noob here with 93 LS400 and have some probs. Need help bad....:( 95ES-300 LS400 14 07-25-10 10:11 AM


Tags
98, air, airbag, bag, blinking, car, es300, flashing, gx470, lexus, light, park, put, rx300, srs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 07:31 PM.

Join ClubLexus
Advertising


Copyright © 2000-2008 Internet Brands, Inc. All Rights Reserved
Privacy Policy | Disclaimer | Terms of Use | JOBS


Get all contact info