Finally posting pics, ES on 20's - Club Lexus Forums

Log In 

Finally posting pics, ES on 20's

Reply
 
 
 
Thread Tools Search this Thread
Old 08-18-13, 10:19 AM   #1
ChristianM
Driver School Candidate
Thread Starter
 
Join Date: May 2012
Location: Ontario
Posts: 20
Cool Finally posting pics, ES on 20's

So I'm finally getting around to posting some pics of my car. Haven't done too much as of yet but I'm working on it slowly. The rims are Lexani LSS8 20"x8.5" running 255/30R20 Goodyear Eagle F1's. It hasn't been lowered yet, trying to pick out a suspension setup for next summer. That second pic where the tires are almost rubbing the fender, that's just what it looks like with a full car load of people
Attached Thumbnails
Finally posting pics, ES on 20's-img_00000265.jpg   Finally posting pics, ES on 20's-img_00000305.jpg   Finally posting pics, ES on 20's-img_00000339.jpg  
ChristianM is offline   Reply With Quote
Old 08-18-13, 01:25 PM   #2
ThumperPup
Lead Lap
 
ThumperPup's Avatar
 
Join Date: Jan 2013
Location: Florida
Posts: 799
Default

hows it ride i mean does it rub at all with 2 people in the front can you cut the wheel all the way or does it start to rub after a bit ?
ThumperPup is offline   Reply With Quote
Old 08-18-13, 07:49 PM   #3
ChristianM
Driver School Candidate
Thread Starter
 
Join Date: May 2012
Location: Ontario
Posts: 20
Default

No rubbing with 2 people in the front. The only times i've rubbed so far was when i hit a bump on the highway at high speeds. Because of the amount of distance the stock suspension travels to absorb the impact, the fender just barely rubs the tires. I do plan on rolling the fenders next summer to get rid of this problem though. As far as rubbing when turning, can't say that i've had that problem as of yet.
ChristianM is offline   Reply With Quote
Old 08-18-13, 08:52 PM   #4
ThumperPup
Lead Lap
 
ThumperPup's Avatar
 
Join Date: Jan 2013
Location: Florida
Posts: 799
Default

i got a set of 20in blanke fwd offset high that im going to have drilled once the warranty is up on my car but that wont be for like another year

the rims are up in ohio
don't evne have the money right now to ship them lol so guess it works out
ThumperPup is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
20's on SC400??? czaredd The Tire Rack's Tires, Wheels & Brakes Forum 13 03-28-12 02:40 AM
First Time Pics DaXxJaPxX IS - 2nd Gen (2006-2013) 23 05-07-11 10:09 PM
98 LS Sittin on 20's FINALLY lexodude LS - 1st and 2nd Gen (1990-2000) 26 06-30-06 11:23 AM
Wazzup! First lady here......... LadyGS3 GS - 2nd Gen (1998-2005) 71 04-13-04 06:46 PM
Pics of Binnos on My Gs400 zxlr8 GS - 2nd Gen (1998-2005) 9 01-13-02 02:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -7. The time now is 06:55 PM.


Copyright © 2000-2016 Internet Brands, Inc. All Rights Reserved